Patch #28510

Show issue assignee gravatar in roadmap and version page

Added by Marius BALTEANU over 1 year ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Roadmap
Target version:4.1.0

Description

I'm trying to make the roadmap and version page more useful for the users. I believe that this module should be one of the most important modules from Redmine, but currently it does provide only some basic features or information (from my/our users point of view).

A first improvement that is quite small and easy to add is the issue assignee gravatar.

On mouse over the image, the assignee name is shown under the format ("Assignee: assignee name" - for eg: "Assignee: David Loper").

Some screenshots:

PS: After/if this patch is committed, we can use this new title format also for author/assignee avatars in the issue page instead of the one added in #26689.

0001-show-issue-assignee-on-roadmap.patch Magnifier (4.41 KB) Marius BALTEANU, 2018-04-09 13:03

roadmap.png (131 KB) Marius BALTEANU, 2018-04-09 13:07

version.png (83.1 KB) Marius BALTEANU, 2018-04-09 13:16

gantt-icons.png (7.47 KB) Go MAEDA, 2019-02-07 07:17

28510.patch Magnifier (4.8 KB) Takenori TAKAKI, 2019-05-05 18:37

version-gravatar-enabled@2x.png (27.7 KB) Go MAEDA, 2019-05-06 03:34

version-gravatar-disabled@2x.png (27.1 KB) Go MAEDA, 2019-05-06 03:34

assignee_first.png (91.9 KB) Marius BALTEANU, 2019-05-06 22:44

0001-Show-assignee-avatar-in-Roadmap-and-Version.patch Magnifier (3.79 KB) Marius BALTEANU, 2019-05-18 15:40

uneven-issues@2x.png (10.6 KB) Go MAEDA, 2019-05-20 17:09

0002-Add-issue-css_classes-to-issue-rows.patch Magnifier (1.8 KB) Marius BALTEANU, 2019-05-21 18:14

0001-Show-assignee-avatar-in-Roadmap-and-Version.patch Magnifier (5.04 KB) Marius BALTEANU, 2019-05-21 18:14


Related issues

Related to Redmine - Patch #31964: VersionsControllerTest#test_show randomly fails Closed
Duplicated by Redmine - Patch #31752: Show assigned people when displaying tickets which are re... Reopened

Associated revisions

Revision 18189
Added by Go MAEDA 5 months ago

Show assignee avatar in Roadmap and Version (#28510).

Patch by Marius BALTEANU.

Revision 18406
Added by Go MAEDA about 1 month ago

VersionsControllerTest#test_show randomly fails (#31964, #28510).

Patch by Yuichi HARADA.

History

#1 Updated by Bernhard Rohloff over 1 year ago

Marius BALTEANU wrote:

I'm trying to make the roadmap and version page more useful for the users. I believe that this module should be one of the most important modules from Redmine, but currently it does provide only some basic features or information (from my/our users point of view).

I totally agree with you that the Roadmap module is one of Redmine's most serious modules and there's a lot of 'untouched' potential in it. If you have any kind of concept/vision for it, it would be great if we could have a glance/discussion on it. Maybe in the forums or somewhere else.

...
A first improvement that is quite small and easy to add is the issue assignee gravatar.

I think it's a good improvement for the issues list. I personally would prefer to have the icon on the left side besides the issues name. On widescreen monitors the distance between the both sides of the table becomes rather huge and there's much empty space in between. Often this makes it hard for me to correlate the content on both sides with each other.

#2 Updated by Marius BALTEANU over 1 year ago

Bernhard Rohloff wrote:

... If you have any kind of concept/vision for it, it would be great if we could have a glance/discussion on it. Maybe in the forums or somewhere else.

Yes, I've something in mind, but I want to make a screen to discuss on it.

#3 Updated by Akipii Oga over 1 year ago

+1
I think that the feature of the roadmap should be improved further.
Because the feature of the roadmap is directly linked to the operation of agile development.
I think that it is better for Redmine to get closer to agile development.

#4 Updated by Bernhard Rohloff over 1 year ago

Marius BALTEANU wrote:

Yes, I've something in mind, but I want to make a screen to discuss on it.

Cool! I'm looking forward to see the results. :-)

#5 Updated by Go MAEDA 8 months ago

I think it is better to add an icon to the left side of the tracker name because gantt already shows gravatar icons like that.

Here is a screenshot of gantt. tiket.png is displayed when gravatar is disabled or no one is assigned to the issue.

#6 Updated by Mizuki ISHIKAWA 6 months ago

+1

#7 Updated by Takenori TAKAKI 6 months ago

+1
As Marius says, adding Gravatar will be a simple and useful UI improvement. I have always felt that I could confirm assigne on the version page.
As for placement, I agree with Mr. Maeda's suggestion.
I made a patch to display the avatar on the left side of the tracker name, and attache it.

#8 Updated by Go MAEDA 6 months ago

Takenori TAKAKI wrote:

I made a patch to display the avatar on the left side of the tracker name, and attache it.

Looks nice. Thanks.

Marius, what do you think about this patch?

[Gravatar enabled]
No avagar icon for issues without an assignee (Issue 1 and 12).

[Gravatar disabled]

#9 Updated by Marius BALTEANU 6 months ago

I think we should take more feedback from users because displaying the ticket image ('icon-issue') to all unassigned issues is not a relevant information from my point of view. I already know that inside a version, all entries are issues. In gantt, it makes a little bit more sense because there the content is mixed (projects, versions, issues). The same is in the activity page where the content is mixed and the icons are used to make a visual difference.

Also, thinking at the near future and gantt, when the users will have the possibility to select the columns (#27672), maybe it'll be better to remove the avatar from issue's subject.

If you really want to show the assignee first, I think I prefer to not have any icon for unassigned issues:

But again, this is just my opinion according to my tastes and how I understand that ticket image.

Regarding the proposed patch, I think we can slightly improve the code.

#10 Updated by Go MAEDA 6 months ago

Marius BALTEANU wrote:

If you really want to show the assignee first, I think I prefer to not have any icon for unassigned issues:

The design is also OK for me. I agree with your opinion that ticket icons don't provide any useful information in this context.

#11 Updated by Marius BALTEANU 5 months ago

Here is the updated patch that can be applied after #31391 is committed.

#12 Updated by Go MAEDA 5 months ago

Marius BALTEANU wrote:

Here is the updated patch that can be applied after #31391 is committed.

The patch works fine but I prefer the layout of assignee_first.png is better the layout of the latest patch because the start position of tracker names is not aligned with the patch applied.

#13 Updated by Takenori TAKAKI 5 months ago

To specify the style of the list element,
How about making the following small changes to the Mariu's patch?

diff --git a/app/views/versions/index.html.erb b/app/views/versions/index.html.erb
index 856ee69ea..4bd61b97b 100644
--- a/app/views/versions/index.html.erb
+++ b/app/views/versions/index.html.erb
@@ -30,7 +30,7 @@
         <% issues.each do |issue| -%>
           <tr class="issue hascontextmenu">
             <td class="checkbox"><%= check_box_tag 'ids[]', issue.id, false, :id => nil %></td>
-            <td class="subject"><%= assignee_avatar(issue.assigned_to, :size => 16, :class => 'icon-gravatar').html_safe + link_to_issue(issue, :project => (@project != issue.project)) %></td>
+            <td class="subject"><%= assignee_avatar(issue.assigned_to, :size => 16, :class => 'icon-gravatar').html_safe + content_tag('span', link_to_issue(issue, :project => (@project != issue.project))) %></td>
             <td class="buttons"><%= link_to_context_menu %></td>
           </tr>
         <% end -%>
diff --git a/app/views/versions/show.html.erb b/app/views/versions/show.html.erb
index 6092c9792..65b82fc1b 100644
--- a/app/views/versions/show.html.erb
+++ b/app/views/versions/show.html.erb
@@ -44,7 +44,7 @@
   <%- @issues.each do |issue| -%>
     <tr class="issue hascontextmenu">
       <td class="checkbox"><%= check_box_tag 'ids[]', issue.id, false, :id => nil %></td>
-      <td class="subject"><%= assignee_avatar(issue.assigned_to, :size => 16, :class => 'icon-gravatar').html_safe + link_to_issue(issue, :project => (@project != issue.project)) %></td>
+      <td class="subject"><%= assignee_avatar(issue.assigned_to, :size => 16, :class => 'icon-gravatar').html_safe + content_tag('span', link_to_issue(issue, :project => (@project != issue.project))) %></td>
       <td class="buttons"><%= link_to_context_menu %></td>
     </tr>
   <% end %>
diff --git a/public/stylesheets/application.css b/public/stylesheets/application.css
index 03fd81441..0e0115d43 100644
--- a/public/stylesheets/application.css
+++ b/public/stylesheets/application.css
@@ -587,6 +587,8 @@ div#roadmap .wiki h1 { font-size: 120%; }
 div#roadmap .wiki h2 { font-size: 110%; }
 div#roadmap h2, div#roadmap h3 { display: inline; padding-right: 0;}
 body.controller-versions.action-show div#roadmap .related-issues {width:70%;}
+body.avatars-on div#roadmap .related-issues td.subject img { position: absolute; }
+body.avatars-on div#roadmap .related-issues td.subject span { padding-left: 20px; display: inline-block; }

 div#version-summary { float:right; width:28%; margin-left: 16px; margin-bottom: 16px; background-color: #fff; }
 div#version-summary fieldset { margin-bottom: 1em; }

#14 Updated by Marius BALTEANU 5 months ago

Thanks Takenori for the patch.

What do you think if we render the assignee in its own cell?

#15 Updated by Takenori TAKAKI 5 months ago

Thanks Marius for new suggestion.

Marius BALTEANU wrote:

What do you think if we render the assignee in its own cell?

I think that the code is cleaner and easier to improve, If we render the assignee in its own cell.
Your patches( #28510#note-14 ) works fine in my environment.

#16 Updated by Go MAEDA 5 months ago

  • Assignee changed from Go MAEDA to Marius BALTEANU

The patch in #28510#note-14 looks nice. Thanks!

But 0002-Add-issue-css_classes-to-issue-rows.patch seems to implement another feature different from this issue. Gravatars are shown correctly, even without the patch. I think it is better to open a new issue to add CSS classes. What do you think?

#17 Updated by Marius BALTEANU 5 months ago

Go MAEDA wrote:

The patch in #28510#note-14 looks nice. Thanks!

But 0002-Add-issue-css_classes-to-issue-rows.patch seems to implement another feature different from this issue. Gravatars are shown correctly, even without the patch. I think it is better to open a new issue to add CSS classes. What do you think?

Agree. Let commit only the first patch which will fix also the error reported in #31391 and I'll open a new issue later with the second patch.

#18 Updated by Go MAEDA 5 months ago

  • Status changed from New to Resolved
  • Target version changed from Candidate for next major release to 4.1.0

Committed the patch. Thank you all for working on this feature.

Marius, could you open a new issue for the second patch?

#19 Updated by Go MAEDA 5 months ago

  • Status changed from Resolved to Closed
  • Assignee changed from Marius BALTEANU to Go MAEDA

Go MAEDA wrote:

Marius, could you open a new issue for the second patch?

I have confirmed #31424. Thanks.

#20 Updated by Marius BALTEANU 3 months ago

  • Duplicated by Patch #31752: Show assigned people when displaying tickets which are related to a specific versions added

#21 Updated by Go MAEDA about 1 month ago

  • Related to Patch #31964: VersionsControllerTest#test_show randomly fails added

#22 Updated by Go MAEDA about 1 month ago

  • Category changed from UI to Roadmap

Also available in: Atom PDF