Feature #5450

Move wiki page to other project

Added by Peter Schuster over 7 years ago. Updated about 3 years ago.

Status:ClosedStart date:2010-05-05
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Wiki
Target version:3.0.0
Resolution:Fixed

Description

I would like to move wiki pages between projects.
Just like it is possible for issues.

Would be cool to see this implemented in an upcoming release.


Related issues

Related to Redmine - Feature #5457: Move files and documets to another project New 2010-05-06
Related to Redmine - Defect #20356: Wiki gets destroyed after rename New
Duplicated by Redmine - Feature #7276: Easily move Wiki site between projects Closed 2011-01-11
Duplicates Redmine - Feature #1026: Add ability to move complete wiki from one project to ano... Closed 2008-04-09

Associated revisions

Revision 13643
Added by Jean-Philippe Lang about 3 years ago

Move wiki page to other project (#5450).

History

#1 Updated by Frederik Dannemare over 7 years ago

Peter Schuster wrote:

I would like to move wiki pages between projects.
Just like it is possible for issues.

Would be cool to see this implemented in an upcoming release.

I second that. Would be very useful IMO.

#2 Updated by Mike Stupalov over 7 years ago

+1

#3 Updated by Terence Mill over 7 years ago

+1

#4 Updated by Željko Trogrlić over 7 years ago

+1

#5 Updated by Terence Mill over 7 years ago

Is there a workaround at the moment?

#6 Updated by Željko Trogrlić over 7 years ago

Terence Mill wrote:

Is there a workaround at the moment?

I had to split project in two, so I copied whole project and deleted unnecessary pages from both projects.

#7 Updated by Terence Mill over 7 years ago

Željko Trogrlić wrote:

Terence Mill wrote:

Is there a workaround at the moment?

I had to split project in two, so I copied whole project and deleted unnecessary pages from both projects.

Hmm..i wanna move sites to existing project, so this aproach won't work.

#8 Updated by Artem Laskov over 7 years ago

+1

#9 Updated by Fardeen GHULAM almost 7 years ago

+ 1

#10 Updated by Terence Mill almost 7 years ago

This is a dupe of Issue #7276

#11 Updated by Ludovic Gasc almost 7 years ago

+1

#12 Updated by Thomas Harris almost 7 years ago

+1

#13 Updated by Kristian Lein-Mathisen almost 7 years ago

Apparently, you can move wiki pages if you have database access:

http://www.redmine.org/boards/2/topics/3003

Better back-up first though :)

#14 Updated by Thomas Zlika almost 7 years ago

+1

#15 Updated by Terence Mill over 6 years ago

+1

#16 Updated by David Parker over 6 years ago

+1

#17 Updated by Maxim Nikolaevich over 6 years ago

I want to describe how it will be useful.
Links should not contain project-id ex:
http://redmine.org/wiki/MyWikiPage
http://redmine.org/wiki/MyWikiPage2
so anyone who link to wiki page like

[[wikiPage]]
will link to page of any project (now it links to current project only)
at second need the button in the right up corner of wiki page (near buttons Edit Watch History) with name "move"
about permisson setting to show this button i can't suggest but probably enough permission for it is "Rename wiki pages" or "Manage wiki" (i dislike idea to do new permission checkmark for this action but probably you think so)
Thank you for your time.

#18 Updated by Terence Mill over 6 years ago

The approach of global name space for wiki pages, as done for issue is nice, but in the wiki context the unqiue ids are the wiki page name and this is quite good for restful urls also but not if you can't give same name twice for different wiki pages in different projects.
This same collission "problem" will occur very soon and often, let me show:

Ones Projkect always will have a page called

  • help
  • knowhow
  • installation
  • faq
  • about
    ...
    just some examples.

How will you carry for unqiue names and make clear to the second one giving the same name, thats he isn't allowed because there's someone already taken in a another project your never care about and never heard of.

You could completly change the unqiue id same as for issues with numbers, but i don't like that because names adresses far better and leave it easy as it.
Another approach ind the mid way- make the sites available on two adresses. On the project via well know wiki name as it, and a new url which is global and adresses the wiki page via and id, that is given automatically and should be shown in a upper corner for everybody to use and link it. This number maybe already exists in a technical way in db, and we only would need the second adressing shema, the view change to show the number. That will keep the well know adressing and make available another one,m that will persist even when wiki page project changes, done by a move page. Of course the projects adress will no longer work if you have moved the site, but you don't have to use it so far.

Two adressing shema for wiki pages example

1. redmine original adressing: http://redmine.org/MyProject/wiki/MyWikiPage
2. new additionly approach : http://redmine.org/MyProject/wiki/<MyWikiPageInternal_ID> e.g http://redmine.org/Myroject/wiki/7736
3. It would also work if you adress the site this way http://redmine.org/wiki/7736, which means you even don't have to know where the wiki site is managed at the moment, as long as you know the id. This behaviour is already well known from issues.

1. will be lost when move > dead end > 404
2. could be automtatically forwarded ( in case of move and renaming) by simply lookup in database for <MyWikiPageInternal_ID> and redirect to browser
3. will work (beyond moves and renaming) as long wiki site is not deleted

#19 Updated by Terence Mill over 6 years ago

Of course as wiki syntax, wiki sites in same projects should be linkable as it.

[[MyWIkiPageInSameProject]]
[[MyWIkiPageInSameProject|my wiki page in same project]]

as ist dhould be possible to links wiki pages in other projects via name and id

[[projectname MyWIkiPageInOtherProject]]
[[projectname MyWIkiPageInOtherProject|my wiki page in other project]]
[[7736]]

#20 Updated by André Bachmann over 6 years ago

+1

To fiddle around with the database is a workaround, but not a nice one...

#21 Updated by Tiago Franco over 6 years ago

+1

#22 Updated by Martin G about 6 years ago

+1

#23 Updated by Paul paul almost 6 years ago

+1

#24 Updated by Tomasz Sawicki almost 6 years ago

+1
Additional option for copying with child pages would be also nice...

#25 Updated by Thien Vuong over 5 years ago

+ 1

#26 Updated by Cassiano Monteiro over 5 years ago

+1!
It´s very common to start some wikipage that turns into a new project.

#27 Updated by Waleed Anbar over 5 years ago

+1

#28 Updated by Johann Gail over 5 years ago

In reply to Terence Mill #19:
At least a cross project link is already possible with the syntax [[project:title]]

#29 Updated by Terence Mill over 5 years ago

I think you missed my comment #18:

THis was targeted towards how wiki linking could also work for my new adressinh shema to make is easily possible to move wiki pages around like don for issues.
I know that you can cross ref wiki sites already, but that has nothing todo with moving. Moving can imply complete new hierarchy and rights for the site.

Johann Gail wrote:

In reply to Terence Mill #19:
At least a cross project link is already possible with the syntax [[project:title]]

#30 Updated by Doruk Fişek over 5 years ago

I second this feature too.

#32 Updated by Paul paul over 5 years ago

Is there a plugin to do that? AFAIK it's just an SQL query to update the project_id?

#33 Updated by Caille Rotie over 5 years ago

+1
You must also redirect existing links with the name of new project
[[title]] or [[project:title]] becomes [[new_project:title]]

#34 Updated by Kirill Kornyakov almost 5 years ago

+1

#35 Updated by Terence Mill almost 5 years ago

Paul paul wrote:

Is there a plugin to do that? AFAIK it's just an SQL query to update the project_id?

No, its not because wiki sites have absolute project specific url, so it would need an new model.
See my comments #5450#note-18

#36 Updated by Markus Pins over 4 years ago

+1

#37 Updated by Terence Mill over 4 years ago

i enhanced my original solution (see #5450#note-18 ). Form my view this solution is very good, as it solves the problem and stays compatible with current shema as copies big parts of the approach how its already done for issues.

Would be really great to see this feature in next version, as there is really a big commandment in community and a clear approach to do so - see the many votes here.

+1

#38 Updated by Gergely Nagy over 4 years ago

+1

(BTW, any idea on how votes are taken into account? maybe it would be nice to have a searchable Votes custom field?)

#39 Updated by K. Scott Tripp over 4 years ago

+1

As for registering votes, take a look at feature #1011

#40 Updated by Thomas Robbs over 4 years ago

+1 for this.

Would be useful if it were just added to the "rename" function - i.e. allow you to change the project association on that form.

Rename is useful to attach this to because it also allows you to setup forwarding.

also, +1 the +1 feature @ #1011

#41 Updated by D K over 4 years ago

+1

#42 Updated by Andreas Eberharter over 4 years ago

+1

#43 Updated by Hisham Said about 4 years ago

+1

#44 Updated by Pawel Orzechowski about 4 years ago

+1

#45 Updated by Martin Dumont about 4 years ago

+1

#46 Updated by Daniel Felix almost 4 years ago

Well, I've had the same issue. I just manipulated the corresponding database tables and moved the wiki pages to another Project. Just a small update. :-)

#47 Updated by Tiago Franco almost 4 years ago

+1

#48 Updated by Neimar Volpini almost 4 years ago

+1

#49 Updated by Maoke Jackson over 3 years ago

+1

#50 Updated by Pierrick Perret over 3 years ago

+2 !

#51 Updated by Rick Hunnicutt over 3 years ago

+1 (does +1 even help???)

#52 Updated by Kevin Palm over 3 years ago

+1

#53 Updated by Salvo Rapisarda over 3 years ago

+1

#54 Updated by Andrew vonderLuft over 3 years ago

+1

#55 Updated by Stefan Mischke over 3 years ago

+1

#56 Updated by asd asd about 3 years ago

+1

#57 Updated by Dietmar H about 3 years ago

+1

#58 Updated by Josef Reichardt about 3 years ago

+1

#60 Updated by Deoren Moor about 3 years ago

+1

So far we've been doing the following:

  1. Creating a new parent page outside of the "root", i.e., "Content that has been moved"
  2. Creating a new page in another project
  3. Cut/paste content from the old page
  4. Save the new page
  5. Root the old page to "Content that has been moved"
  6. Add a link from the old page to the new one to catch any links to that old page

Now if you visit the old wiki index page (and say you were using the {{child_pages}} macro there) the old page will no longer show in the list. It's crude/simple, but it worked when we recently consolidated our documentation from separate projects into one central documentation project.

#61 Updated by Jean-Philippe Lang about 3 years ago

  • Assignee set to Jean-Philippe Lang
  • Target version set to 3.0.0

#62 Updated by Jean-Philippe Lang about 3 years ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Feature added in r13643.

You can now move a wiki page to another project from the "Rename" form. When moving a page with child pages, child pages are moved too.

#63 Updated by Deoren Moor about 3 years ago

Jean-Philippe Lang wrote:

Feature added in r13643.

You can now move a wiki page to another project from the "Rename" form. When moving a page with child pages, child pages are moved too.

How will references to the old location work? Will a redirect be added which sends the user to the new project/page location? We're really looking forward to this feature!

#64 Updated by Jean-Philippe Lang about 3 years ago

Yes, this is exactly what happens when you move a page.

#65 Updated by Andrew vonderLuft about 3 years ago

any chance this could be merged into 2.6-stable branch? Thanks.

#66 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Defect #20356: Wiki gets destroyed after rename added

Also available in: Atom PDF