Feature #6154

Save issue as draft

Added by Martin Kande about 7 years ago. Updated over 3 years ago.

Status:ReopenedStart date:2010-08-17
Priority:LowDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

Please add possibility to save issue drafts for later submission.


Related issues

Duplicated by Redmine - Feature #12225: (Automatic) Draft Save Closed

History

#1 Updated by Holger Just about 7 years ago

This is a duplicate of #2910.

http://github.com/jbbarth/redmine_drafts is a plugin which could solve your issue.

#2 Updated by Holger Just about 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

#3 Updated by Martin Kande about 7 years ago

  • Status changed from Closed to Reopened

My idea is not about loosing unsaved data or "Warning on leaving edited issue page", so it is not a dublicate of #2910.

Idea description: Each user can save drafts for later submission. So, there should be more buttons: [submit], [save as draft]. Each user can save unlimited number of drafts, review and submit them later when they are ready. It should be very useful for brainstorming or idea projects.

That means one more column in issue table and small patch.

#4 Updated by Mischa The Evil almost 7 years ago

  • Resolution deleted (Duplicate)

Martin Kande wrote:

My idea is not about loosing unsaved data or "Warning on leaving edited issue page", so it is not a duplicate of #2910.

[...]

Clear! Thanks for taking care of giving feedback. I'll remove the issue-relation and the set resolution.

#5 Updated by Mike Kokhanov over 6 years ago

Martin Kande wrote:

Please add possibility to save issue drafts for later submission.

This would be a really good improvement.
Probably, issue-drafts should be visible for the issue-owners only. And there should be a flow for that kind of issues:
  • once issue saved as a draft, system should not track changes (versions, titles, assignees etc.)
  • once issue was published, it cannot become draft anymore.

#6 Updated by Terence Mill over 6 years ago

This modification can not be a one time thing per issue, because every change on the issue (aka edit) can have state change "draft" to "publish change" never the less it is a new or an existing (First change) issue the change applies on.
In worst case there can be unlimited number of drafts for changes the users never published and i case of a workflow there is an actual state the permission at least for the status chnage depends on. So on every "publish my draft" (must per saved at least per user per issue, or even more than one draft per user and issue - huh gets complicated) there could raise a exception that change i sno more allowed because the underlying issue state chnaged in the mean time and e.g the draft's status change is nor more allowed.

Mike Kokhanov wrote:

Martin Kande wrote:

Please add possibility to save issue drafts for later submission.

This would be a really good improvement.
Probably, issue-drafts should be visible for the issue-owners only. And there should be a flow for that kind of issues:
  • once issue saved as a draft, system should not track changes (versions, titles, assignees etc.)
  • once issue was published, it cannot become draft anymore.

#7 Updated by Daniel Felix almost 5 years ago

+1!

I like to have this in the next major release. This would be quite useful for developers which have to switch often between two or more tickets.

#8 Updated by MIchael Ermolenko over 4 years ago

I'm also waiting for this feature. While issue is in draft status no notifications should be sent.

#9 Updated by Romain Kassel almost 4 years ago

Any updates on this feature?

#10 Updated by sch uess over 3 years ago

+1
I'd also like to have this feature plus "automatically save a draft of things I do every 30 seconds" (e.g. as gmail does it)
It sometimes happens I edit a ticket and an external link opens in this tab so all my work is lost.

Also available in: Atom PDF