Feature #617

wiki: thoughts of WYSIWYG

Added by glen geisen over 10 years ago. Updated over 4 years ago.

Status:ReopenedStart date:2008-02-07
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Plugin Request
Target version:-
Resolution:

Description

Any thought of using WYSIWYG editing (FCKeditor), or embedding (or linking to) something like Mediawiki?

redmine-mediawiki.patch Magnifier - MediaWiki integration patch (9.53 KB) Brendan Ragan, 2008-05-27 09:09

error_log (9.05 KB) Tim Aleinikoff, 2009-05-22 14:23

logo.gif (677 Bytes) Hubert SABLONNIERE, 2010-04-03 02:09

screenshot_wiki.PNG (52.5 KB) Andrew Krasnoff, 2011-09-05 09:16


Related issues

Related to Redmine - Feature #8095: Allow overriding the default text formatting in each project New 2011-04-07
Related to Redmine - Feature #26968: Integrate Mediawiki's VisualEditor New
Duplicated by Redmine - Feature #5312: CKEditor Closed 2010-04-14
Duplicated by Redmine - Feature #9185: Wiki WYSIWYG editor Closed 2011-09-05

History

#1 Updated by Jean-Philippe Lang over 10 years ago

  • Status changed from New to Closed

FCKeditor seems to produce html code but Redmine wiki is not html based.
I don't know any WYSIWYG textile editor.

#2 Updated by rupert thurner about 10 years ago

  • Status changed from Closed to Reopened

#3 Updated by Auriel Manolson about 10 years ago

We were looking at integrating WYSIYM or WYmean type editors

see http://www.wymeditor.org or http://demo.wymeditor.org/demo.html

#4 Updated by Brendan Ragan about 10 years ago

Here's a patch for 0.7 that will add a MediaWiki tab to your project settings and integrate it into the issues pages.

You will also need to add:

`is_mediawiki` tinyint(1) NOT NULL default '0',
`mediawikiurl` varchar(255) NOT NULL default '',
`mediawikinamespace` varchar(255) NOT NULL default ''

To the projects table for this to work.

#5 Updated by Michael Mosburger almost 10 years ago

I took a look at the trac plugin. I think this might be good solution to start with, isn't it? Would be nice to have a wysiwyg for non-tech. users.

#6 Updated by Babar O'Cap almost 10 years ago

A good article on this topic http://blog.aisleten.com/2008/09/11/rails-textile-and-javascript-wysiwyg-roundup/
There is markItUp http://markitup.jaysalvat.com/home/
Look at the textile demo http://markitup.jaysalvat.com/examples/textile/
Maybe it's similar to Redmine AJAX preview feature.

#7 Updated by taras kornichuk over 9 years ago

Babar Le lapin wrote:

Maybe it's similar to Redmine AJAX preview feature.

Feature up.
Is it necesary to use textile editor? Maybe should add also HTML based edirot + WYSIWYG ?
Can someone anser me ?
Thanks.

#8 Updated by Cary Fitzhugh over 9 years ago

We're looking at redmine at work, and one desire is that all of the documentation could be written in the wiki.
Similar to Google Docs or something like that.
It appears that something like TinyMCE may work well.

Though - so I can help - what are the issues? Is textile the format that the page must be saved in?
I found this link: http://huddledmasses.org/greasemonkey-tinymce-editor/

But a bigger question is would it be a better idea to take the plunge, change the wiki rendering to be XHTML or something more standard, so you could just drop in something robust like TinyMCE?

Or maybe - is there a plugin we are currently using for the editing that can be extended to do the things that I need it to do?

I'm up for helping get this done.

#9 Updated by Cary Fitzhugh over 9 years ago

Another thing is that I'd like to get PDF download working for the wiki as well. So if someone decides to write up an RFQ or something in the wiki, we can export it to PDF to send to a client.

I'm up for helping with these things, just don't know where to start.

#11 Updated by rupert thurner over 9 years ago

Jean-Philippe Lang wrote:

FCKeditor seems to produce html code but Redmine wiki is not html based.
I don't know any WYSIWYG textile editor.

http://moinmo.in uses fckeditor, and converts the html back to wiki markup: http://hg.moinmo.in/moin/1.9/file/e86a7b66eb0e/MoinMoin/converter/text_html_text_moin_wiki.py.

#12 Updated by Peter Muusers-Meeuwsen over 9 years ago

Jean-Philippe Lang wrote:

FCKeditor seems to produce html code but Redmine wiki is not html based.
I don't know any WYSIWYG textile editor.

There seems to be some work in progress at http://mediawiki.fckeditor.net/

Can anyone tell if this is a possible addition for redmine? Unfortunately i'm not really into Ruby language (yet), so at the moment i'm not able to try implementing this myself (i'm happy to have been able to install ruby/redmine properly on my server :))

Once you know wiki-markup, it's pretty straightforward, but a lot of non-tech people can't make any sense of it and prefer a wysiwyg-approach. If a wysiwyg-solution is available for textile markup, i think it would be a lot easier to 'sell' this to the general audience, and make it a more pleasant and accessible workflow to actually participate in projects... In my experience, a lot of end-users are turned off by the Textile markup. It feels like teaching them HTML is easier than teaching them Textile, because the HTML tags have some sensible descriptions that they can relate to.

Anyway (let's not make this a rant about Textile... ;)).... Any thoughts of implementing fckeditor as they did at http://mediawiki.fckeditor.net/ ?

I'd be happy to help out where i can.
Cheers,
Peter

#13 Updated by Tim Aleinikoff over 9 years ago

Is it works on current versions? 0.8.3, 0.8.4, trunk ?
I try to install on 0.8.3 and receive errors ( log in attachment ).

#14 Updated by Jens Goldhammer over 9 years ago

What´s the status of this topic? Change to html? Keep textile?

I think, this topic is very important for the future of redmine. In my eyes, the wiki should be easy to use by the users and have a good export possibility. Extensions and macros should be easily added. Look at Confluence- They also integrate a good wysiwyg editor and convert it to their special syntax. They have a great pdf export.

What are your thoughts?
Thanks,
Jens

#15 Updated by Andy McMaster about 9 years ago

Hi,

Any update on this please? Just starting to use Redmine and very impressed but would like to move existing wiki use into a more project based format (i.e. Redmine). Currently using vqwiki.

However, a better editor would make some users lives easier...

Cheers

Andy

#16 Updated by Holger Winkelmann about 9 years ago

Cary Fitzhugh wrote:

Saw this as well -
http://developer.yahoo.com/yui/editor/

Hi, I was thinking of the YUI Editor as well because of the feature
I have seen in the flickr example http://developer.yahoo.com/yui/examples/editor/flickr_editor.html

Tgis way we can reference objects in redmine like Ticket, Changesets etc. by adding a button and make a
AJAX based search for the redmine objects (i.e. Ticket description) the Editor inserts the correct link
then.

#17 Updated by and l over 8 years ago

Update??

This is a really important feature, it would be great if the community could be informed of it's status.
Thanks for the great work.

#18 Updated by David Cullen over 8 years ago

Hi Folks,

Just started to use Redmine, I was wondering if there is any definative update on this issue? It seems that there is a patch for 0.7 from Brendan Ragan but no mention as to wether what other versions the patch will work for. I think a WYSIWYG editor for a Wiki is a must not just for the products apeal but for productivity alone.

Dave

#19 Updated by Tyler Mulligan over 8 years ago

I too would like to see this feature. It would certainly help the less tech savvy users contribute to the wiki

#20 Updated by and l over 8 years ago

It seems this feature is in demand by users but their aren't the coders to make it happen. Is there are bounty system in redmine or what's the process for getting tickets like these into coders priorities?

We use redmine for tech work but increasingly for non-tech projects as well. The current wiki prevents non-tech users from really getting active in the system.

This ticket is really an opportunity for redmine to expand it's reach and user base.

#21 Updated by Jeffrey Jones over 8 years ago

Textile was designed to be a "sane" version of HTML and be user friendly (i.e. usable by non-techies) however if that isn't enough then usually the best way to get something put into an open-source project is to roll up your sleeves or offer to pay someone to develop the code.

Maybe contact the core members directly or ask in the plugin forum since the plugin writers probably have a reasonably good knowledge of the code-based.

I am totally 100% against the idea of switching the wiki to XHTML markup without allowing users to stick with textile. Personally my experience of WYSIWYG editors like fck and TinyMCE is ...varied.

#22 Updated by Tyler Mulligan over 8 years ago

In my experience textile has been more confusing to users than anything. Especially if they are actually semi-technical users coming from wiki's that use more common syntax. Regardless of that point, I think a stronger WYSIWYG is needed.

I found a decent textile WYSIWYG editor which layers on top of Textile which can be a start to a transition to an easier time in the wiki for your average user: http://tore.darell.no/sanskrit/

#23 Updated by federico silva over 8 years ago

Jeffrey Jones wrote:

Textile was designed to be a "sane" version of HTML and be user friendly (i.e. usable by non-techies)

In my experience it is me or the other devs the ones who end up editing the documentation the users should provide in the wiki and the tickets
get full of format atrocities due to users pasting text which ends up evaluated as textile.

Several clients have asked us to use google pages (wiki template) and drop "that thing' which is a shame, really.

Jeffrey Jones wrote:

however if that isn't enough then usually the best way to get something put into an open-source project is to roll up your sleeves or offer to pay
someone to develop the code.

I am (very slowly) looking into it; so any news about anyone also doing it would be welcome.
I will post back when there is something worth showing.

Regargs, fede

#24 Updated by Eric Davis over 8 years ago

Other markup formats can be created as plugins using the wiki_format_provider API. For example there is a Markdown version.

#25 Updated by G N over 8 years ago

I have used several markup languages on wikis, bug trackers, blog and cms engines. All are fine, but when it comes down to productivity, nothing compares to wysiwyg, especially when content is written by people not so familiar with computers.

The Redmine feature set makes it a rather general project management platform that can be used for virtually any kind of project and not just software. I think that supporting a wysiwyg editor for wiki/issues/forums, which would store content as XHTML, would be a useful addition.

I was a big fan of the markdown and restructured text formats, until I tried to use TinyMCE in a django project a few months ago. I ain't going back... I just realized WYSIWYG editors have evolved. Also, WYMeditor seems like another great choice. It gives enough choice to the user, but not too much to cause any kind of trouble.

My $0.02

#26 Updated by Eric Davis over 8 years ago

  • Category set to Plugin Request

#27 Updated by Oshyan Greene over 8 years ago

I agree this is a very useful feature, and while I recognize the value of Textile and wiki syntax, I see no good reason why that can't be compatible with WYSIWYG. I'd be willing to help sponsor this. As someone else asked, is there any formal way to sponsor, vote for, or otherwise support development on an issue?

#28 Updated by Andreas Schnederle-Wagner over 8 years ago

As we would also need a WYSIWYG within Redmine (non-techs working on wiki) we also would be willing to sponsor the development of this feature - is there a way to do so?

We even thought about hiring an own coder to write this plugin for us - but if there is something in the pipe it would be nonsense to code the same plugin several times ... ;-)

Feedback anyone?

#29 Updated by Tyler Mulligan over 8 years ago

I too would be willing to sponsor the development of this.

I tried to hack in http://tore.darell.no/sanskrit/ and it was clear some of the work involved was over my head.

#30 Updated by rupert thurner over 8 years ago

George Notaras wrote:

The Redmine feature set makes it a rather general project management platform that can be used for virtually any kind of project and not just software. I think that supporting a wysiwyg editor for wiki/issues/forums, which would store content as XHTML, would be a useful addition.

I was a big fan of the markdown and restructured text formats, until I tried to use TinyMCE in a django project a few months ago. I ain't going back... I just realized WYSIWYG editors have evolved. Also, WYMeditor seems like another great choice. It gives enough choice to the user, but not too much to cause any kind of trouble.

how is a (readable) diff to the privious version done in this case?

#31 Updated by Tyler Mulligan over 8 years ago

how is a (readable) diff to the privious version done in this case?

With XHTML, just like any other code? I'm fairly certain it's possible to rig up something more visual, doing something like etherpad does with different background colors showing different editors.

#32 Updated by Hubert SABLONNIERE over 8 years ago

Hi,

I'm a developper and like most of you here, I think a WYSIWYG editor for the wiki is a must in order to get Redmine used by everyone in a project (including non technical users).

I've done some tries in a dirty way (using CKEditor) and I think I would be able to make a clean WYSIWYG plugin. I think I'll use tinyMCE which seems to be more suitable.

I'll try to start in this order:

  1. Modify views not to interpret contents as textile but as (X)HTML.
  2. Modify textareas as WYSIWYG editors. (the toolbar would only include already existing buttons)
  3. Implement new buttons in order to supply special links (tickets, revisions, wiki pages...)

I think I would be able to start in April.

Meanwhile, do not hesitate to comment.

#33 Updated by Hubert SABLONNIERE over 8 years ago

I forgot to mention stuffs about diffs. I think what Google Docs does or etherpad (thx Tyler) is a good start to study.

  1. Modify views not to interpret contents as textile but as (X)HTML.
  2. Modify textareas as WYSIWYG editors. (the toolbar would only include already existing buttons)
  3. Implement new buttons in order to supply special links (tickets, revisions, wiki pages...)
  1. Implement diff between versions

#34 Updated by Akihiro Ono over 8 years ago

I tried to implement Redmine CKEditor Plugin.
http://github.com/a-ono/redmine_ckeditor

CKEditor is added as a text formatting. (refs #2025)
There was a textile dependency in IssuesController#reply, so I thought it should be eliminated.

Contents are simply treated as HTML.
I hope it will serve as a reference.

#35 Updated by Eric Voisard over 8 years ago

Sure my non-tech colleagues would appreciate such a plugin, especially since CKEditor is already available in other webapps we're using.

But how do plain text email notifications look? Is html correctly removed? (because I guess resulting html is more complex than textile's one)

Eric

#36 Updated by Akihiro Ono over 8 years ago

Eric Voisard wrote:

But how do plain text email notifications look? Is html correctly removed? (because I guess resulting html is more complex than textile's one)

It is easy only to remove html tags.
But it seems you should select html email if you need readability.

#37 Updated by Vladimir Dzalbo over 8 years ago

Akihiro,

That is really a great plugin indeed! I like it a lot.. The only difficulty I am having now is with integrating pictures into the page. Normally you would want to put an attachment picture and put it into the issue comment within one update..

Anybody has any ideas on how to overcome this?

#38 Updated by Eric Voisard over 8 years ago

One more concern: how about the readability of an issue history. I mean with textile, text formating is limited to a small set of font sizes and a few of html tags, while with powerful editors such as CKEditor, users can give their updates the look they want.
Wouldn't it be much more difficult to find our way through the history of an issue, if "Updated by ...> lines get burried into a long and "multi-styled" html page (dependent on users skills in graphic arts)?...

I think such advanced editors would be cool for Wiki documentation but I'm not convinced about their usage in issue management. Well, one still can define some policy for editing issues (use default font/size, list of allowed tags).

Or can we make CKEditor providing different sets of functionalities and styles depending if it's used for wiki edition or issue updates?...

#39 Updated by Hubert SABLONNIERE over 8 years ago

I agree with Eric, I think having to much power in the WYSIWYG editor is a bad think. Maybe we should stick to features which are on the current toolbar and maybe add some preconfigured styles (by the admin). This way the project wikis can have a relative common look on every pages.

Concerning issue history, the formatting limits should be quiet the same as the ones currently in use.

About the picture integration, especially the one update thing, there's really some thinking to do...

#40 Updated by Eraldo Girardi over 8 years ago

Akihiro Ono wrote:

I tried to implement Redmine CKEditor Plugin.
http://github.com/a-ono/redmine_ckeditor

Great plugin! Works well on 0.9.3 but conflicts with subtask_plugin.
I have this trace:

ActionView::TemplateError (undefined method `issues_family_content' for #<ActionView::Base:0x672bb3>) on line #45 of vendor/plugins/redmine_subtasks/app/views/issues/_list.rhtml:
42:                          parents_on_first_lvl += [ first_parent ] unless parents_on_first_lvl.include?( first_parent)
43:                      end -%>
44:                 <% parents_on_first_lvl.each do |parent| -%>
45:                     <%= issues_family_content( parent, issues, query, emphasis_issues) %>
46:                 <% end -%>
47:       <% end -%>
48:     </tbody>

    vendor/plugins/redmine_subtasks/app/views/issues/_list.rhtml:45:in `_run_rhtml_vendor47plugins47redmine_subtasks47app47views47issues47_list46rhtml_locals_issues_list_object_query'
    vendor/plugins/redmine_subtasks/app/views/issues/_list.rhtml:44:in `each'
    vendor/plugins/redmine_subtasks/app/views/issues/_list.rhtml:44:in `_run_rhtml_vendor47plugins47redmine_subtasks47app47views47issues47_list46rhtml_locals_issues_list_object_query'
    vendor/plugins/redmine_subtasks/app/views/issues/_list.rhtml:1:in `_run_rhtml_vendor47plugins47redmine_subtasks47app47views47issues47_list46rhtml_locals_issues_list_object_query'
    vendor/plugins/redmine_subtasks/app/views/issues/index.rhtml:55:in `_run_rhtml_vendor47plugins47redmine_subtasks47app47views47issues47index46rhtml'
    app/controllers/issues_controller.rb:78:in `index'
    app/controllers/issues_controller.rb:77:in `index'
    file:/lib/jruby-rack-0.9.7.jar!/rack/adapter/rails.rb:36:in `serve_rails'
    file:/lib/jruby-rack-0.9.7.jar!/rack/adapter/rails.rb:41:in `call'
    file:/lib/jruby-rack-0.9.7.jar!/jruby/rack/rails.rb:149:in `call'
    file:/lib/jruby-rack-0.9.7.jar!/rack/handler/servlet.rb:19:in `call'
    :1

Rendered rescues/_trace (265.0ms)
Rendered rescues/_request_and_response (32.0ms)
Rendering rescues/layout (internal_server_error)

I tried to solve but without luck.. I'm not so ruby involved..
Do you have any suggestion?
Thanks!

#41 Updated by Hubert SABLONNIERE over 8 years ago

Little update:

I worked this weekend on my own WYSIWYG plugin using tinyMCE editor. Akihiro's project helped me a lot, thanks again!

I achieved a simple implementation of the editor the same way. Once installed, you've go to set TinyMCE as the text formatting in configuration.

FYI, I'll definitly spend the necessary amount of time to have something decent over the next 2 weeks. Be patient.

I'll create my github repo later this week with a small roadmap of the plugins I intend to develop (links, images...)

#42 Updated by Mingcai SHEN over 8 years ago

Hello,

Thanks for your work. But what do you think CKEditor+CKFinder?

Regards.
--

Hubert SABLONNIERE wrote:

Little update:

I worked this weekend on my own WYSIWYG plugin using tinyMCE editor. Akihiro's project helped me a lot, thanks again!

I achieved a simple implementation of the editor the same way. Once installed, you've go to set TinyMCE as the text formatting in configuration.

FYI, I'll definitly spend the necessary amount of time to have something decent over the next 2 weeks. Be patient.

I'll create my github repo later this week with a small roadmap of the plugins I intend to develop (links, images...)

#43 Updated by Eraldo Girardi over 8 years ago

You read my mind. CKEditor is really useful but there's a serious problem with the image upload. It has to be configured to use a certain page to upload images but how to do this in Redmine?
CKFinder can't help because it needs php or asp to work.
Do someone knows how to use an url to load an attachment to Redmine?
Please see this page: CKEditor File Browser Uploader

Mingcai SHEN wrote:

Hello,

Thanks for your work. But what do you think CKEditor+CKFinder?

Regards.
--

#44 Updated by Hubert SABLONNIERE over 8 years ago

Hi WYSIWYG fans,

My work on the plugin is in progress! I also found a little name for it : Tinymine. (Redmine wysiwyg tinyMCE was very long). Here's my roadmap:

v0.1.0
  • The WYSIWYG replace the classic editor
  • A button on the toolbar allows you to add a link to a wiki page
  • A button on the toolbar allows you to save your work without going back to the view

FYI: There's features are almost done, there's still some little bugs.

v0.2.0
  • A button on the toolbar for document links
  • A button on the toolbar for version links
  • A button on the toolbar for SCM files links
  • A button on the toolbar for the TOC
v0.3.0
  • Handling images with some kind of graphical browser/finder.
  • A button on the toolbar for code with syntax coloration
v0.4.0
  • Handling diffs
  • A task for automatic textile 2 html conversion a one or more projects

I'll publish my code on github once the v0.1.0 will be done.

Regards.

#45 Updated by Holger Winkelmann over 8 years ago

Hey Hubert,

Soounds great ;-) what about links to issues ?

#46 Updated by Hubert SABLONNIERE over 8 years ago

Holger Winkelmann wrote:

Hey Hubert,

Soounds great ;-) what about links to issues ?

Thanks Holger that's right, I took the list of the macro from the RedmineWikiFormatting page and completly forgot the first part about issues and changesets. I'll take care of it in v0.2.0

#47 Updated by Holger Winkelmann over 8 years ago

Hubert SABLONNIERE wrote:

Thanks Holger that's right, I took the list of the macro from the RedmineWikiFormatting page and completly forgot the first part about issues and changesets. I'll take care of it in v0.2.0

Good to know, this approach combined with the autocomplete controller can be a huge step for editing wiki content. But I talked about this already in comment 16 of this issue above. ;-)

#48 Updated by Benjamin FRAUD about 8 years ago

Hi Hubert.

Have you made any progress in your work? This feature sounds really interesting, and we're already using TinyMCE in another project. I was wondering though, will it be possible to catch a link when opening the file browser, so it can easily be copied in the main text field? In our current version of TinyMCE used with a PHP application, we open the file when clicking on it, it would be really cool if we could copy the link to the clipboard.

Thank you for your work. Have a nice one!

#49 Updated by Hubert SABLONNIERE about 8 years ago

Hi Benjamin,

I've been a little busy these times. I'll try to spend some time this week end.

Thanks again for your interest!

#50 Updated by Nicholas Kulikov about 8 years ago

+1 vote for WYSIWYG editor. Now we are using integration with CKEditor (http://github.com/a-ono/redmine_ckeditor) but it has weak support of links and file uploading. Moreover, some views (for example, Activity) do not display this markup correctly.

#51 Updated by Hubert SABLONNIERE about 8 years ago

Thanks for your remarks. I made some progress on link insertion. I'll try to push my code soon.

#52 Updated by Eraldo Girardi about 8 years ago

Great Hubert! Hope to see you soon with other good news!

#53 Updated by Benjamin FRAUD about 8 years ago

Hi!

I'm using CKEditor too (at least for the time being), and like Nicholas I'm facing some trouble with the links and uploading functions. Apparently the support of links to wiki pages inside Redmine is not handled, which force the user to use the adress bar to create a new wiki page. Would it be possible to add this functionnality? And I'm still looking for a way to catch a file link with some kind of browser through a webdav protocol, any chance someone might know something about that?

#54 Updated by Hubert SARRET about 8 years ago

Nice job Hubert ;)

#55 Updated by Alexander A almost 8 years ago

Nicholas Kulikov wrote:

+1 vote for WYSIWYG editor. Now we are using integration with CKEditor (http://github.com/a-ono/redmine_ckeditor) but it has weak support of links and file uploading. Moreover, some views (for example, Activity) do not display this markup correctly.

Nicholas, а каким образом решили вопрос с отображением в настройках плагина информации, которая в /plugins/redmine_ckeditor/config/locales/ru.yml
Я создал такой файл, пишу в нем кириллицей, но отображение некорректно. Пришлось пока транслитом и символами обходиться.

#56 Updated by Tony Rasskazov almost 8 years ago

CKeditor with redmine is a great feature. But now we can't switch on it, because we have many documents written in Wiki formatting (texttile) and when we switch to CKeditor all texttile documents becomes unformatted. Can CKeditor produce texttile code? Or what should I do, to stay rendering correct for old texttile documents, after switch on CKeditor?

#57 Updated by Nicholas Kulikov almost 8 years ago

Alexander A wrote:

Nicholas Kulikov wrote:

+1 vote for WYSIWYG editor. Now we are using integration with CKEditor (http://github.com/a-ono/redmine_ckeditor) but it has weak support of links and file uploading. Moreover, some views (for example, Activity) do not display this markup correctly.

Nicholas, а каким образом решили вопрос с отображением в настройках плагина информации, которая в /plugins/redmine_ckeditor/config/locales/ru.yml
Я создал такой файл, пишу в нем кириллицей, но отображение некорректно. Пришлось пока транслитом и символами обходиться.

Hey! :)
We do not use localization at all, so can't help you here.

Unfortunately current state of plugin is not very well for us. I've some unpredictable glitches when trying to make well formated text, so it takes a lot of time to do that work... Dunno, I think that we will back to textile formating.

#58 Updated by Peter Lawrence almost 8 years ago

I've tried the redmine_ckeditor, but like others here it is not that practical since you need to reformat all your wiki pages to a new format. What I requite is a wysiwyg editor for the textile format.
Ruby supports a method of converting textile to html and back again for example RedCloth3 which is used by Redmine.
So converting wiki textile pages to html for CKEditor and then back again shouldn't be a big issue.

I've tested this theory via a quick hack of the redmine code and it seems to work.
What I did was to replace the RedmineCkeditor::WikiFormatting code with the standard textile code. Then altered the redmine WikiController edit function to convert the wiki page to html from textile format to html, using...

@content.text=RedCloth3.new(@content.text).to_html

....and then on post I convert the contents back again using...
          htmlparser = HTMLToTextileParser.new
          htmlparser.feed(params[:content][:text])
          params[:content][:text]=htmlparser.to_textile

The HTMLToTextileParser came from http://jystewart.net/process/2007/11/converting-html-to-textile-with-ruby/

Any suggestions on the correct way of overloading WikiController edit and preview function via a plug-in interface would be useful.

#59 Updated by Paul paul almost 8 years ago

Any suggestions on the correct way of overloading WikiController edit and preview function via a plug-in interface would be useful.

Peter, do you have patches for the changes you've made?
Getting this to work properly (including the edit / preview functions) would be very useful for many of us.
Thank you.

#60 Updated by Peter Lawrence almost 8 years ago

For info on obtaining the code see the forum topic
[[http://www.redmine.org/boards/3/topics/17852]]
Note this is just a test application that should not be used outside a developmental environment.

#61 Updated by Ludovic Leroux over 7 years ago

Brendan Ragan wrote:

Here's a patch for 0.7 that will add a MediaWiki tab to your project settings and integrate it into the issues pages.

You will also need to add:
[...]

To the projects table for this to work.

Brendan,

We try to use the redmine-mediawiki.patch with the redmine 1.0.4 version.
It doesn't work and we have the error :

ActionView::TemplateError (Missing template projects/settings/_mediawiki.erb in view path app/views) on line #24 of app/views/common/_tabs.rhtml:

What is our problem ?

#62 Updated by Terence Mill over 7 years ago

Did anyone checkout if https://github.com/ebrahim/redmine_ckeditor can do that?

#63 Updated by Jim Nelson about 7 years ago

Eric Voisard wrote:

Sure my non-tech colleagues would appreciate such a plugin, especially since CKEditor is already available in other webapps we're using.

But how do plain text email notifications look? Is html correctly removed? (because I guess resulting html is more complex than textile's one)

Eric

We've been using CKEditor with Redmine for a bit now and plain text email notification is the one sticking point. Email notifications arrive with HTML formatting, even if Redmine is configured to send only plain text. The email is garbled, especially if it contains more than basic formatting. It doesn't appear the author plans on fixing this:

https://github.com/a-ono/redmine_ckeditor/issues/7

#64 Updated by Jim Nelson about 7 years ago

Rereading my comment, perhaps I wasn't clear about one point: it's not that the emails arrive as HTML mail, but rather as plain text with HTML formatting codes embedded throughout.

#65 Updated by Terence Mill about 7 years ago

The more bigger problem is that it is not possible to migrate to ckeditor and back because ckeditor doesn't use textile as internally markup.
If using html editor how can i enter an use wiki macros, esecially how will that work on a WYSIWYG editor, because marcos need a server roundtrip to render.

#66 Updated by Eric Voisard about 7 years ago

Jim Nelson wrote:

Rereading my comment, perhaps I wasn't clear about one point: it's not that the emails arrive as HTML mail, but rather as plain text with HTML formatting codes embedded throughout.

I see, content is just sent as is, with text/plain MIME type. They aren't MIME multipart emails with a text/html section as they should. Mmh...

Eric

#67 Updated by Andrew Krasnoff almost 7 years ago

At current point I saw the best WYSIWYG Wiki editor in the Atlassian Confluence product.
I've added screenshot with Atlassian wiki editor.
It very difficult to edit wiki tables in the current redmine wiki editor.
Atlassian wiki editor make it more simple.

This site use the same wiki editor: [[http://www.laits.utexas.edu/colaguides/content/wiki-site-editing]]
It based on http://www.tinymce.com

#68 Updated by Joe McLaughlin almost 7 years ago

_Here's a patch for 0.7 that will add a MediaWiki tab to your project settings and integrate it into the issues pages.

You will also need to add:

`is_mediawiki` tinyint(1) NOT NULL default '0',
`mediawikiurl` varchar(255) NOT NULL default '',
`mediawikinamespace` varchar(255) NOT NULL default ''

To the projects table for this to work._

This patch appears to be missing some critical files, such as the /app/views/projects/settings/_mediawiki.rhtml file. Does not seem to work with what was provided.

#69 Updated by Mischa The Evil almost 7 years ago

Joe McLaughlin wrote:

[...]

This patch appears to be missing some critical files, such as the /app/views/projects/settings/_mediawiki.rhtml file. Does not seem to work with what was provided.

For your information: that patch was created against Redmine 0.7.x, which is heavily outdated since we're currently on 1.2.x. That patch most likely won't work anymore and does probably not apply anymore also.

#70 Updated by Joe McLaughlin over 6 years ago

Any information you could give on an updated version of the patch??? I'm trying to basically reproduce it myself, but if something already exists...

#71 Updated by Joshua Lee over 5 years ago

Now we can use CKEditor+CKFinder.
[[http://www.redmine.org/plugins/ckfinder_for_redmine]]

#72 Updated by Dmitry K about 5 years ago

Joshua Lee wrote:

Now we can use CKEditor+CKFinder.
[[http://www.redmine.org/plugins/ckfinder_for_redmine]]

This solution is only for Windows. How about *nix (ubuntu)? Does anybody know, how to use it?

#73 Updated by Vito Marolda over 4 years ago

Is this feature request scheduled somewhere in the near future? (Nearly)-seamless copy/paste of text/images/tables to/from other documents can really boost productivity.

#74 Updated by Toshi MARUYAMA over 4 years ago

  • Related to Feature #5995: Text formatting can be dfferent base on project added

#75 Updated by Toshi MARUYAMA over 4 years ago

  • Related to Feature #8095: Allow overriding the default text formatting in each project added

#76 Updated by Toshi MARUYAMA over 4 years ago

  • Related to deleted (Feature #5995: Text formatting can be dfferent base on project)

#77 Updated by Toshi MARUYAMA 7 months ago

Also available in: Atom PDF