Project

General

Profile

Actions

Feature #10734

closed

Search on Open or Closed Issues

Added by Ewan Makepeace about 12 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Category:
Search engine
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

There is no way to limit my issue searches to either open or closed issues. Generally I know whether the issue I am looking for was either something that was requested a long time ago but not actioned, or done a long time ago, but there is no way to specify that.
Being able to just search open or closed issues would greatly accelerate my searching and I search a lot!


Files

search_open_tickets_only.patch (2.05 KB) search_open_tickets_only.patch Quick'n'dirty patch to filter out closed tickets Arne P., 2014-01-19 12:30

Related issues

Related to Redmine - Feature #3491: Filtering while searching for issuesClosed2009-06-13

Actions
Is duplicate of Redmine - Feature #992: Option to search open issues onlyClosedJean-Philippe Lang2008-04-04

Actions
Actions #1

Updated by Filou Centrinov about 11 years ago

Category: Search engine

Actions #2

Updated by Toshi MARUYAMA about 11 years ago

  • Category set to Search engine
Actions #3

Updated by Daniel Felix about 11 years ago

Added relation to #992 and #3491.

Actions #4

Updated by Arne P. over 10 years ago

Enclosed you find a quick'n'dirty patch for the search_controller that filters out all non-open issues from the result list.

It works pretty well, but it does not handle the number of search results. The result count is still the same as when searching for open and non-open issues, which might be confusing to users.

For a real solution this has to be done in the acts_as_searchable plugin.

This is for Version 1.4.7

Actions #5

Updated by Arnis Juraga over 10 years ago

Do You have plans to update and implement in any close future releases?

Actions #6

Updated by Jean-Philippe Lang over 9 years ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Target version set to 3.0.0
  • Resolution set to Fixed

Feature added in r13858, you can search in open issues only.

Actions #7

Updated by Jean-Philippe Lang over 9 years ago

  • Target version deleted (3.0.0)
  • Resolution changed from Fixed to Duplicate
Actions #8

Updated by Toshi MARUYAMA over 9 years ago

  • Related to deleted (Feature #992: Option to search open issues only)
Actions #9

Updated by Toshi MARUYAMA over 9 years ago

  • Is duplicate of Feature #992: Option to search open issues only added
Actions

Also available in: Atom PDF