Defect #13521

Gantt bars with start date and end date on the same day don't become red by overdue

Added by Toru Haraguchi about 5 years ago. Updated about 1 month ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Gantt
Target version:4.0.0
Resolution:Fixed Affected version:2.2.2

gantt-defect13521@2x.png (31.8 KB) Go MAEDA, 2017-11-27 09:18

fix_late_line.patch Magnifier (2.18 KB) Mizuki ISHIKAWA, 2017-12-15 01:35

gantt2.png (48.7 KB) Mizuki ISHIKAWA, 2017-12-15 01:36

gantt1.png (50.9 KB) Mizuki ISHIKAWA, 2017-12-15 01:36

Associated revisions

Revision 17294
Added by Go MAEDA about 1 month ago

Gantt bars with start date and end date on the same day don't become red by overdue (#13521).

Patch by Mizuki ISHIKAWA.

History

#1 Updated by Daniel Felix about 5 years ago

As I remember, they wont have any bar. Doesn't it? But in the tracker is a patch which fixes this behaviour.

I would try this, but I'm currently not at home (just on my smartphone).

You can find the patches on #12730 and it's related issues. Maybe you could give a quick feedback.

#2 Updated by Toru Haraguchi about 5 years ago

Daniel Felix wrote:

As I remember, they wont have any bar. Doesn't it?

DOES it.

> I would try this, but I'm currently not at home (just on my smartphone).

This issue is not so urgent and can be combined with another refine.

You can find the patches on #12730 and it's related issues. Maybe you could give a quick feedback.

The thread is too messy to figure out where is the solution for this issue.

#3 Updated by Go MAEDA 6 months ago

Confirmed.

#4 Updated by Mischa The Evil 6 months ago

FWIW: Pavel Shalagin wrote about it first (and even provided a patch for it) in #6276#note-17 about 7 years ago:

"Don't know if it can be considered as a problem, but the tasks with the same start_date and end_date seems not to be colored of progress and late correctly on the diagram. They all are just grey. [...]
I would suggest some changes (please see the patch). [...]"

#5 Updated by Mizuki ISHIKAWA 5 months ago

I confirmed that the patch written by Pavel Shalagin will solve the problem.
However, I think that the Gantt Bar should turn red when the start date is the same as the current date.

I added a few fixes and test code to the patch written by Pavel Shalagin at #6276#note-17.

change from change to

#6 Updated by Toshi MARUYAMA 5 months ago

  • Target version set to 4.1.0

#7 Updated by Go MAEDA about 1 month ago

  • Status changed from Confirmed to Closed
  • Assignee set to Go MAEDA
  • Target version changed from 4.1.0 to 4.0.0
  • Resolution set to Fixed

Committed. Thanks to everyone involved in fixing this issue.

#8 Updated by Go MAEDA about 1 month ago

  • Subject changed from Gantt bars with start_date and end_date on a same day do not become red by over due to Gantt bars with start date and end date on the same day don't become red by overdue

Also available in: Atom PDF