Project

General

Profile

Actions

Defect #13854

closed

Unable to raise new issue

Added by Jeremy Hanoun almost 11 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Email notifications
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

Hi,

when I try to create a new issue for a project, I get an Internal Error :

WebPage :
Internal error

An error occurred on the page you were trying to access.
If you continue to experience problems please contact your Redmine administrator for assistance.

If you are the Redmine administrator, check your log files for details about the error.

From the logs :
Started POST "/projects/dataprocessor-v2/issues" for 127.0.0.1 at 2013-04-23 16:24:26 +0200
Processing by IssuesController#create as HTML
Parameters: {"utf8"=>"✓", "authenticity_token"=>"3nLQOJlCHHWT+0LFJS701kjLntvcnbxDNGMVlTk2Y08=", "issue"=>{"is_private"=>"0", "tracker_id"=>"1", "subject"=>"test", "description"=>"test", "status_id"=>"1", "priority_id"=>"2", "assigned_to_id"=>"", "fixed_version_id"=>"1", "parent_issue_id"=>"", "start_date"=>"2013-04-23", "due_date"=>"", "estimated_hours"=>"", "done_ratio"=>"0"}, "commit"=>"Create", "project_id"=>"dataprocessor-v2"}
Current user: jhanoun (id=4)
Rendered mailer/_issue.text.erb (1.0ms)
Rendered mailer/issue_add.text.erb within layouts/mailer (3.0ms)
Rendered mailer/_issue.html.erb (5.0ms)
Rendered mailer/issue_add.html.erb within layouts/mailer (7.0ms)
Completed 500 Internal Server Error in 3185ms

NoMethodError (undefined method `error' for :smtp:Symbol):
app/models/mailer.rb:432:in `deliver_mail'
app/models/issue_observer.rb:20:in `after_create'
app/models/issue.rb:159:in `create_or_update'
app/controllers/issues_controller.rb:141:in `create'

=========================================================

FYI, I received the mail even if I see NoMethodError

Config : Win 7 Pro / 64 bits / MySQL 5.5 64bits
Environment:
Redmine version 2.3.0.stable
Ruby version 1.9.3 (i386-mingw32)
Rails version 3.2.13
Environment production
Database adapter Mysql2
Redmine plugins:
no plugin installed

Thanks


Related issues

Is duplicate of Redmine - Defect #5703: On SMTP failure, an internal error occurs and all changes to an issue are lostClosed2010-06-17

Actions
Actions

Also available in: Atom PDF