Project

General

Profile

Actions

Feature #20106

closed

Adding issue watchers to "Issues Visibility" permissions

Added by Emrah KAVUN over 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues permissions
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Currently, issues visibility options in "Roles & Permissions" determine if a user is allowed to see all issues, all non private issues, or issues created by, or assigned to the user.

Feature request:
  • Add an option to allow issues where the user is a watcher. This could be bundled with the last option, where the user either created the issue, is assigned to the issue or is a watcher on the issue.
Actions #1

Updated by Alexis Parent over 8 years ago

+1

Actions #2

Updated by Ezequiel Hernandez over 8 years ago

+1

Actions #3

Updated by Hang Xie over 8 years ago

Try my patch at Issue #8488

Actions #4

Updated by Toshi MARUYAMA about 8 years ago

  • Related to Feature #8488: Create an 'Involve' mechanism to private issues added
Actions #5

Updated by Toshi MARUYAMA about 8 years ago

  • Related to Feature #16845: Add permission rule to allow watchers can edit issues added
Actions #6

Updated by Go MAEDA about 8 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as duplicate of #14318. The patch attached to that issue suggests new option "Issues created by, assigned to, or watched by the user" to "Issues visibility".

Actions #7

Updated by Go MAEDA about 8 years ago

  • Is duplicate of Patch #14318: Watchers Alerted To Changes But Cannot See Issues (potentially) added
Actions #8

Updated by Toshi MARUYAMA about 8 years ago

  • Related to deleted (Feature #8488: Create an 'Involve' mechanism to private issues)
Actions #9

Updated by Toshi MARUYAMA about 8 years ago

  • Related to deleted (Feature #16845: Add permission rule to allow watchers can edit issues)
Actions #10

Updated by Jean-Philippe Lang almost 8 years ago

  • Is duplicate of deleted (Patch #14318: Watchers Alerted To Changes But Cannot See Issues (potentially))
Actions

Also available in: Atom PDF