Defect #21168

Cannot save project when associated with a parent project.

Added by Rupesh J about 2 years ago. Updated about 2 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Project settings
Target version:-
Resolution:Duplicate Affected version:3.1.0

Description

  • Create a Role "Project Update"
  • do not provide permission to "create project" or "create sub projects"
  • Provide him "Edit Project" permission
  • associate a user with this role to a project having a parent project.
  • Login as a user and edit the project.
  • Modify the description and save.
  • The save fails.

Environment:
Redmine version 3.1.1.stable
Ruby version 2.2.1-p85 (2015-02-26) [x86_64-linux]
Rails version 4.2.4
Environment production
Database adapter Mysql2
We are using 3.1.1, But may exists in other versions as well.

Attaching the patch for the correction.

0001-fix-for-sub-project-save-error.patch Magnifier (891 Bytes) Rupesh J, 2015-11-06 11:40


Related issues

Duplicates Redmine - Defect #20282: Error message when editing a child project without add pr... Closed

History

#1 Updated by budo kaiman about 2 years ago

Is this a duplicate of #20282?

#2 Updated by Rupesh J about 2 years ago

  • Status changed from New to Resolved

Thanks budo kaiman.!

#3 Updated by Jean-Philippe Lang about 2 years ago

  • Status changed from Resolved to Closed
  • Resolution set to Duplicate

#4 Updated by Toshi MARUYAMA about 2 years ago

  • Priority changed from Urgent to Normal

#5 Updated by Toshi MARUYAMA about 2 years ago

  • Duplicates Defect #20282: Error message when editing a child project without add project/subprojects permissions added

Also available in: Atom PDF