Defect #21766

CSV import does not keep the project it was clicked from

Added by Olivier Houdas over 4 years ago. Updated 6 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Importers
Target version:4.1.0
Resolution:Fixed Affected version:3.2.0

Description

When clicking the new Import link in the side bar menu of Issues, the project information seems to be lost.

There are several consequences:
  1. Clicking the sidebar links in one of the import steps has various consequences, from no action (custom queries) to Error 500 (Calendar, Gantt)
  2. When reaching the field mapping step, there is a project which is preselected, but not the one the import link was clicked from.

0002-Fix-CSV-import-does-not-keep-the-project-it-was-clic.patch Magnifier (5.39 KB) Marius BALTEANU, 2019-11-01 23:06

Associated revisions

Revision 19381
Added by Jean-Philippe Lang 6 months ago

CSV import does not keep the project it was clicked from (#21766).

Patch by Marius BALTEANU.

Revision 19387
Added by Jean-Philippe Lang 6 months ago

Merged r19381 to 4.1-stable (#21766).

History

#1 Updated by Olivier Houdas over 4 years ago

Sorry, for the Calendar and Gantt links, the error 500 is due to a plugin.

#2 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from New to Needs feedback

Did you solve problems?

#3 Updated by Olivier Houdas over 4 years ago

Well, not #2.
The fact that side-bar menus are not really relevant in the import page (since it is not set to any project) is just a note.

This is not a serious issue, but there is a reference to @import.project in the mapping page (views/mapping.html.erb) which returns a value, but we will never get the project we actually came from, because the link in the project\issues page is not project-dependent.

#4 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from Needs feedback to New

#5 Updated by Marius BALTEANU 7 months ago

  • Status changed from New to Confirmed

I confirm this behavior in the latest trunk.

#6 Updated by Marius BALTEANU 7 months ago

  • Assignee set to Marius BALTEANU

#7 Updated by Marius BALTEANU 7 months ago

  • Subject changed from CSV import does keep the project it was clicked from to CSV import does not keep the project it was clicked from

#8 Updated by Marius BALTEANU 7 months ago

Attached is a fix for this problem, it can be applied on top of #32196.

#9 Updated by Marius BALTEANU 7 months ago

Should we include this fix in 4.1.0?

#10 Updated by Go MAEDA 6 months ago

  • Target version changed from Candidate for next major release to 4.1.0

#11 Updated by Go MAEDA 6 months ago

Confirmed the issue. Since the change is small, I have set the target version to 4.1.0.

#12 Updated by Jean-Philippe Lang 6 months ago

  • Status changed from Confirmed to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Committed.

Also available in: Atom PDF