Project

General

Profile

Actions

Feature #2500

closed

configure custom fields as "required for status transition"

Added by Olivier Abad over 15 years ago. Updated over 11 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues workflow
Target version:
-
Start date:
2009-01-13
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

I would like to be able to configure custom fields as "required" but only for some issue statuses.

For example, in our workflow, we defined a status named "Livré", and a custom field named "Réf dossier livraison", and we would like this field to be filled when changing the ticket status to "Livré" but not before.


Files

dynamic-mandatory-issue-field.js (1.36 KB) dynamic-mandatory-issue-field.js Javascript for theme to check custom fields in transition. Sébastien Gripon, 2011-11-02 18:13

Related issues

Related to Redmine - Feature #8050: Mightful workflow field enhancement: visible, read only and mandatory Closed2011-04-03

Actions
Has duplicate Redmine - Feature #8005: Required fields depending on statusClosed2011-03-28

Actions
Has duplicate Redmine - Feature #9280: Required Custom field on StatusClosed2011-09-19

Actions
Is duplicate of Redmine - Feature #703: Configurable required fields per tracker/status/roleClosedJean-Philippe Lang2008-02-21

Actions
Actions #1

Updated by Hans Kazan about 15 years ago

+1

Actions #2

Updated by Steve Overton over 13 years ago

I believe this would be a major change to Redmine but it would take it to the next level. We are currently using ClearQuest (contractual) and Redmine and one of the few things (that matter to us) that ClearQuest has that Redmine does not is to have required fields per status.

+1

Actions #3

Updated by Torgrim Brochmann over 13 years ago

+1

Required per status for all fields, not just custom fields

Actions #4

Updated by Etienne Massip over 13 years ago

  • Category changed from Issues to Issues workflow
Actions #5

Updated by Terence Mill over 13 years ago

+1
This is very essential for use, but we already live this feature by process doc and this isn't very safe. A redmine enforced behavour would be much better.

Actions #6

Updated by Gilles DUGAST over 13 years ago

+1
Very essential feature! I'd like to see it very soon.

Actions #7

Updated by Fabrice MOUCHERE over 13 years ago

+1

Actions #8

Updated by Julio Blanco about 13 years ago

+1 Critical feature

Actions #9

Updated by Bruno Samora about 13 years ago

+1

Actions #10

Updated by Andrea Saccavini about 13 years ago

+1

Actions #11

Updated by Paulo Oliveira about 13 years ago

+1

Actions #12

Updated by Jason Waldrip about 13 years ago

+1

Actions #13

Updated by Clyde Goffe almost 13 years ago

+1

Actions #14

Updated by Gurvan Le Dromaguet almost 13 years ago

+1 Almost mandatory, key feature to have reliable information when >100 users

Actions #15

Updated by Sébastien Gripon over 12 years ago

+1

Actions #16

Updated by Daniel Moore over 12 years ago

Sébastien Gripon wrote:

+1

+1

Actions #17

Updated by Daniel Moore over 12 years ago

+1

Actions #18

Updated by Sébastien Gripon over 12 years ago

Note that in order to get this important feature, we have inserted javascript function that check some fields when changing the status. This is really easy to implement but should be built in redmine.

Actions #19

Updated by Gurvan Le Dromaguet over 12 years ago

Sébastien Gripon wrote:

Note that in order to get this important feature, we have inserted javascript function that check some fields when changing the status. This is really easy to implement but should be built in redmine.

Hi Sébastien,
In case your code is re-usable, any chance to share it with us ?

Actions #20

Updated by Sébastien Gripon over 12 years ago

The code was not really reusable because of many business specific rules. However, I attached a clean dirty version with no warranty! Not tested, with no support! Sorry but time is missing ;o)

Actions #21

Updated by Gurvan Le Dromaguet over 12 years ago

Thanks Sebastien,
I should have time to take a look at it and test it on my generic environment tomorrow.
will come back thereafter :)

Actions #22

Updated by Terence Mill over 12 years ago

This is covered by #8050

Actions #23

Updated by Jean-Philippe Lang almost 12 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Implemented as part of #703.

Actions

Also available in: Atom PDF