Project

General

Profile

Actions

Feature #2624

closed

Repository statistics should honour user-mapping

Added by Gerrit Kaiser over 15 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
SCM
Target version:
-
Start date:
2009-01-30
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

at the moment the Repository statistics graphs show different stats for two repository-users that were mapped onto one Redmine-User. It is probably more useful to only show one entry in that case.


Files

merge_users_stats.diff (1.82 KB) merge_users_stats.diff João Machado, 2010-03-14 01:25

Related issues

Related to Redmine - Defect #13487: Honor committer => user mapping in repository statisticsClosedJean-Baptiste Barth

Actions
Has duplicate Redmine - Feature #3826: It would be good if Redmine showed repository statistics on mapped names.Closed2009-09-05

Actions
Has duplicate Redmine - Feature #9505: Committers name (if mapped to redmine user) show up on statisticsClosed2011-11-01

Actions
Has duplicate Redmine - Defect #15994: Repository view does not obfuscate author emailsClosed

Actions
Actions #1

Updated by Damien Couderc over 15 years ago

+1

The stats are pretty useless without that ...

Actions #2

Updated by Thorbjørn Hermansen about 15 years ago

++
I found this too; plase fix? And thank you for all the work done on this project :-)

Actions #3

Updated by Derek Montgomery about 15 years ago

Just saw the mapping options and my first check was to see how it affected graphs... so, +1 here too.
Thanks JP!!

Actions #4

Updated by Marlin Forbes about 15 years ago

And another +1 here too. I have 4 entries for myself from a repository I'm using because of accessing it from different hosts. The display only shows my name, not email address. So stats show me as 4 indistinguishable Marlin Forbes's. :)

Actions #5

Updated by Derek Montgomery about 15 years ago

Please?

Actions #6

Updated by Anonymous about 15 years ago

+1

Actions #7

Updated by Guillaume Ayoub over 14 years ago

It seems to be a duplicate of #2065. A patch has been submitted, tests welcome.

Actions #8

Updated by João Machado about 14 years ago

This ticket is not a duplicate of #2065, but using your patch from that ticket (#2065) and altering some code, i was able to
correct this ticket's issue ;)

tested in r3517 .

Marked as resolved (is it ok? ) ;)

Actions #9

Updated by Greg Mefford almost 14 years ago

+1 (I'll try to take a look at this patch tonight if I have time)

Actions #10

Updated by Damien Couderc over 13 years ago

Hi all,
I'm using 1.0.2 and I'm unable to see anything fixed here.
Excuse me if I'm wrong but maybe the issue shouldn't be marked resolved until the fix is really in the SCM.

Actions #11

Updated by Mischa The Evil over 13 years ago

  • Status changed from Resolved to New

Damien Couderc wrote:

I'm using 1.0.2 and I'm unable to see anything fixed here.

Excuse me if I'm wrong but maybe the issue shouldn't be marked resolved until the fix is really in the SCM.

You are right. Thanks for mentioning it!

Actions #12

Updated by Damien Couderc over 13 years ago

The diff provided by João Machado seems to be trivial. Any reason why it did not go into trunk ?

Actions #13

Updated by Daniel Macedo over 13 years ago

Damien Couderc wrote:

The diff provided by João Machado seems to be trivial. Any reason why it did not go into trunk ?

+1

Actions #14

Updated by Ludovic Gasc over 13 years ago

+1

Actions #15

Updated by Dan Clarke over 12 years ago

+1

Actions #16

Updated by Federico Bonelli over 11 years ago

28 jan 2013 here, did it get patched? I'm still experiencing this same behavior

Actions #17

Updated by Anonymous about 11 years ago

I created issue #13487 with an alternate patch for this. I would appreciate if either the patch here or mine could be merged.

Actions #18

Updated by Dipan Mehta about 11 years ago

+1. Very important to have this sorted.

Actions #19

Updated by Toshi MARUYAMA over 10 years ago

  • Has duplicate Defect #15994: Repository view does not obfuscate author emails added
Actions #20

Updated by Jean-Baptiste Barth almost 10 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I close this one as the discussion continues in #13487.

Actions

Also available in: Atom PDF