Patch #26662

Add border around issue history to prevent accidental deletion of an issue

Added by Go MAEDA over 1 year ago. Updated 6 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:UI
Target version:4.0.0

Description

In my observation, some users accidentally delete an issue trying to delete last note. The misoperation is probably caused by the current UI of Redmine. The delete button at the bottom of IssuesController#show page looks as if it is a button for delete the last note, but actually it is a button to deletes the issue.

Such misoperation can be prevented by making a slight change to UI. Please see the following screenshots. By adding border around issue history, it becomes clear that the button is not a button for deleting the note. Our company have succeeded in significantly reducing accidents that our customers mistakenly delete an issue by implementing the change.

The patch was extracted from farend basic theme.

Before:

After:

border-around-history-before@2x.png (40 KB) Go MAEDA, 2017-08-11 06:17

border-around-history-after@2x.png (38.1 KB) Go MAEDA, 2017-08-11 06:17

add_border_around_issue_history.diff Magnifier - patch (666 Bytes) Go MAEDA, 2017-08-11 06:18


Related issues

Duplicated by Redmine - Feature #28514: issue delete button confusion Closed

Associated revisions

Revision 17366
Added by Go MAEDA 6 months ago

Add a border around issue history to prevent accidental deletion of an issue (#26662).

Patch by Go MAEDA.

History

#1 Updated by Go MAEDA about 1 year ago

  • Target version set to 4.1.0

I am sure that this small UI change would be of benefit to most users.
setting target version to 4.1.0.

#2 Updated by Marius BALTEANU 7 months ago

#3 Updated by Yuuki NARA 6 months ago

+1

I agree with this change.

It seems that, this UI is easy to cause accident of data deletion.
Especially for those who are unfamilar with Redmine operation and those who use different systems.

This change modify only CSS.
I think that possibility of defect due to this change is low.

Notes.
Several themes UI have no effect by this modification.
Several themes have already been applied this modification.

#4 Updated by Go MAEDA 6 months ago

  • Assignee set to Go MAEDA
  • Target version changed from 4.1.0 to 4.0.0

Committed.

#5 Updated by Go MAEDA 6 months ago

  • Status changed from New to Closed

Also available in: Atom PDF