Project

General

Profile

Actions

Feature #29470

open

Possibility to mark tracker as "Subtask only"

Added by Kamil . over 5 years ago. Updated 4 months ago.

Status:
Reopened
Priority:
Normal
Category:
Issues
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

There are some types of trackers (like "Story Blocker" or "Subtask") which makes sense only when it is a subtask.
Please provide additional checkbox "Subtask only" while creating new tracker.
When checked, new item can be created only as a Subtask


Files

tracker_subtask.png (52.6 KB) tracker_subtask.png Marius BĂLTEANU, 2019-06-30 23:36
workflow.png (238 KB) workflow.png Marius BĂLTEANU, 2019-06-30 23:38
new_issue.png (87.5 KB) new_issue.png Marius BĂLTEANU, 2019-06-30 23:43
0001-Option-to-set-a-tracker-only-as-subtask.patch (20.1 KB) 0001-Option-to-set-a-tracker-only-as-subtask.patch Marius BĂLTEANU, 2020-04-05 13:26
Option-to-set-a-tracker-only-as-subtask-r20091.patch (17.9 KB) Option-to-set-a-tracker-only-as-subtask-r20091.patch Go MAEDA, 2020-09-28 10:12

Related issues

Related to Redmine - Feature #27988: Option to configure which trackers can be set as subtasks for each trackerNewMarius BĂLTEANU

Actions
Actions #1

Updated by Marius BĂLTEANU over 5 years ago

  • Is duplicate of Feature #27988: Option to configure which trackers can be set as subtasks for each tracker added
Actions #2

Updated by Marius BĂLTEANU over 5 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Please see the related issue.

Actions #3

Updated by Kamil . over 5 years ago

My request is related to, but it is not the same as Feature #27988.
In my feature the idea is that some trackers must not be top-level trackers

Actions #4

Updated by Marius BĂLTEANU over 5 years ago

  • Resolution changed from Duplicate to Invalid

Kamil . wrote:

My request is related to, but it is not the same as Feature #27988.
In my feature the idea is that some trackers must not be top-level trackers

Kamil, I've closed this ticket as "Duplicate" because you can obtain the same behaviour as you requested in this issue using the patch from #27988.

Thinking now better, you can obtain this behaviour also with the current Redmine versions by making the "Parent task" field mandatory for all roles in the Workflow page (I know that is not a checkbox, but the result is the same). I'm changing the reason from "Duplicate" to "Invalid", please let me know if you consider that something is missing and I'll reopen it.

Actions #5

Updated by Marius BĂLTEANU over 5 years ago

  • Is duplicate of deleted (Feature #27988: Option to configure which trackers can be set as subtasks for each tracker)
Actions #6

Updated by Marius BĂLTEANU over 5 years ago

  • Related to Feature #27988: Option to configure which trackers can be set as subtasks for each tracker added
Actions #7

Updated by Kamil . over 5 years ago

Marius, why to complicate is so much?
Do you consider your solution as good UX?

Actions #8

Updated by Marius BĂLTEANU over 5 years ago

Kamil . wrote:

Marius, why to complicate is so much?
Do you consider your solution as good UX?

Do you refer at the solution with setting the parent task mandatory?

Actions #9

Updated by Kamil . over 5 years ago

Yes, specifically:
1) Knowing that you have to go to Workflow
2) Field Permissions
3) Select Role "ALL"
4) Select Tracker
5) Click Edit
6) Find "Parent task row"
7) Click and select value "Required" in each Issue status
8) Click save

Actions #10

Updated by Kamil . over 5 years ago

So my point is that your version is not user friendly and doesn't have user intention in mind.
I think that every tool should strive to have better UX, therefore I created this issue

Actions #11

Updated by Marius BĂLTEANU over 5 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (Invalid)

Is not my version, is the current implementation from Redmine which is more flexible than having only a checkbox in the Tracker page.

IMHO, current implementation, plus the feature from #27988 covers this feature request, but I'll reopen this ticket to get more feedback.

Actions #12

Updated by Kamil . over 5 years ago

Ok, thank you

Actions #13

Updated by Marius BĂLTEANU over 4 years ago

  • Assignee set to Marius BĂLTEANU
  • Target version set to Candidate for next major release
Actions #14

Updated by Marius BĂLTEANU over 4 years ago

Attached a patch that adds the possibility to mark a tracker as "Subtask only":

In the workflow, if the user edits a a tracker or multiple trackers which are "Subtask only", the field is marked as mandatory and the option "Required" is not available. If the user edits mixed trackers, the field behaves normally.

The field "Parent task" is mandatory when user tries to create an issue with tracker type "Subtask only":

Actions #15

Updated by Marius BĂLTEANU over 4 years ago

  • File deleted (0001-Option-to-set-a-tracker-only-as-subtask.patch)
Actions #16

Updated by Marius BĂLTEANU over 4 years ago

  • File 0001-Option-to-set-a-tracker-only-as-subtask.patch added
  • Assignee set to Jean-Philippe Lang
  • Target version changed from Candidate for next major release to 4.2.0

I've updated the patch to apply cleanly on the current trunk and I'm assigning this to 4.2.0 in order to work on this as early as we can.

Actions #17

Updated by Marius BĂLTEANU almost 4 years ago

  • File deleted (0001-Option-to-set-a-tracker-only-as-subtask.patch)
Actions #19

Updated by ashraf alzyoud over 3 years ago

Marius BALTEANU wrote:

Updated again to apply cleanly.

its very important i have 30 tracker in same project
our users need who main tracker and sub
thx for u for this idea
this patch available in 4.1??

Actions #20

Updated by Go MAEDA over 3 years ago

  • File Option-to-set-a-tracker-only-as-subtask-r20091.patch added

Updated the patch for the latest trunk (r20091).

Actions #21

Updated by Go MAEDA over 3 years ago

  • File deleted (Option-to-set-a-tracker-only-as-subtask-r20091.patch)
Actions #23

Updated by ashraf alzyoud over 3 years ago

Is there a possibility to hide the subtask trackers when in added newIssue?? and its appear only when im added subtask??

Actions #24

Updated by Marius BĂLTEANU almost 3 years ago

  • Target version changed from 4.2.0 to 5.0.0
Actions #25

Updated by Marius BĂLTEANU almost 3 years ago

Moved this to 5.0.0 because the changes are quite big.

Actions #26

Updated by Marius BĂLTEANU almost 2 years ago

  • Target version changed from 5.0.0 to Candidate for next major release
Actions #27

Updated by Alessandro Zucchi over 1 year ago

Any update ?
tnx
Alessandro

Actions #28

Updated by ashraf alzyoud 4 months ago

any update??

Actions

Also available in: Atom PDF