Feature #30118

Ruby 2.6 support

Added by Go MAEDA 6 months ago. Updated 4 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Ruby support
Target version:4.0.1
Resolution:Fixed

Description

Ruby 2.6 is going to be released on 2018-12-25.
https://bugs.ruby-lang.org/projects/ruby-trunk/roadmap#2.6


Related issues

Related to Redmine - Patch #30241: Update nokogiri gem (~> 1.10.0) Closed
Related to Redmine - Patch #30420: Update pg gem (~> 1.1.4) Closed

Associated revisions

Revision 17696
Added by Go MAEDA 6 months ago

Don't explicitly install csv gem in Ruby 2.6 (#30118).

Redmine installs csv gem since r17245 as a workaround for a bug of csv 1.0.0 which is bundled with Ruby 2.5 (see #28112). But in Ruby 2.6, installing the gem is not necessary because the bundled csv gem was updated to 3.0.

Revision 17706
Added by Go MAEDA 6 months ago

Ruby 2.6: Don't explicitly install rdoc gem (#30118).

Revision 17820
Added by Jean-Philippe Lang 4 months ago

Merged r17706 to 4.0-stable (#30118).

History

#1 Updated by Go MAEDA 6 months ago

The current trunk r17686 passed tests (but I skipped LDAP and rmagick tests) in ruby 2.6.0preview2.

#2 Updated by Marius BALTEANU 6 months ago

Go MAEDA wrote:

The current trunk r17686 passed tests (but I skipped LDAP and rmagick tests) in ruby 2.6.0preview2.

I made a branch on the GitLab CI to track the test results until Ruby 2.6 is released.

#3 Updated by Jean-Philippe Lang 6 months ago

ruby2.6-rc1 is added to the CI server: http://www.redmine.org/builds

#4 Updated by Go MAEDA 6 months ago

  • Target version changed from Candidate for next major release to 4.0.1

I think we can support Ruby 2.6 in Redmine 4.0.1.

#5 Updated by Go MAEDA 5 months ago

  • Assignee set to Jean-Philippe Lang

All tests passed with Ruby 2.6.0p0 on my environment.

I think we can close this issue if Ruby 2.6 on the CI server is updated from 2.6.0preview2 to 2.6.0 and r17706 is merged to 4.0-stable.

#6 Updated by Go MAEDA 5 months ago

  • Related to Patch #30241: Update nokogiri gem (~> 1.10.0) added

#7 Updated by Go MAEDA 5 months ago

#8 Updated by Go MAEDA 5 months ago

#9 Updated by Go MAEDA 4 months ago

#10 Updated by Jean-Philippe Lang 4 months ago

  • Status changed from New to Closed
  • Resolution set to Fixed

Also available in: Atom PDF