Patch #30241

Update nokogiri gem (~> 1.10.0)

Added by Pavel Rosický about 1 month ago. Updated 13 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Gems support
Target version:4.0.1

Description

passed all tests

Gemfile.patch Magnifier (416 Bytes) Pavel Rosický, 2018-12-17 23:42


Related issues

Related to Redmine - Feature #30118: Ruby 2.6 support Closed
Related to Redmine - Feature #30356: Drop Ruby 2.2 support Closed

Associated revisions

Revision 17769
Added by Go MAEDA about 1 month ago

Update nokogiri gem (~> 1.9.0) (#30241).

Patch by Pavel Rosický.

Revision 17770
Added by Go MAEDA about 1 month ago

Merged r17769 from trunk to 4.0-stable (#30241).

Revision 17777
Added by Go MAEDA 13 days ago

Update nokogiri gem (~> 1.10.0) (#30241).

Patch by Pavel Rosický.

Revision 17778
Added by Go MAEDA 13 days ago

Use nokogiri 1.9 for Ruby 2.2 (#30241).

Revision 17779
Added by Go MAEDA 13 days ago

Merged r17777 and r17778 from trunk to 4.0-stable (#30241).

History

#2 Updated by Go MAEDA about 1 month ago

  • Tracker changed from Defect to Patch
  • Target version set to 4.0.1

Thank you for reporting that nokogiri 1.9.0 has been released. I am setting the target version to 4.0.1.

#3 Updated by Go MAEDA about 1 month ago

  • Target version changed from 4.0.1 to 3.4.8

#4 Updated by Go MAEDA about 1 month ago

  • Status changed from New to Resolved

#5 Updated by Go MAEDA about 1 month ago

  • Status changed from Resolved to Closed
  • Assignee set to Go MAEDA
  • Target version changed from 3.4.8 to 4.0.1

Committed. Thanks.

#6 Updated by Pavel Rosický 14 days ago

  • Status changed from Closed to Reopened

Go MAEDA -> FYI Nokogiri 1.10.0 has been released on 2019-01-04

this version includes Ruby 2.6 support on Windows #30118

#7 Updated by Go MAEDA 13 days ago

#8 Updated by Go MAEDA 13 days ago

#9 Updated by Go MAEDA 13 days ago

  • Subject changed from Update nokogiri gem (~> 1.9.0) to Update nokogiri gem (~> 1.10.0)

Nokogiri requires Ruby >= 2.3.0 but Redmine 4.0.0 officially supports Ruby 2.2.2. I have opened #30356 to drop support for Ruby 2.2.

$ bundle update
 .
 .
 .
Bundler could not find compatible versions for gem "ruby":
  In Gemfile:
    ruby

    nokogiri (~> 1.10.0) was resolved to 1.10.0, which depends on
      ruby (>= 2.3.0)

#10 Updated by Go MAEDA 13 days ago

  • Status changed from Reopened to Closed

Committed.
Uses Nokogiri 1.9 for Ruby 2.2, 1.10 for Ruby >=2.3.

Also available in: Atom PDF