Project

General

Profile

Actions

Defect #30257

closed

include/child_pages macro documentation typo

Added by Guillermo ML about 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Website (redmine.org)
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

At the Textile formatting wiki page it says that the syntax for include macro is:

!{{include(Foo)}}

but in our 3.4.4.stable server (or www.redmine.org) it seems that the first character "!" is wrong, without it works fine.

Same with child_pages macro:

!{{child_pages}}

without the "!" mark works fine.

see example


Related issues

Related to Redmine - Defect #19002: Typos in descriptions of buildin macros (seen through {{macro_list}} output)ClosedJean-Philippe Lang

Actions
Actions #1

Updated by Bernhard Rohloff about 5 years ago

That's because in the documentation the macros description in the wiki is shown by the {{macro_list}} macro and the syntax of the child_pages macro has changed since 2014.
It is perhaps a better idea to create the documentation of the macros by hand.

Actions #2

Updated by Go MAEDA over 4 years ago

  • Category changed from Documentation to Website (redmine.org)
  • Status changed from New to Closed
  • Resolution set to Duplicate

This is due to a bug of {{macro_list}} macro fixed in Redmine 2.6.3 (#19381). The website will be fixed when redmine.org is updated to the latest version.

I am closing this issue as a duplicate of #19002.

Actions #3

Updated by Go MAEDA over 4 years ago

  • Related to Defect #19002: Typos in descriptions of buildin macros (seen through {{macro_list}} output) added
Actions

Also available in: Atom PDF