Project

General

Profile

Actions

Defect #30949

closed

Roadmap shows 100%, but one of its tasks is still set to 90%

Added by Particip IT over 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Category:
Roadmap
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

I am using Redmine for controlling the development of an application inside the company I work for. I am just about to close the last release and realised that, even though one of the issues included in this version is still at 90%, the roadmap is showing me that the version is completed.

See screenshots for more details.

This is the information about our Redmine Installation:

Environment:
  Redmine version                3.4.8.stable
  Ruby version                   2.3.3-p222 (2016-11-21) [x86_64-linux-gnu]
  Rails version                  4.2.11
  Environment                    production
  Database adapter               Mysql2
SCM:
  Git                            2.11.0
  Filesystem                     
Redmine plugins:
  a_common_libs                  2.4.7
  easy_gantt                     1.10
  easy_mindmup                   1.0
  easy_wbs                       1.5
  redmine_base_deface            0.0.1
  redmine_default_assign         0.6
  redmine_editauthor             0.11.0
  redmine_extended_watchers      1.0.5
  redmine_issue_history          1.0.0
  redmine_issue_templates        0.2.0
  redmine_query_share            2.1.0
  redmine_refresh                0.2.0
  unread_issues                  2.2.0

We use MariaDB as database

It is not a big deal for us, but it may be interesting fro you to know.

All the best


Files

ticket.png (26.2 KB) ticket.png Particip IT, 2019-03-01 12:16
roadmap.png (37.4 KB) roadmap.png Particip IT, 2019-03-01 12:16
prevent_rounding_of_version_progress.diff (1.76 KB) prevent_rounding_of_version_progress.diff Bernhard Rohloff, 2019-03-01 17:28
fix_rounding_of_progress_bar.diff (505 Bytes) fix_rounding_of_progress_bar.diff Bernhard Rohloff, 2019-03-01 18:10
show_correct_progress_values.diff (1.27 KB) show_correct_progress_values.diff Bernhard Rohloff, 2019-03-01 18:10

Related issues

Related to Redmine - Defect #27848: The progress exceeding 99.5% is displayed as 100%ClosedJean-Philippe Lang

Actions
Actions #1

Updated by Bernhard Rohloff over 4 years ago

I can reproduce it and agree, that this is an odd behavior.
The issue is that the calculated done ratio gets rounded before displaying which in my opinion is wrong.
Attached you can find a patch to fix it. Feedback is highly appreciated. :)

Actions #2

Updated by Bernhard Rohloff over 4 years ago

By the way...
The issue is also related to #27848 where a different approach was chosen to fix nearly the same problem, so it would be nice to have a bit of feedback from the Redmine veterans, too.

Actions #3

Updated by Bernhard Rohloff over 4 years ago

Just split up my previous patch and made rounding similar to #27848.
I think that's the better way.

Actions #4

Updated by Bernhard Rohloff about 4 years ago

  • Related to Defect #27848: The progress exceeding 99.5% is displayed as 100% added
Actions #5

Updated by Marius BALTEANU about 4 years ago

  • Assignee set to Marius BALTEANU
Actions #6

Updated by Marius BALTEANU about 4 years ago

  • Description updated (diff)
Actions #7

Updated by Marius BALTEANU about 4 years ago

  • Status changed from New to Confirmed
  • Target version set to 4.1.0

Bernhard Ganslmeier, I've reviewed your patches from note-3 and your fixes look good to me.

I've created a test as well to be applied on top of your patches. The patch can be found here.
Tests pass: https://gitlab.com/marius-balteanu/redmine/-/jobs/183120442

Actions #8

Updated by Marius BALTEANU about 4 years ago

  • Assignee deleted (Marius BALTEANU)
Actions #9

Updated by Jean-Philippe Lang almost 4 years ago

  • Status changed from Confirmed to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Patch and test committed, thanks to both of you.

Actions

Also available in: Atom PDF