Feature #31322

Provide a way to automatically close all open subtasks too when a parent issue is being closed

Added by Hinako Tajima over 1 year ago. Updated 2 months ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

I wish to add the function of reminder which shows up like pop-up screen to ask for closing the subtask when the parent issue is closed.

親チケットが閉じられたときに、子チケットを閉じるように求める、ポップアップ画面が表示されるようなリマインダー機能を追加してほしい。

issue-31322.diff Magnifier (3.47 KB) Toshi MARUYAMA, 2019-09-30 19:51

issue-31322-ver.2.diff Magnifier (2.56 KB) Toshi MARUYAMA, 2019-09-30 20:01

POC.png (36.2 KB) Toshi MARUYAMA, 2019-09-30 20:13

issue-31322-ver.3.diff Magnifier (4.3 KB) Toshi MARUYAMA, 2019-10-09 10:01

issue-31322.ver.4.diff Magnifier (8 KB) Toshi MARUYAMA, 2019-10-16 04:15

issue-31322.ver.4.png (61.3 KB) Toshi MARUYAMA, 2019-10-16 04:15

20191218-01-ajax-check.diff Magnifier (14.1 KB) Toshi MARUYAMA, 2019-12-19 03:01

20191218-02-ajax-modal-form.png (24.7 KB) Toshi MARUYAMA, 2019-12-19 03:02

20191218-02-ajax-modal-form.diff Magnifier (5.13 KB) Toshi MARUYAMA, 2019-12-19 03:02

20191218-03-close-all-open-subtasks.diff Magnifier (20.1 KB) Toshi MARUYAMA, 2019-12-19 03:03

20191218-03-close-all-open-subtasks.png (22 KB) Toshi MARUYAMA, 2019-12-19 03:03

20200131-collapse.diff Magnifier (25.4 KB) Toshi MARUYAMA, 2020-01-31 15:22

20200131-series.diff Magnifier (39.3 KB) Toshi MARUYAMA, 2020-01-31 15:22

20200609-collapse.diff Magnifier (25.5 KB) Toshi MARUYAMA, 2020-06-09 10:43

20200609-series.diff Magnifier (39.2 KB) Toshi MARUYAMA, 2020-06-09 10:43


Related issues

Related to Redmine - Feature #31321: Option not to block closing a parent issue when its subta... Closed
Related to Redmine - Feature #28492: Option not to block closing a parent issue when it has op... New
Related to Redmine - Feature #31589: Show warning and the reason when the issue cannot be clos... Closed

History

#1 Updated by Go MAEDA over 1 year ago

  • Related to Feature #31321: Option not to block closing a parent issue when its subtask is open added

#2 Updated by Go MAEDA about 1 year ago

  • Category set to Issues

#3 Updated by Go MAEDA about 1 year ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Closing as a duplicate of #28492.

#4 Updated by Go MAEDA about 1 year ago

  • Duplicates Feature #28492: Option not to block closing a parent issue when it has open subtask(s) added

#5 Updated by Toshi MARUYAMA 11 months ago

  • Subject changed from Close subtasks along with a parent issue. to Confirming to close a parent issue when its subtask is open
  • Status changed from Closed to New
  • Resolution deleted (Duplicate)

I don't think this issue is duplicate of #28492.

#6 Updated by Toshi MARUYAMA 11 months ago

  • Duplicates deleted (Feature #28492: Option not to block closing a parent issue when it has open subtask(s))

#7 Updated by Toshi MARUYAMA 11 months ago

  • Related to Feature #28492: Option not to block closing a parent issue when it has open subtask(s) added

#8 Updated by Toshi MARUYAMA 11 months ago

This is POC.
There is no test.
You need apply #28492 patch first.

#9 Updated by Toshi MARUYAMA 11 months ago

Simplified.

#10 Updated by Toshi MARUYAMA 11 months ago

$ LC_ALL=en_US.UTF-8 firefox

#11 Updated by Toshi MARUYAMA 10 months ago

This is new POC version.
There is still no test.

#12 Updated by Toshi MARUYAMA 10 months ago

This patch has test.
You need to apply #28492#note-14 patch first.

#13 Updated by Toshi MARUYAMA 8 months ago

Previous patch uses complicated javascript.
This patch rewrite to use jQuery submit event.

Previous patch uses client html elements to check whether subtask is open or not.
So it cannot check invisible issue.
This patch uses ajax and check in server.

You need to apply #28492#note-14 patch first.

#14 Updated by Toshi MARUYAMA 8 months ago

This is additional patch to previous patch.
This patch replaces Javascript confirm dialog to ajax modal form.

#15 Updated by Toshi MARUYAMA 8 months ago

This is additional patch to previous patch.

  • All open subtasks are visible
  • Selected status is allowed in all open subtasks

In this case this dialog opens.

If not, previous note dialog opens.

#16 Updated by Toshi MARUYAMA 7 months ago

  • Related to Feature #31589: Show warning and the reason when the issue cannot be closed because of open subtasks or blocking open issue(s) added

#17 Updated by Mitsuyoshi Kawabata 7 months ago

Regarding Maruyama's patches, how about just #31589? It would be simple and clear.

#18 Updated by Mischa The Evil 7 months ago

  • Subject changed from Close all open subtasks when parent issue to be closed to Provide a way to automatically close all open subtasks too when a parent issue is being closed

FWIW: This issue is not related/being superseded by either #28492 or #31589. See my explanation in #31589#note-21.

@Toshi MARUYAMA: It has become very hard to review your patches for this feature. Can you provide all your changes for this feature in a single patch and clearly specify which requirements it has (like a dependency on an implementation for issue #28492)?

#19 Updated by Toshi MARUYAMA 6 months ago

  • File 20200131-series.diff added
  • File 20200131-collapse.diff added

Mischa The Evil wrote:

@Toshi MARUYAMA: It has become very hard to review your patches for this feature. Can you provide all your changes for this feature in a single patch and clearly specify which requirements it has (like a dependency on an implementation for issue #28492)?

Done.

These depend on #28492#note-20 issue-28492.ver.3.diff.

#20 Updated by Toshi MARUYAMA 6 months ago

Fix indents.

#21 Updated by Toshi MARUYAMA 6 months ago

  • File deleted (20200131-series.diff)

#22 Updated by Toshi MARUYAMA 6 months ago

  • File deleted (20200131-collapse.diff)

#23 Updated by Toshi MARUYAMA 2 months ago

r19803 changed ajax behavior and it broke previous patches.
These are fixed patches.

Also available in: Atom PDF