Project

General

Profile

Actions

Defect #31929

closed

MarkdownFormatterTest#test_should_support_underlined_text is declared as private

Added by Mischa The Evil almost 4 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Code cleanup/refactoring
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

#28169 introduced Redmine::WikiFormatting::MarkdownFormatterTest#test_should_support_underlined_text. However, this test seems to be unintentionally declared as private instead of being public due to the existence of the private method #assert_section_with_hash.

This issue was reported by Martin Cizek in issue #22323#note-5.


Files

fix_test.patch (1.18 KB) fix_test.patch Marius BALTEANU, 2019-08-20 20:32

Related issues

Related to Redmine - Patch #28169: Enable and add underline button to the toolbar for Markdown formatting ClosedJean-Philippe Lang

Actions
Related to Redmine - Defect #33562: Some tests in ApplicationHelperTest are declared as privateClosedGo MAEDA

Actions
Actions #1

Updated by Marius BALTEANU almost 4 years ago

  • Related to Patch #28169: Enable and add underline button to the toolbar for Markdown formatting added
Actions #2

Updated by Marius BALTEANU almost 4 years ago

It was introduced by me in #28169. Attached a patch with the fix.

Actions #3

Updated by Go MAEDA almost 4 years ago

  • Target version changed from Candidate for next minor release to 4.0.5

Setting the target version to 4.0.5.

Actions #4

Updated by Go MAEDA almost 4 years ago

  • Category set to Code cleanup/refactoring
  • Status changed from Confirmed to Closed
  • Assignee set to Go MAEDA
  • Target version changed from 4.0.5 to 4.1.0
  • Resolution set to Fixed

Committed the patch. Thanks.

I don't think we have to backport this change to 4.0-stable because the issue does not affect users.

Actions #5

Updated by Mischa The Evil almost 3 years ago

  • Related to Defect #33562: Some tests in ApplicationHelperTest are declared as private added
Actions

Also available in: Atom PDF