Feature #33256

Show wiki toolbar for spent time custom fields with text formatting enabled

Added by Marius BALTEANU 10 months ago. Updated 10 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Go MAEDA% Done:

0%

Category:Time tracking
Target version:4.2.0
Resolution:Fixed

Description

Before:

Using this patch:

after.png (147 KB) Marius BALTEANU, 2020-04-05 11:44

before.png (120 KB) Marius BALTEANU, 2020-04-05 11:44

0001-Show-wiki-toolbar-in-time-spent-form-for-custom-fiel.patch Magnifier (2.15 KB) Marius BALTEANU, 2020-04-05 11:50

33256-undefined-in-preview.png (81.1 KB) Go MAEDA, 2020-04-05 16:05


Related issues

Duplicated by Redmine - Feature #33288: Add wiki bar to Time_Log Closed
Blocked by Redmine - Defect #32471: Layout of the custom field edit page is different between... Closed

Associated revisions

Revision 19692
Added by Go MAEDA 10 months ago

Show wiki toolbar in time spent form for custom fields with text formatting enabled (#33256).

Patch by Marius BALTEANU.

History

#1 Updated by Marius BALTEANU 10 months ago

This patch implements the wiki toolbar in the following pages:
  1. timelog#new
  2. timelog#edit
  3. timelog#bulk_edit.

#2 Updated by Marius BALTEANU 10 months ago

Tests pass: https://gitlab.com/redmine-org/redmine/pipelines/132973534 (the one that fails is caused by another issue).

#3 Updated by Go MAEDA 10 months ago

Thank you for submitting the patch, but I found an issue that the Preview tab always displays "undefined" when bulk editing time entries. See 33256-undefined-in-preview.png.

#4 Updated by Marius BALTEANU 10 months ago

Go MAEDA wrote:

Thank you for submitting the patch, but I found an issue that the Preview tab always displays "undefined" when bulk editing time entries. See 33256-undefined-in-preview.png.

Oh, I forgot to mention that it should work on top of #32471. Can you retest it after you apply those patches?

#5 Updated by Go MAEDA 10 months ago

  • Blocked by Defect #32471: Layout of the custom field edit page is different between the single edit page and the batch edit page added

#6 Updated by Go MAEDA 10 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you.

#7 Updated by Go MAEDA 9 months ago

Also available in: Atom PDF