Defect #36585

Change "Delete" entry in issue context to "Delete issue(s)"

Added by Frederico Camara 5 months ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:Duplicate Affected version:4.2.3

Description

Similarly to #31278, this context entry can be interpreted wrongly. Specifically, one redmine user did the following:

1. Opened an issue (issue#view) (redmine:3000/issues/40, for example)
2. Added a related issue (41, for example)
3. Decided to delete the relation
4. Opened the context menu, instead of clicking on the broken link icon (the one with the tooltip "Delete relation", but who reads tooltips?)
5. Clicked on the "Delete" button
6. Clicked OK on the popup (the text there could be more straightforward, for example: "Delete issue(s)? Are you sure?" but who reads popups?)
7. Later, called support (me) asking why the issue disappeared?

The problem is not the user not reading the popups. Various popus in Redmine are written like this: "Are you sure you want to" whatever. This is not the best way to write confirmation popups, but even with a strightforward text, lie in the example above, popups are rather dismissed than acknowledged.

The problem here is the usability of the context entry. The icon to delete the relation is next to the icon that opens the context menu, but "Delete" issue is more destructive than "Delete relation", because you can't rollback deleting an issue.

Notice that "Delete relation" though less destructive, because there is very little data loss, and you can always redo a relation, has the full text "Delete relation" on the popup.

I won't post a patch. Instead i did a grep of label_issues_delete (my sugestion, though it needs translation for other languages):

app/views/context_menus/issues.html.erb:152:  <li><%= context_menu_link l(:label_issues_delete), issues_path(:ids => @issue_ids, :back_url => @back),

config/locales/en.yml:594:  label_issues_delete: Delete issue(s)

config/locales/pt-BR.yml:365:  label_issues_delete: Excluir tarefa(s)

screenshot.png (124 KB) Mizuki ISHIKAWA, 2022-02-09 00:50


Related issues

Duplicates Redmine - Feature #31278: Change Delete button name to Delete issue Closed

History

#1 Updated by Mizuki ISHIKAWA 5 months ago

The "Delete" button seems to have been replaced by "Delete issue" in the context menu by #31278's work.
This is the current Redmine screen under development:

Is it possible to make this issue resolved? Or is there something else that needs to be changed?

#2 Updated by Frederico Camara 5 months ago

  • Status changed from New to Resolved

My bad.

I should have applied the community's solution to the issue I reported myself. I just assumed there were minimal differences between mine and the community's patch.

Sorry and thanks for your time.

#3 Updated by Holger Just 5 months ago

  • Duplicates Feature #31278: Change Delete button name to Delete issue added

#4 Updated by Holger Just 5 months ago

  • Status changed from Resolved to Closed
  • Resolution set to Duplicate

Also available in: Atom PDF