Patch #4641

Add information about openid requirements to /admin/info

Added by Holger Just over 9 years ago. Updated over 6 years ago.

Status:NewStart date:2010-01-23
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:OpenID
Target version:-

Description

Issue #3431 asked for information about the installed openid requirements. Resolution was to add some documentation.

For an admins trying to enable openid authentication (like myself) it is however not initially clear that a further dependency (i.e. the ruby-openid gem) is necessary. Therefore I propose a patch to add the information about the (not) installed gem to admin/info.

The most informative patch however would be a short notice just below the checkbox stating in 3 words that the ruby-openid could not be found. Thus the admin wuould not be forced to search for hints on why the checkbox might be disabled.

openid_info.patch Magnifier (27.9 KB) Holger Just, 2010-01-23 20:34

History

#1 Updated by Eric Davis over 9 years ago

  • Category set to Accounts / authentication
  • Status changed from New to 7
  • Assignee set to Eric Davis

#2 Updated by Eric Davis over 8 years ago

  • Assignee deleted (Eric Davis)

I am stepping down from working on Redmine. If someone else is interesting in working on this issue, feel free to reassign it to them.

Eric Davis

#3 Updated by Etienne Massip over 7 years ago

  • Category changed from Accounts / authentication to OpenID

#4 Updated by Jean-Philippe Lang over 6 years ago

  • Status changed from 7 to New

Assigned issue with no assignee back to New status.

Also available in: Atom PDF