Project

General

Profile

Actions

Feature #5272

closed

Allow multiple target versions

Added by Oliver Gierke about 14 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Roadmap
Target version:
-
Start date:
2010-04-08
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Assume you develop two major branches of a project, e.g. maintaining a 1.x branch while developing a 2.x. branch. When you now have issues that affect both branches (or features that will be implemented for both), there is no way to indicate, that they will be implemented or fixed in/for both. So it would be cool to be able to assign multiple versions as target versions.


Related issues

Has duplicate Redmine - Feature #13779: Allow to set more than one target version for a ticketClosed

Actions
Is duplicate of Redmine - Feature #1266: Feature: Allow setting multiple target-milestonesNew2008-05-20

Actions
Actions #1

Updated by Eraldo Girardi about 14 years ago

This would be a useful feature. In my company we have different branches to mantain, and always there are bugs affecting more than a single one.

Actions #2

Updated by Nigel Jones about 14 years ago

I agree this would be a useful feature.

Actions #3

Updated by Alexander Usikov about 14 years ago

+1
Need for this feature

Actions #4

Updated by Daniel Miller almost 14 years ago

This feature-request might be a duplicate of feature-request #284.

Actions #5

Updated by Kiall Mac Innes over 13 years ago

+1 There are many other tickets for the same thing, but none have had any activity 9-10 months, and some for years.

This is a really important feature for many developers! We're maintaining 2x versions of the KohanaPHP framework in redmine and struggling to come up with a usable workflow!

Actions #6

Updated by Andy Bolstridge about 13 years ago

A suggestion: it would be useful to be able to automatically create sub-issues (or related issues) for all versions in a project.

eg. you have version 1.0 and version 2.0 to support, when a new bug is found and created, it wil automatically have related/sub issues for all versions, so that they can either be marked 'not a problem for this version' or 'waiting to be fixed in this version'. Then the bug will not be closed until its resolved in all active versions.

It might be better to handle as an option on new issue creation, but it might help a lot of projects that support several versions at once.

Actions #7

Updated by Pavel Konstantinov over 12 years ago

+1
Need for this feature

Actions #8

Updated by Terence Mill over 12 years ago

Could be resolved by custom field if multiselect support #1189 will be implemented.

Actions #9

Updated by Tharuka Pathirana over 12 years ago

+1
Also see #219, #5510 and #1266.

Actions #10

Updated by Terence Mill over 12 years ago

In general multiselect switch feature should be possible for all fields, also custom fields of type list or enumeration.

Actions #11

Updated by Eraldo Girardi over 11 years ago

Tried to use a multiselect custom field but it's so different from the default Target version field.
Target version is useful because you can click on it and see what issues are related to that version. This doesn't work with multiselect version custom field.
So I really hope multiple target versions is implemented into Redmine.
Thanks

Actions #12

Updated by Joel SCHAAL over 11 years ago

Can we have some update on what will be decided for this task ?
It has been entered more than 2 years ago and it is still new.

Is this a rejected issue ? Does this issue depend on other work ?

Actions #13

Updated by Anthony BOUQUET about 11 years ago

+1 for this feature, really need this for our project instead of copying/pasting issues to multiple milestones !

Actions #14

Updated by Jongwook Choi about 11 years ago

+1
This is a must-have.

Actions #15

Updated by Michael Lo about 11 years ago

I am sponsoring a fix for this. Hope to have a test version soon.

Actions #16

Updated by Prof. Dr. YoMan almost 11 years ago

I falsely issued a duplicate of this, but from what I see it is a more than once requested feature.

Why isn't it anywhere on the roadmap?

Actions #17

Updated by Toshi MARUYAMA almost 11 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

I close as duplicate with #1266.

Actions #18

Updated by Alice Etchegaray over 9 years ago

+ 1 !!
Michael Lo, have you succeed in developing a fix for that ??

Actions #19

Updated by zhiguo Zhu almost 9 years ago

+100

Actions

Also available in: Atom PDF