Project

General

Profile

Actions

Feature #5303

closed

Add spent_hours to /issues/index API

Added by Alex Last about 14 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
REST API
Target version:
-
Start date:
2010-04-13
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

I'm trying to import redmine tasks into Microsoft Project through REST API.
I need "time spent" info for tasks to update the remaining time properly in MSP plan.

can we add the corresponding API ?


Related issues

Related to Redmine - Defect #18943: REST API does not return spent_hours when listing issuesClosed

Actions
Is duplicate of Redmine - Feature #34857: Add total estimated hours, spent hours, total spent hours for issues to issue list APIClosedGo MAEDA

Actions
Actions #1

Updated by Alex Last about 14 years ago

I haven't looked at the redmine database structure, but I believe adding this info into basic/default data packet sent by Redmine REST API can slow down the system because it would require SQL select from several tables.

maybe we could introduce a special parameter for REST API to indicate that additional info should be added to the data structure? this way we can keep the default data format intact and only add extra fields (by running more expensive SQL queries) only when needed

Actions #2

Updated by Jean-Philippe Lang about 14 years ago

spent_hours is already present in /issues/1.xml

Actions #3

Updated by Alex Last about 14 years ago

Jean-Philippe, is there a way to add that information to "issues list" response as well (let's say, if some additional parameter is provided in the request). The reason I'm asking about this - it would be very ineffective to load data from Redmine to an external system (like Microsoft Project ) this way. If I export 500 tasks, I'd have to perform 500 additional requests to get the "time spent" info for every task being exported.

I'm currently working on a system, which automatically generates Microsoft Project (MSP) files from the real data stored in Redmine. This way we can reuse all possible reports provided by MSP.

Actions #4

Updated by Jean-Philippe Lang over 13 years ago

  • Subject changed from get "time spent" info through REST API to Add spent_hours to /issues/index API
Actions #5

Updated by Maxim Zyukin over 12 years ago

I'm working with Alexey on the system.
And one of our customers asked for this ability.

Could you, plz, implement this feature?

Actions #6

Updated by Ivan Cenov over 11 years ago

Do you need this: http://www.redmine.org/projects/redmine/wiki/Rest_TimeEntries
If so, I think this issue could be closed.

Actions #7

Updated by Daniel Felix over 11 years ago

  • Due date set to 2013-03-31
  • Status changed from New to Needs feedback

Please give some Feedback if note 6 solves your problem/if everything is fine.
Please give some feedback in the next 14 days. Otherwise this issue will be closed. Thanks.

Actions #8

Updated by Alex Last over 11 years ago

no, the point was to include time info into "get issues" response so that the client code won't need to perform dozens or hundreds of extra requests after receiving a list of issues. we already implemented the import, so I don't really care that much.

Actions #9

Updated by Daniel Felix about 11 years ago

  • Due date deleted (2013-03-31)
  • Status changed from Needs feedback to New

I'm removing due date as this one still needs some further investigation.

Actions #10

Updated by David Lukas Müller almost 11 years ago

I think, I've observed the same phenomenon:
  • When selecting issues via a query like this http://myhost/redmine/issues.json?cf_7=42, the spent_hours information is missing
  • But wenn I ask for a single issue details directly via http://myhost/redmine/issues/1234.json, the spent_hours information is provided

I'm using Redmine version 2.3.1.stable on Ruby version 1.9.3 (x86_64-linux) with Rails version 3.2.13 (Database adapter Mysql2).

Beside some other plugins, I'm using "redmine_spent_time 2.5.0"

Actions #11

Updated by Toshi MARUYAMA over 9 years ago

  • Related to Defect #18943: REST API does not return spent_hours when listing issues added
Actions #12

Updated by Go MAEDA almost 3 years ago

  • Is duplicate of Feature #34857: Add total estimated hours, spent hours, total spent hours for issues to issue list API added
Actions #13

Updated by Go MAEDA almost 3 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

It has been implemented by #34857 and will be available in Redmine 5.0.0.

Actions

Also available in: Atom PDF