Project

General

Profile

Actions

Feature #6332

closed

"OR" filter and not only "AND" filter

Added by Alexander F over 13 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
2010-09-08
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Hi,
I can currently set quite complex filters on the issue list with redmine.

The only problem is that the filters have a default behavior of logical "AND" between them and I can't set it to "OR"/other logical operators.


Related issues

Has duplicate Redmine - Feature #6695: Allow filters to include an 'OR' searchClosed2010-10-18

Actions
Has duplicate Redmine - Feature #12897: Separate "Filter" and "Options" settings for ticket views to allow different parallel settingsClosed

Actions
Is duplicate of Redmine - Feature #4939: List of tasks filtered as OR and not ANDNew2010-02-26

Actions
Actions #1

Updated by Jean-Baptiste Barth over 13 years ago

It would add too much complexity to the model. I don't see any known website that offers such a possibility. Any other opinion about that ?

Actions #2

Updated by Jon Lumpkin over 13 years ago

+1 for this issue.

Many of the other issue tracking systems do actually allow this, including:
  • Jira
  • Trac
  • BugTracker.net

I was going to try fogbugz, but I couldn't find a totally open demo install. I don't mind trying other alternatives too, but wasn't sure which others were large enough or had open demos. I just went through the list of other sites we looked at before using Redmine.

Jira and BugTracker.net both allow you to use 'OR' basically by allowing multiple selections. They either use a listbox or other method for you to choose more than one option.

Trac on the other hand has another field that allows you to say if its an 'or' or 'and' comparison.

This shouldn't change any models too much, all you would be doing is letting the user build more of the query that they are already making.

Actions #3

Updated by Jon Lumpkin over 13 years ago

+1 for this issue.

Many of the other issue tracking systems do actually allow this, including:
  • Jira
  • Trac
  • BugTracker.net

I was going to try fogbugz, but I couldn't find a totally open demo install. I don't mind trying other alternatives too, but wasn't sure which others were large enough or had open demos. I just went through the list of other sites we looked at before using Redmine.

Jira and BugTracker.net both allow you to use 'OR' basically by allowing multiple selections. They either use a listbox or other method for you to choose more than one option.

Trac on the other hand has another field that allows you to say if its an 'or' or 'and' comparison.

This shouldn't change any models too much, all you would be doing is letting the user build more of the query that they are already making.

We would really like this feature because then you could do queries like 'I want to see all issues I am assigned to and watching'.

Actions #4

Updated by Jon Lumpkin over 13 years ago

Could someone remove comment #2? I forgot the redmine.org installation didn't let you edit your comments.

Actions #5

Updated by Frank Helk over 13 years ago

+1

I'd like such options, too ... at least I would appreciate to have list based fields (i.e. status, category, priority, versions) to have multiple selection lists (OR connected) ... i.e. [Status = New OR Assigned]

On the other hand it would be nice if I could set more than one filter on a text field - i.e. [Subject contains "tracker"] AND [Subject contains "field"]. That would allow more detailled searches in long ticket lists.

A more revolutionary approach: Give two ways of definig filters. The current way and a formula based one. In the formula based filter there could be a text field for a search formula like [subject~"tracker" and (status=assigned or status=new) and subject!~"project"] meaning "subject contains tracker but not project and status is assigned or new".

Actions #6

Updated by Paolo Sulprizio over 13 years ago

Frank Helk wrote:

On the other hand it would be nice if I could set more than one filter on a text field - i.e. [Subject contains "tracker"] AND [Subject contains "field"]. That would allow more detailled searches in long ticket lists.

there is my feature req #1140 ;)

Actions #7

Updated by Stéphane Gourichon about 12 years ago

Frank Lee : you can have "multiple selection lists" since #1189 is closed.
Regarding them being used for queries, I don't know.

Actions #8

Updated by Daniel Albuschat over 11 years ago

+1
I'd like to create a filter that shows tickets that are scheduled for today (call it "Today's tickets"). But the filter should additionally include tickets with the priority "Critical", regardless of when the tickets are scheduled (critical tickets don't need scheduling).

Actions #9

Updated by Gerd Müller over 11 years ago

+1
I'd like to list all tickets that are assigned to me OR I'm observing.

Actions #10

Updated by Jeremy Payn over 11 years ago

I agree that there needs to hopefully be greater filter ability. I am needing to set a filter that includes items assigned to me or items authored by me. I cannot currently do this. What ends up filtering down are the items that I authored and assigned to myself. I would also like the email notifications by the projects that I choose to include only that, and not other projects that someone assigned me as a watcher on. Thanks.

Actions #11

Updated by Christian Ziegelt over 11 years ago

+1 !
Since redmine ist realy the best system out there I would realy realy like to stay with redmine.
Unfortunately this is a kind of KO criteria for us.

Actions #12

Updated by peter longfield over 11 years ago

+1
See also #10999

Actions #13

Updated by Anonymous over 11 years ago

+1
Also it should be possible to set brackets to refine custom queries

Actions #14

Updated by Amr Noaman over 11 years ago

+1 for this.

Actions #15

Updated by Knut Meyer about 11 years ago

+1 for this.

Actions #16

Updated by Gurvan Le Dromaguet about 11 years ago

+1
Isn't this a duplicate of 4939 ?

Actions #17

Updated by Daniel Felix about 11 years ago

  • Category set to Issues
  • Status changed from New to Closed
  • Resolution set to Duplicate

Gurvan Le Dromaguet wrote:

Isn't this a duplicate of 4939 ?

Yes. Your right. Currently they are just in relation. I will set this issue as duplicate of #4939 and add the other relation to it.

Actions #18

Updated by Toshi MARUYAMA about 10 years ago

  • Related to deleted (Feature #10999: Ticket list filter: More flexible filter conditions)
Actions #19

Updated by Vladimir Perepechenko over 7 years ago

Yes, OR for filters is really needed.

Actions #20

Updated by Susana Mielgo about 7 years ago

+1 for this

Actions #21

Updated by Augustin de La Rivière about 7 years ago

+1 for this

Actions #22

Updated by Lionel Vanacker almost 7 years ago

I need too to do filter with logical "OR". How can I do ?

Actions #23

Updated by Roman Yagodin over 6 years ago

+1 for this.

It could be great to allow filters with multiple conditions by same field (e.g. status is "open" AND status is not feedback) also.

Actions #24

Updated by Albrecht Dreß about 6 years ago

+1 for this!

This worked just fine with trac (which has many other drawbacks compared to Redmine, though), by using either the UI or by defining the sql queries directly. The latter would be a nice option, too, as it might allow to address more complex use cases.

Typical use case for my organization (note the parentheses…): ticket is open AND (I am assignee OR I am author)

Actions #25

Updated by Ray Cheung over 3 years ago

+1 for this.

Actions #26

Updated by Erik S. over 2 years ago

+1 for this but more logical operators for filters in general also multiple conditions for the same field.

How can this basic functionality not have been prioritized after all these years (11 years!)?

I'm trying to create filters to create a simple Eisenhower Matrix: [[https://todoist.com/productivity-methods/eisenhower-matrix]] with the help of

tags
but I fail since cannot create the condition:
tag is "Important" AND tag is "Urgent"
for a logical AND. But I can only create a logical OR.

Please prioritize!

Actions #27

Updated by Igor M about 2 years ago

Erik S. wrote:

+1 for this but more logical operators for filters in general also multiple conditions for the same field.

How can this basic functionality not have been prioritized after all these years (11 years!)?

Please prioritize!

+1 !!!!!

Actions

Also available in: Atom PDF