Project

General

Profile

Actions

Feature #7884

closed

Import issues from Excel or CSV file

Added by Se Ri about 13 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Importers
Target version:
-
Start date:
2011-03-16
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Hi everybody,

I know this is not a new request on this. There are a lot of issues asking for this feature, and I have read all, but it seems that there is no official solution. I have tried rchady_redmine_importer and failed to import my issue list to Redmine. That's so disappointed for such a nice application as Redmine. So, anybody can give me a solution, because it's already been 3 years from the first request and there is still no way to do ?

Thanks,
Seri


Files

Mail.java (6.62 KB) Mail.java Thomas Godard, 2013-07-26 11:56

Related issues

Related to Redmine - Feature #3647: Data Import/Export SystemNew2009-07-21

Actions
Has duplicate Redmine - Feature #12247: How to import excel file to RedmineClosed

Actions
Is duplicate of Redmine - Feature #950: Import Issues from delimited/CSV fileClosedJean-Philippe Lang2008-03-29

Actions
Actions #1

Updated by Etienne Massip about 13 years ago

  • Category set to Importers
Actions #2

Updated by Ryan H about 13 years ago

What are you looking for? The basics - Tracker/Status/Subject/Description?

Ryan

Se Ri wrote:

Hi everybody,

I know this is not a new request on this. There are a lot of issues asking for this feature, and I have read all, but it seems that there is no official solution. I have tried rchady_redmine_importer and failed to import my issue list to Redmine. That's so disappointed for such a nice application as Redmine. So, anybody can give me a solution, because it's already been 3 years from the first request and there is still no way to do ?

Thanks,
Seri

Actions #3

Updated by Se Ri almost 13 years ago

Hi Ryan,

Sorry for my late reply. What I need is a tool to import my list of issues from Excel files. Not only basic fields, but also custom fields. It's nice to have this feature built-in (rather than as plugin) in future versions of Redmine.

Seri

Actions #4

Updated by Bernhard Wangler almost 11 years ago

Hi everybody,

I would also request this feature. I have to import a whole bunch of predefined requirements and task from other tools into redmine.
What I need is a very simple CSV import for issues. Using a plug in for such a common and often used feature is too risky for me.

Thanks,
Bernhard

Actions #5

Updated by Maik Lindner over 10 years ago

I'ld love to see that feature also. Still no news on this? It would be great to import issues from an excel sheet. Is there any other solution?

Actions #6

Updated by Thomas Godard over 10 years ago

As Redmine is now, the best way to import properly issues with no knowledge of ruby nor rails is to use the import via e-mail.

I did my migration at the beginning of the week like this. I created a small JAVA script which reads my excel sheet and automatically creates and sends e-mails as Redmine needs them.

My migration took me 3 days to import my nearly 7000 issues with more than 2.5 GB of attachments (total).

Here is my JAVA code. I have translated it in English and simplified it at best. Some errors might have been created during the modification. Some improvements can be done.

To improve performance, only use this script for 200 lines at once. More lines could cause Redmine import to create issues twice.

I found some mistakes in code. Please do not consider those lines :

                for (k = 1; k <= 16; k++) {

                    CHEMINCell[k][j] = CHEMINSheet.getCell(k, j);

                    CHEMINString[k][j] = CHEMINCell[k][j].getContents();

                }

Also remove quotes at the end of the line :

String body = "description\n " + wbString[1][j] + "\nproject: " + wbString[2][j] + ... + "\nLot: " + wbString[3][j]";

Actions #7

Updated by Lubos Racansky over 10 years ago

What an unpleasant surprise! Doesn't redmine really support the import feature out of the box? I've found just only ruby script.

Actions #8

Updated by Lubos Racansky over 10 years ago

Lubos Racansky wrote:

What an unpleasant surprise! Doesn't redmine really support the import feature out of the box? I've found just only ruby script.

Or you have to write your own call of REST API

Actions #9

Updated by Lubos Racansky over 10 years ago

Here there is a plugin, but it seems quite outdated http://www.redmine.org/plugins/importer

Actions #10

Updated by Juan Fernandez over 10 years ago

Hi,

I just created a Configurable PHP CLI tool that uses the API to import CSV as Issues, with custom Fields. Other types of objects can also be added. just extending EntityPopulator\Entities\Entity with a class who´s name matches the API.

just clone it from github and run composer install to fetch dependencies.

https://github.com/juanmf/RedmineIssueImporter

Best,
Juan

Actions #11

Updated by Maxim Krušina over 10 years ago

+1

Actions #12

Updated by Lu Pon over 9 years ago

+1

Actions #13

Updated by Toshi MARUYAMA over 9 years ago

Actions #14

Updated by Jean-Philippe Lang over 8 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Same as #950 implemented for 3.2.0.

Actions #15

Updated by Jean-Philippe Lang over 8 years ago

  • Is duplicate of Feature #950: Import Issues from delimited/CSV file added
Actions

Also available in: Atom PDF