Project

General

Profile

Actions

Defect #9842

closed

{{toc}} is not replaced by table of content when exporting wiki page to pdf

Added by Florent Fievez almost 12 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Low
Assignee:
-
Category:
PDF export
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed
Affected version:

Description

While exporting a wiki page to pdf, the {{toc}} keyword stay untranslated, it should be replaced by a table of content as in html rendering of the page.
See attached pdf file for example.


Files

CentOS_64bits_30_release_notes.pdf (312 KB) CentOS_64bits_30_release_notes.pdf Florent Fievez, 2011-12-19 11:51
Proyecto-uinfo.pdf (305 KB) Proyecto-uinfo.pdf Lu Pon, 2012-02-07 14:56
issue-ja.pdf (8.07 KB) issue-ja.pdf Toshi MARUYAMA, 2013-01-20 18:40
wiki-ja.pdf (5.95 KB) wiki-ja.pdf Toshi MARUYAMA, 2013-01-20 18:40

Related issues

Related to Redmine - Defect #13559: {{toc}} remains when exporting wiki page to textNew

Actions
Has duplicate Redmine - Defect #11728: Macros should be rendered or stripped before render to PDFClosed

Actions
Actions #1

Updated by Gokay Gok almost 12 years ago

+1

Actions #2

Updated by Cassiano Monteiro over 11 years ago

+1

Actions #3

Updated by franz baumann over 11 years ago

+1

Actions #4

Updated by Oli Kessler over 11 years ago

+1

Actions #5

Updated by Lu Pon over 11 years ago

+1

Macro pages (when you include a subpage) are not rendering correctly when you export to PDF and works well when you export to html.

Actions #7

Updated by Lu Pon over 11 years ago

See attached file. Do you think I must open a new issue for this?

Actions #8

Updated by Alexander Alexeev over 11 years ago

+1

Actions #9

Updated by Pierluigi Soana over 11 years ago

+1
Macro in general are not rendered by the export job

Actions #10

Updated by Martin Jinoch over 11 years ago

same problem in 1.3.1

Actions #11

Updated by Etienne Massip over 11 years ago

  • Status changed from New to Confirmed
  • Target version set to Candidate for next minor release
Actions #12

Updated by Anatoliy Gavrilov over 11 years ago

+1

Actions #13

Updated by Stephen Ostrow over 11 years ago

This is present in Redmine 1.4.3.stable as well.

Actions #14

Updated by Cassiano Monteiro over 11 years ago

Up!

Since defect #10688 was fixed, if this one and #10689 were fixed too, this would be very nice!

Actions #15

Updated by Toshi MARUYAMA about 11 years ago

  • Category changed from Wiki to PDF export
Actions #16

Updated by Carlos Peñas about 11 years ago

It really happens with any macro (exporting to pdf) not only with {{toc}}

Actions #17

Updated by Maurizio Totti almost 11 years ago

+1

Actions #18

Updated by David Fouche almost 11 years ago

+1
Macro in general

Actions #19

Updated by Michael Oostdyk almost 11 years ago

+1
Please

Actions #20

Updated by Kevin Gillen almost 11 years ago

+1

Actions #21

Updated by Daniel Felix over 10 years ago

  • Target version changed from Candidate for next minor release to 2.2.2
  • Affected version (unused) changed from 1.3.0 to 2.2.1
  • Affected version changed from 1.3.0 to 2.2.1

I can confirm this issue in 2.2.1 and current trunk (r11196).

This should be fixed. Anyway... just display the TOC or remove it, cause it doesn't make so much sense on the pdf-export, as Adobe has it's own TOC available.

Actions #22

Updated by Jean-Philippe Lang over 10 years ago

  • Status changed from Confirmed to Closed
  • Resolution set to Fixed

{{toc}} is now removed in PDF output.

Actions #23

Updated by Toshi MARUYAMA over 10 years ago

  • Status changed from Closed to Reopened

It seems that r11227 is broken in CJK.

Actions #24

Updated by Toshi MARUYAMA over 10 years ago

Toshi MARUYAMA wrote:

It seems that r11227 is broken in CJK.

Sorry, r11227 works fine in CJK.

Actions #25

Updated by Karel Pičman over 10 years ago

The same problem seems to me remains in TXT export.

Anyway I'd expect to implement TOC conversion to PDF instead of stripping of the tag.

Actions #26

Updated by Toshi MARUYAMA over 10 years ago

Karel Pičman wrote:

The same problem seems to me remains in TXT export.

Anyway I'd expect to implement TOC conversion to PDF instead of stripping of the tag.

I have created new issue #13559.

Actions

Also available in: Atom PDF