Feature #17720

Filter issues by "Updated by" and "Last updated by"

Added by Scott Hildebrand over 2 years ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues filter
Target version:3.4.0
Resolution:Fixed

Description

There appears to be no good way to filter by involvement. I think that maybe there are 2 filters needed here.

updated by (this would be general involvement, other users could have updated an issue afterwards)
last updated by (this would be specifically to find issues by who touched it last)

Similarly I think that these need to be added as available columns.

BTW I did try this plugin (https://github.com/neowit/redmine_last_updated_by_column) but it was kind of broken, and I don't think it quite addresses this general need.

filter_after_updated_by_and_last_updated_by.patch Magnifier (14.8 KB) Marius BALTEANU, 2016-08-03 00:28

filter_after_updated_by_and_last_updated_by_v2.patch Magnifier (13.9 KB) Marius BALTEANU, 2016-10-09 12:42

filter_after_updated_by_and_last_updated_by_v3.patch Magnifier (7.59 KB) Toshi MARUYAMA, 2016-11-07 13:10

filter_after_updated_by_and_last_updated_by_v4.patch Magnifier (7.02 KB) Marius BALTEANU, 2017-01-16 19:20

updated.png (27.4 KB) Marius BALTEANU, 2017-01-16 20:01

filter-position-before.png (17.3 KB) Go MAEDA, 2017-01-21 11:11

filter-position-after.png (17.9 KB) Go MAEDA, 2017-01-21 11:11

17720-change-filter-position.diff Magnifier - patch (change position in filters drop-down) (1.04 KB) Go MAEDA, 2017-01-21 11:15


Related issues

Related to Redmine - Feature #17932: [Feature Request] History Assignee filter Resolved
Related to Redmine - Feature #6375: Last updated by colum in issue list Closed 2010-09-12
Duplicated by Redmine - Feature #23210: "Updated by" filter is needed Closed
Duplicated by Redmine - Feature #1882: filter issues "modified by" a user Closed 2008-09-10
Duplicated by Redmine - Feature #13727: Search option 'updates made by me' Closed
Duplicated by Redmine - Feature #2333: Add ability to search for issues that the user touched Closed 2008-12-13

Associated revisions

Revision 16228
Added by Jean-Philippe Lang 3 months ago

Adds updated_by and last_updated_by filters on issues (#17720).

Revision 16229
Added by Jean-Philippe Lang 3 months ago

Adds :field_updated_by and :field_last_updated_by strings to locales (#17720).

Revision 16248
Added by Jean-Philippe Lang 3 months ago

Changed filter position (#17720).

Patch by Go MAEDA.

History

#1 Updated by Lajish Lakshmanan over 2 years ago

Hi Scott Hildebrand,

You are right, I also had the same problem. In redmine, there is no way to track who all users were involved in a tracker. Mostly developers who resolves issues have to reassign tracker to author so that it get verified by same(i.e. tester). To handle this, I made a custom field called 'Resolved By'.

I think, one of the problems you mentioned above can be handled by this plugin http://www.redmine.org/plugins/involvement_filter

But these features need to incorporated in Redmine core. I request Redmine team to consider these issues as soon as possible.

#2 Updated by Scott Hildebrand over 2 years ago

Thanks Lajish! It seems to be working for version 2.4.2, except for some missing translations which is no biggie. This is the plugin for 2.x that I'm using: https://github.com/commandprompt/redmine_involvement_filter

#3 Updated by Toshi MARUYAMA over 2 years ago

  • Category changed from Issues workflow to Issues

#4 Updated by Etienne Massip over 2 years ago

  • Related to Feature #17932: [Feature Request] History Assignee filter added

#5 Updated by Joel SCHAAL about 2 years ago

+1
These 2 filters would make sense for us too.

For example: List all the open issues I have modified since "that day". We can have all the opened issues modified since "that day", but not the ones (last) modified by a specific user.

#6 Updated by Janeks Kamerovskis almost 2 years ago

Are there any options for this filter "updated by" for Redmine v.3.x. ?

#7 Updated by Go MAEDA about 1 year ago

  • Related to Feature #6375: Last updated by colum in issue list added

#8 Updated by Toshi MARUYAMA 10 months ago

  • Category changed from Issues to Issues filter

#9 Updated by Toshi MARUYAMA 10 months ago

#10 Updated by JW Fuchs 10 months ago

+1

#11 Updated by Marius BALTEANU 9 months ago

I made a patch (with tests) that adds these 2 useful filters:

  1. updated_by: it can be used to find tickets updated or not by specific project users
    Use case: Find all the tickets that have been updated (touched) by me.
  2. last_updated_by: it can be used to find tickets that were last updated or not by specific users
    Use case: Find all the tickets that have been last updated by user x (a customer for example).

Both filters apply only on issues with at least one update made after issue creation.

Because the "last_updated_by" filter expects that the issue updated_on date to be equal with last journal created_on date, it was required to make some changes to issues fixtures and journal fixtures in order to match the dates. If i'm wrong with this expectation, please let me know and I'll try to find another solution.

Also, I've added a new journal entry in journal fixtures to test a scenario (with "!" operator). Because of this new journal entry, I changed in issue_test the issue id of the ticket without journals.

I'll add another patch that implements the last_updated_by as column in #6375.

#12 Updated by Go MAEDA 9 months ago

  • Priority changed from High to Normal
  • Target version set to 3.4.0

Thanks for submitting the patch, Marius BALTEANU. This is very useful.

It works fine for me and passed all tests. Setting target version to 3.4.0.

#13 Updated by Marius BALTEANU 7 months ago

Updated the patch to cleanly apply on the current trunk. All the tests pass.

#14 Updated by Toshi MARUYAMA 6 months ago

Rebased on r15949 v2 patch with minor fix.

diff --git a/test/unit/query_test.rb b/test/unit/query_test.rb
--- a/test/unit/query_test.rb
+++ b/test/unit/query_test.rb
@@ -29,7 +29,7 @@
            :queries,
            :projects_trackers,
            :custom_fields_trackers,
-           :workflows
+           :workflows, :journals

#15 Updated by Go MAEDA 5 months ago

  • Duplicated by Feature #1882: filter issues "modified by" a user added

#16 Updated by Marius BALTEANU 3 months ago

Updated the patch to cleanly apply on the current trunk.

@Jean-Philippe Lang, is there anything I can do in order to have this committed?

#17 Updated by Jean-Philippe Lang 3 months ago

  • Status changed from New to Needs feedback

For users who are not allowed to view private notes, these filters can match issues even if the update is not visible to the user.

Eg. user A updates issue X with private notes, user B (who is not allowed to view private notes) filters issues updated by user A and sees issue X in the results. But he won't see any update by user A when looking at the issue history.

Is it an acceptable behaviour?

#18 Updated by Marius BALTEANU 3 months ago

Jean-Philippe Lang wrote:

For users who are not allowed to view private notes, these filters can match issues even if the update is not visible to the user.

Eg. user A updates issue X with private notes, user B (who is not allowed to view private notes) filters issues updated by user A and sees issue X in the results. But he won't see any update by user A when looking at the issue history.

Is it an acceptable behaviour?

Very good question :)

From my point of view, this is an acceptable behaviour because the privacy of the note is not affected. User B it'll see only that the issue X was updated by user A. Currently, you can see the last update date, but without seeing the respective update in the history:

In the same time, I agree that the behaviour can be a little bit confusing for the users.

My proposal is to implement them as it is and see if the users will complain about it.

#19 Updated by Marius BALTEANU 3 months ago

Because I've mix feelings about my previous proposal, I'm going to take some feedback this week from our users regarding the expected behavior.

#20 Updated by Marius BALTEANU 3 months ago

I don't have a clear resolution after the feedback received, some of our users consider the behavior acceptable, and others agree that can be a little bit confusing.

Considering that is quite complex to ignore the private updates depending on the user permissions (with my Ruby/Redmine skills), and that the chances to find the issues updated by A to which user B doesn't have access are low, I think it is an acceptable behavior at least in the first phase.

#21 Updated by Jean-Philippe Lang 3 months ago

  • Subject changed from Need to be able to filter by "updated by" to Filter issues by "Updated by" and "Last updated by"
  • Status changed from Needs feedback to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Thanks for your feedback Marius.
I think hiding private updates is a better option and was not so difficult to implement without too much changes. It's committed in r16228. I've made a few tests with Postgres and 1M journals without performance issues. Please let know how it works for you.

#22 Updated by Go MAEDA 3 months ago

Sorry for reopening this issue.

I think it would be better to change the position of "Updated by" and "Last updated by" in the filters drop-down. Here is a patch: 17720-change-filter-position.diff

Please see the following images for details.

Before (current implementation):

After:

#23 Updated by Jean-Philippe Lang 3 months ago

  • Status changed from Reopened to Closed

Committed, thanks.

#24 Updated by Go MAEDA 3 months ago

  • Duplicated by Feature #13727: Search option 'updates made by me' added

#25 Updated by Marius BALTEANU 3 months ago

Jean-Philippe Lang wrote:

I think hiding private updates is a better option and was not so difficult to implement without too much changes. It's committed in r16228. I've made a few tests with Postgres and 1M journals without performance issues. Please let know how it works for you.

Thanks for committing this new filters and for the journal visibility implementation. I test it and it works great for us. Unfortunately, I don't have a large MySQL database for tests, but I'll let you know if we have any performance issue on our instance after 3.4.0 release.

Speaking about 3.4.0 and a little bit off-topic, do you have any estimation about the release date? There are a lot of great features already committed :).

#26 Updated by Go MAEDA 29 days ago

  • Duplicated by Feature #2333: Add ability to search for issues that the user touched added

Also available in: Atom PDF