Feature #10250

Renaming "duplicates" and "duplicated by" to something less confusing

Added by Fares Abdullah over 5 years ago. Updated 5 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:UI
Target version:3.4.0
Resolution:Fixed

Description

Reporting against Redmine 1.3.0.

I am always very confused by "duplicates" and "duplicated by" in the Redmine related issues. Even after doing it wrong and correcting it many times, I still cannot always remember which is which.

To some people, "duplicates" sounds like the plural of "duplicate" or "it performs duplication", and "duplicated by" sounds like "who does the duplication"

Could we please rename them in the English translation to (for example):
"duplicates" to "has duplicate"
"duplicated by" to "is duplicate of"

change_relations_locales.patch Magnifier (554 Bytes) Marius BALTEANU, 2016-10-30 18:29

Associated revisions

Revision 16452
Added by Jean-Philippe Lang 5 months ago

Renaming "duplicates" and "duplicated by" to something less confusing (#10250).

History

#1 Updated by Etienne Massip over 5 years ago

Fares Abdullah wrote:

Could we please rename them in the English translation to (for example):
"duplicates" to "has duplicate"
"duplicated by" to "is duplicate of"

Actually, it is exactly the opposite.

#2 Updated by Fares Abdullah over 5 years ago

Ok, it looks like I've made my own point...

#3 Updated by Fares Abdullah over 5 years ago

Then could we please rename them in the English translation to (for example):
"duplicates" to "is duplicate of"
"duplicated by" to "has duplicate"

#4 Updated by Dieter Egert over 5 years ago

1+

#5 Updated by Josef Grahn over 5 years ago

I, as well, have found this to be a general source of confusion. I think the main problem is that the "duplicate" as a concept implies some sort of symmetry -- both copies are identical -- while the relation we are trying to describe in Redmine has directional semantics.

Why not make it something completely different, that cannot be misinterpreted? Say for example "already reported in" for the copy that is redundant, clearly suggesting a precedence for the other issue. Maybe not as concise, but aesthetics is subordinate to comprehension, IMHO.

#6 Updated by Francewhoa (Francois Carpentier) about 4 years ago

+1 for clarifying the wording

#7 Updated by Francewhoa (Francois Carpentier) about 4 years ago

Documentation about that

duplicates - Links issues so that closing one, will close the other (e.g. closing A will close B)
For example, if issue B duplicates A:
- closing B will leave A open
- closing A will automatically close B
duplicated by - Reciprocal of duplicates
For example, if issue A is duplicated by issue B:
- closing B will leave A open
- closing A will automatically close B

Source: http://www.redmine.org/projects/redmine/wiki/RedmineIssues

#8 Updated by Kenichi Maehashi about 4 years ago

+1

#9 Updated by Gregor K over 3 years ago

+1
Please clarify the wording. I have to look it up in the documentation every single time.

#10 Updated by Alfred Perlstein over 2 years ago

+1

I have to look this up each time as well, very frustrating for our team.

#11 Updated by Bahri Yardim over 1 year ago

"duplicates" to "is duplicate of"
"duplicated by" to "has duplicate"

+1

#12 Updated by budo kaiman over 1 year ago

+1

#13 Updated by Ieuan Jenkins over 1 year ago

Josef Grahn wrote:

I, as well, have found this to be a general source of confusion. I think the main problem is that the "duplicate" as a concept implies some sort of symmetry -- both copies are identical -- while the relation we are trying to describe in Redmine has directional semantics.

Why not make it something completely different, that cannot be misinterpreted? Say for example "already reported in" for the copy that is redundant, clearly suggesting a precedence for the other issue. Maybe not as concise, but aesthetics is subordinate to comprehension, IMHO.

Agree with Josef, I have to google and find this same issue nearly every time to check the definition I come to use this relation because the phrasing doesn't make it clear which way around the relationship is.

#14 Updated by Marius BALTEANU 10 months ago

The same confusion exists in our company too. I applied the changes from the attached patch and the feedback received from our users was positive.
"Duplicated by" -> "Is duplicated by"
"Blocked by" -> "Is blocked by"

#15 Updated by Go MAEDA 10 months ago

  • Target version set to Candidate for next major release

Marius BALTEANU wrote:

The same confusions exists in our company too. I applied the changes from the attached patch and the feedback received from our users was positive.
"Duplicated by" -> "Is duplicated by"
"Blocked by" -> "Is blocked by"

I think it is a smart solution. Since the solution only adds "Is " to the current string, there is no adverse effects on the compatibility.

#16 Updated by Go MAEDA 6 months ago

  • Target version changed from Candidate for next major release to 3.4.0

Setting target version to 3.4.0 in support of #10250#note-14.

#17 Updated by budo kaiman 6 months ago

I don't think adding "Is" to the beginning really solves the problem. The biggest cause of confusion (for me at least) is "Duplicates" which is very vague. I think the best solution was suggested further up as it clears up both ends of the relation:

"duplicates" to "is duplicate of"
"duplicated by" to "has duplicate"

To me, I can look at these and clearly understand the relation between tickets, which I would not be able to do with the change suggested by note 14.

#18 Updated by Greg T 6 months ago

budo kaiman wrote:

I don't think adding "Is" to the beginning really solves the problem.

Me neither.
In our translation, I used wording that translates about

  label_duplicates: "Primary issue is" 
  label_duplicated_by: "A secondary issue is" 
as anything with the root word duplicate was awkward and ambiguous in Hungarian.

#19 Updated by Jean-Philippe Lang 5 months ago

  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Resolution set to Fixed

Strings are changed as follow:

"duplicates" to "is duplicate of"
"duplicated by" to "has duplicate"

Also available in: Atom PDF