Feature #15919

Set default category assignee immediately upon category selection

Added by Miodrag Milic almost 5 years ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:4.0.0
Resolution:Fixed

Description

Currently, the one can see default assignee only after the issue is created. This confuses people and it should be good to set it ASAP using AJAX call.

0001-Set-default_assigned_to_id-in-category.patch Magnifier (2.1 KB) Mizuki ISHIKAWA, 2017-10-31 07:08

0002-Set-default_assigned_to_id-in-project.patch Magnifier (1.06 KB) Mizuki ISHIKAWA, 2017-10-31 07:08

duplicated_assignee.png (71.8 KB) Marius BALTEANU, 2018-06-22 13:15


Related issues

Related to Redmine - Feature #26680: Show default assignee when creating new issue New
Related to Redmine - Defect #28951: Cannot clear category field on copying an Issue Closed
Related to Redmine - Defect #29695: Duplicated assignee option when selecting a category with... New

Associated revisions

Revision 17320
Added by Go MAEDA 7 months ago

Set default category assignee immediately upon category selection (#15919).

Patch by Mizuki ISHIKAWA.

Revision 17389
Added by Jean-Philippe Lang 6 months ago

Handle default assignee when changing category (#15919).

History

#1 Updated by Jean-Philippe Lang almost 5 years ago

  • Tracker changed from Defect to Feature

#2 Updated by Go MAEDA about 1 year ago

  • Related to Feature #26680: Show default assignee when creating new issue added

#3 Updated by Mizuki ISHIKAWA about 1 year ago

I wrote a patch to implement this feature.

Please try to apply this patch: 0001-Set-default_assigned_to_id-in-category.patch

In addition, applying this patch will allow you to set default project assignee in the same way:
0002-Set-default_assigned_to_id-in-project.patch

#4 Updated by Toshi MARUYAMA about 1 year ago

  • Target version set to 4.1.0

#5 Updated by Go MAEDA 7 months ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Priority changed from High to Normal
  • Target version changed from 4.1.0 to 4.0.0
  • Resolution set to Fixed

Committed the patch 0001-Set-default_assigned_to_id-in-category.patch. Thank you for improving Redmine.

I will commit the second patch 0002-Set-default_assigned_to_id-in-project.patch for #26680.

#6 Updated by Marius BALTEANU 7 months ago

  • Status changed from Closed to Reopened

This is a nice feature, indeed, but I think that the current implementation has some issues that we should address/clarify:

1. The default category assignee is not cleared when the category is changed with a category without assignee
- Go to new issue page
- Select a category with assignee
- Observe that the assignee is set correctly
- Change the category with a category without assignee
- Observe that assignee remains the previous one

The expected result from my point of view is to clear the assignee.

2. Manually selected assignee is override by the category assignee.
- Go to new issue page
- Manually select an assignee
- Select a category with assignee
- Observe that the manually selected assignee is replaced by the category assignee

The expected result here (and also the current behaviour until this ticket) is to keep the manually selected assignee.

3. Because there are a lot of scenarios and the code become quite complex, we should cover the cases with system tests.

I can help on fixing this issues and adding some tests, just please let me know.

#7 Updated by Jean-Philippe Lang 6 months ago

  • Status changed from Reopened to Closed

I made a small change that improves the behaviour when changing/removing the category and solves the 2 issues reported by Marius.

#8 Updated by Go MAEDA 6 months ago

  • Related to Defect #28951: Cannot clear category field on copying an Issue added

#9 Updated by Marius BALTEANU 6 months ago

  • File duplicated_assignee.png added
  • Status changed from Closed to Reopened
  • Assignee changed from Go MAEDA to Jean-Philippe Lang
  • Resolution deleted (Fixed)

I found another issue:

1. Go to a project with a default category assignee
2. Go to new issue page
3. Select the category with the default assignee
4. Open the Assignee dropdown
5. Observe that the default category assignee is duplicated in the dropdown.

The issue is generated by the line source:trunk/app/views/issues/new.js.erb#L6

#10 Updated by Marius BALTEANU 3 months ago

We can deliver this feature as it is and I will try to find a proper implementation for the next minor version of Redmine 4.

#11 Updated by Jean-Philippe Lang 3 months ago

  • Status changed from Reopened to Closed
  • Resolution set to Fixed

#12 Updated by Marius BALTEANU 2 months ago

  • Related to Defect #29695: Duplicated assignee option when selecting a category with default assignee added

Also available in: Atom PDF