Project

General

Profile

Actions

Defect #19059

closed

Wrong number of issues for a version in the roadmap

Added by Filou Centrinov over 9 years ago. Updated about 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Roadmap
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate
Affected version:

Description

Using a version for an open project that contains also archived subprojects cause problems with the shown number of issues for that version.

Issues from archived subprojects are also counted in the roadmap version but this is very confusing because they are not listed. The roadmap should only count issues from open projects.

version contains two issues but only one is shown


Files

roadmap_invisible_issues.png (26.2 KB) roadmap_invisible_issues.png version contains two issues but only one is shown Filou Centrinov, 2015-02-08 17:43

Related issues

Related to Redmine - Defect #19187: Roadmap links in subproject Closed

Actions
Is duplicate of Redmine - Patch #27676: Information leak on roadmap and versions viewClosedJean-Philippe Lang

Actions
Actions #1

Updated by Filou Centrinov over 9 years ago

  • Description updated (diff)
Actions #2

Updated by Sebastian Paluch about 9 years ago

This is not the only case when you can see mismatch.

The number shown will not match listed issues also when subprojects are open and using different trackers. In such case, available trackers for select in sidebar comes from the project only, not subprojects. When subproject is using a tracker that the projects is not using, it will not be listed in sidebar, so can't be selected and you will see less issues on the list then indicated by counters.

Actions #3

Updated by Toshi MARUYAMA about 9 years ago

Actions #4

Updated by Shai Gilboa over 8 years ago

Hi,
We also have the same issue with wrong numbers in roadmap counters, using 2.6.1.

Was this ever fixed in newer Redmine versions?
Thanks

Actions #5

Updated by Kevin Palm over 7 years ago

+1

Actions #6

Updated by Marius BĂLTEANU over 6 years ago

This issue was fixed by r17051.

I don't think that a test is required also for this scenario, it is covered by the test from #19187 and I propose to close this ticket with resolution "Duplicate".

Actions #7

Updated by Marius BĂLTEANU about 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Fixed by r17051.

Actions #8

Updated by Go MAEDA about 6 years ago

  • Is duplicate of Patch #27676: Information leak on roadmap and versions view added
Actions

Also available in: Atom PDF