Project

General

Profile

Actions

Patch #26655

closed

Additional icon for contextmenu

Added by Felix Gliesche over 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
UI
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

The contextmenu is a very helpful feature that can increase the productivity while working with redmine. Many people don't know of this great feature because it is only triggered by a right mouse click, which is not a common user interaction on the web. In order to make this feature more prominent this patch adds an icon to table rows that have a contextmenu, which allows to trigger the appearance of the contextmenu with a regular mouse click.

As there was no icon with three dots available in the famfamfam available, we created our own by using an existing icon with a dot.

This gif shows this new icon in action on the issues table:


Files

contextmenu.gif (71.4 KB) contextmenu.gif Felix Gliesche, 2017-08-09 12:37
vertical.png (109 KB) vertical.png Marius BALTEANU, 2017-08-14 21:58
mastodon-context-menu-button@2x.png (35.8 KB) mastodon-context-menu-button@2x.png Go MAEDA, 2017-08-16 02:52
26555-list_html_erb-for-r16971.diff (1.55 KB) 26555-list_html_erb-for-r16971.diff Go MAEDA, 2018-01-28 02:35
3_bullets.png (1.22 KB) 3_bullets.png Icon for context menu Go MAEDA, 2018-01-28 02:35
icon-for-subtasks@2x.png (18 KB) icon-for-subtasks@2x.png Go MAEDA, 2018-01-28 05:28
0001-Use-button-as-additional-option-for-contextmenu.patch (18.9 KB) 0001-Use-button-as-additional-option-for-contextmenu.patch Felix Gliesche, 2018-04-19 16:05

Related issues

Related to Redmine - Feature #5711: Make Bulk Edit menu more apparent...New2010-06-18

Actions
Related to Redmine - Feature #28829: Add right-click context menu to the contextual area of an issueReopenedGo MAEDA

Actions
Has duplicate Redmine - Feature #1590: Awkward way of accessing shortcut menu in issue listClosed2008-07-06

Actions
Has duplicate Redmine - Defect #5739: Direct access to Issue update from issue listClosed2010-06-23

Actions
Has duplicate Redmine - Feature #29074: Add "Edit" function to entries in "Spent Time" block appropriatelyClosed

Actions
Actions #1

Updated by Jan from Planio www.plan.io over 5 years ago

  • Target version set to Candidate for next minor release
Actions #2

Updated by Jan from Planio www.plan.io over 5 years ago

  • File deleted (contextmenu.gif)
Actions #4

Updated by Jan from Planio www.plan.io over 5 years ago

  • Tracker changed from Defect to Patch
Actions #5

Updated by Go MAEDA over 5 years ago

+1

Felix Gliesche wrote:

Many people don't know of this great feature because it is only triggered by a right mouse click, which is not a common user interaction on the web.

I think it is exactly right. It is very good idea to make the context menu obvious.

Actions #6

Updated by Luis Blasco over 5 years ago

You're absolutely right. Context menu is not used, too "hidden". This is a very good solution.

Actions #7

Updated by Jan from Planio www.plan.io over 5 years ago

The patch is based on user research we did for Planio Redmine Hosting. We also surveyed a number of other platforms which use item list representations and context menus (Dropbox, Nextcloud, box.net, etc.). A horizontal three dotted icon seems by far to be the most common trigger for a context menu these days. Right click without alternative was only present in a few examples (e.g. Google Drive). The feature will be rolling out at Planio soon and I would love for this to become part of Redmine as well!

Actions #8

Updated by Go MAEDA over 5 years ago

  • Target version changed from Candidate for next minor release to 4.1.0

The icon greatly improves usability.
Setting target version to 4.1.0.

Actions #9

Updated by Marius BALTEANU over 5 years ago

Very nice feature, especially that it will make the context menu available on the mobile.

It looks good also with a vertical three dotted icon.

Actions #10

Updated by Felix Schäfer over 5 years ago

Marius BALTEANU wrote:

It looks good also with a vertical three dotted icon.

This would be confusing as the vertical dots are already used as drag and drop handlers for trackers, enumerations, statuses and so on.

Actions #11

Updated by Marius BALTEANU over 5 years ago

Felix Schäfer wrote:

Marius BALTEANU wrote:

It looks good also with a vertical three dotted icon.

This would be confusing as the vertical dots are already used as drag and drop handlers for trackers, enumerations, statuses and so on.

From my knowledge, the drag and drop handlers have a green arrow as icon. Anyway, it is not so important how the dots are displayed, both options look good to me and also, the dots can be easily rotated only from CSS. I just wanted to point out this alternative.

Actions #12

Updated by Felix Schäfer over 5 years ago

Marius BALTEANU wrote:

From my knowledge, the drag and drop handlers have a green arrow as icon.

You are right, I am sorry, the 3 dots are used in a theme, and vertical dots are used as drag and drop handlers in Gmail for example too.

Actions #13

Updated by Felix Gliesche over 5 years ago

  • File 0001-Use-button-as-additional-option-for-contextmenu.patch added

I am attaching an updated patch, that sets correct colspan when grouping issue lists.

Actions #14

Updated by Jan from Planio www.plan.io over 5 years ago

  • File deleted (0001-Use-button-as-additional-option-for-contextmenu.patch)
Actions #15

Updated by Go MAEDA over 5 years ago

FYI:
Mastodon (social network server) uses horizontal three dots button for context menu.

Actions #16

Updated by Toshi MARUYAMA over 5 years ago

  • Description updated (diff)
Actions #17

Updated by Go MAEDA over 5 years ago

  • Has duplicate Feature #1590: Awkward way of accessing shortcut menu in issue list added
Actions #18

Updated by Mischa The Evil over 5 years ago

  • Related to Feature #5711: Make Bulk Edit menu more apparent... added
Actions #19

Updated by Go MAEDA about 5 years ago

I made a slight change to the patch because I couldn't apply to the current trunk (r16971 and later).

And the patch doesn't include 3_bullets.png, so I stole the icon from Planio :)

Actions #20

Updated by Go MAEDA about 5 years ago

I found a small problem that the context menu icon is displayed in a wrong position for subtasks. No problem for related issues. I also confirmed the very similar problem in my Planio account.

Felix Gliesche, could you fix this?

Actions #21

Updated by Felix Gliesche about 5 years ago

Go MAEDA wrote:

I found a small problem that the context menu icon is displayed in a wrong position for subtasks. No problem for related issues. I also confirmed the very similar problem in my Planio account.

Felix Gliesche, could you fix this?

Sure, I'll have a look into it.

Actions #22

Updated by Felix Gliesche about 5 years ago

  • File 0001-Use-button-as-additional-option-for-contextmenu.patch added

I am uploading a patch, that should apply to the current trunk. The problem, you are referencing to is related to missing mobile optimiziation. I added missing styles to public/stylesheets/responsive.css as you can see in the updated version of the patch.

Actions #23

Updated by Felix Gliesche about 5 years ago

  • File 0001-Use-button-as-additional-option-for-contextmenu.patch added

I had to update the patch (see attached). Could you please delete the previous one, to avoid confusion?

Actions #24

Updated by Felix Gliesche about 5 years ago

  • File 0001-Use-button-as-additional-option-for-contextmenu.patch added

I found, that the text shines through, due to right padding, which is not necessary on mobile devices. I removed this, whit this updated patch. Please use this one ;)

Actions #25

Updated by Marius BALTEANU about 5 years ago

  • File deleted (0001-Use-button-as-additional-option-for-contextmenu.patch)
Actions #26

Updated by Marius BALTEANU about 5 years ago

  • File deleted (0001-Use-button-as-additional-option-for-contextmenu.patch)
Actions #27

Updated by Marius BALTEANU about 5 years ago

  • File deleted (0001-Use-button-as-additional-option-for-contextmenu.patch)
Actions #28

Updated by Go MAEDA about 5 years ago

  • Status changed from Needs feedback to New

Thank you for updating the patch. Now it works perfectly. I think this feature should be a part of Redmine 4.0 / 4.1.

Actions #29

Updated by Go MAEDA almost 5 years ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Target version changed from 4.1.0 to 4.0.0

Committed. Thank you for sharing this great improvement.

Actions #30

Updated by Go MAEDA almost 5 years ago

  • Status changed from Closed to Reopened
  • Assignee deleted (Go MAEDA)
  • Target version changed from 4.0.0 to 4.1.0

Reverted r17252 and r17253 because the patch breaks the test suite.

Actions #31

Updated by Go MAEDA almost 5 years ago

  • Assignee set to Felix Gliesche

After applying the patch, an exception is raised if a user who does not have "Manage related issues" permission opens an issue with one or more related issues. You can also confirm the problem by running test/functional/issues_controller_test.rb.

But I noticed that this bug has already fixed in Planio. Could you kindly provide a patch based on the current Planio's code base?

Actions #32

Updated by Felix Gliesche almost 5 years ago

Go MAEDA wrote:

After applying the patch, an exception is raised if a user who does not have "Manage related issues" permission opens an issue with one or more related issues. You can also confirm the problem by running test/functional/issues_controller_test.rb.

But I noticed that this bug has already fixed in Planio. Could you kindly provide a patch based on the current Planio's code base?

Sure, I will have a look into it. Already working on the patch, so that it does not break the test suite.

Actions #33

Updated by Felix Gliesche almost 5 years ago

Go MAEDA wrote:

Committed. Thank you for sharing this great improvement.

I am uploading the updated patch. It does not break the test suite and fixes the problem for users without the "manage related issues" permission that you mentioned.

Actions #34

Updated by Jan from Planio www.plan.io almost 5 years ago

  • File deleted (0001-Use-button-as-additional-option-for-contextmenu.patch)
Actions #35

Updated by Go MAEDA almost 5 years ago

  • Status changed from Reopened to Resolved

Committed. Thank you so much for updating the patch.

Actions #36

Updated by Go MAEDA almost 5 years ago

  • Status changed from Resolved to Closed
Actions #37

Updated by Go MAEDA almost 5 years ago

  • Target version changed from 4.1.0 to 4.0.0
Actions #38

Updated by Go MAEDA almost 5 years ago

  • Assignee changed from Felix Gliesche to Go MAEDA
Actions #39

Updated by Go MAEDA almost 5 years ago

  • Related to Feature #28829: Add right-click context menu to the contextual area of an issue added
Actions #40

Updated by Go MAEDA almost 5 years ago

  • Has duplicate Defect #5739: Direct access to Issue update from issue list added
Actions #41

Updated by Marius BALTEANU almost 5 years ago

  • Has duplicate Feature #29074: Add "Edit" function to entries in "Spent Time" block appropriately added
Actions

Also available in: Atom PDF