Defect #30312

Cannot know whether a wiki page is locked unless clicking the drop-down menu

Added by Go MAEDA 5 months ago. Updated 27 days ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:UI
Target version:-
Resolution:Duplicate Affected version:4.0.0

Description

The change r17678 moved some action links on a wiki page to the drop-down menu. Lock/Unlock button was moved as well.

Due to the change, you cannot know whether the wiki page is locked without clicking the drop-down menu. The buttons also have a function to show the locked/unlocked status of a page. I think the change made usability worse because Lock/Unlock status of a wiki page is one of the important information.

I propose the change to making the Lock/Unlock icon visible again.

before@2x.png (20.6 KB) Go MAEDA, 2019-01-04 06:07

after@2x.png (21.2 KB) Go MAEDA, 2019-01-04 06:07

show-lock-button-on-wiki-pages.diff Magnifier - patch (1.57 KB) Go MAEDA, 2019-01-04 06:10


Related issues

Duplicates Redmine - Feature #9634: Show locked badge for locked wiki pages Closed 2011-11-22

History

#1 Updated by Go MAEDA 5 months ago

  • Related to Feature #9634: Show locked badge for locked wiki pages added

#2 Updated by Marius BALTEANU 5 months ago

I know that the fastest solution is to make the button visible again, but I'm not sure if is the best solution. In my opinion, it is quite hard to get the status of the page based on the button.

What do you think if we show the status as a badge next to the wiki page title (as I proposed for the versions in #29391)? And maybe to show it only for the locked pages. Another option is to show the "locked" icon instead of the badge.

#3 Updated by Bernhard Rohloff 5 months ago

Marius BALTEANU wrote:

What do you think if we show the status as a badge next to the wiki page title (as I proposed for the versions in #29391)? And maybe to show it only for the locked pages. Another option is to show the "locked" icon instead of the badge.

I actually like the idea of a "locked" badge next to the page title as it would introduce badges more widespread in Redmine and is more obvious.

#4 Updated by Go MAEDA 5 months ago

Marius BALTEANU wrote:

What do you think if we show the status as a badge next to the wiki page title (as I proposed for the versions in #29391)? And maybe to show it only for the locked pages. Another option is to show the "locked" icon instead of the badge.

I think it is a nicer solution than I suggested. Actually, my solution is not useful for ordinary users because the lock/unlock button is visible for only privileged users. Currently, they cannot know the reason why the wiki page is not editable. The problem is reported as #9634.

Maybe your solution is visible for every user who has access to wiki pages, so it addresses #9634.

#5 Updated by Jean-Philippe Lang 4 months ago

  • Target version changed from 4.0.1 to 4.0.2

#6 Updated by Jean-Philippe Lang 3 months ago

  • Target version changed from 4.0.2 to Candidate for next minor release

#7 Updated by Marius BALTEANU 27 days ago

  • Related to deleted (Feature #9634: Show locked badge for locked wiki pages)

#8 Updated by Marius BALTEANU 27 days ago

  • Duplicates Feature #9634: Show locked badge for locked wiki pages added

#9 Updated by Marius BALTEANU 27 days ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for next minor release)
  • Resolution set to Duplicate

We'll fix this issue in #9634.

Also available in: Atom PDF