Project

General

Profile

Actions

Feature #3395

closed

add ability to filter on blank start and end, etc. date fields in Issues panel

Added by Mark Pettigrew almost 15 years ago. Updated over 12 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
UI
Target version:
-
Start date:
2009-05-20
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

add ability to filter on blank start and end date fields in Issues panel

Issues may be created without a start or end due date. It would very useful to be able to search for these issues explicitly so that can be updated with a start/end date easily.


Files

3395_add_operators_to_date.diff (841 Bytes) 3395_add_operators_to_date.diff Holger Just, 2010-07-02 12:20

Related issues

Related to Redmine - Feature #3600: Allow blank / empty filter values for all issue fieldsClosed2009-07-09

Actions
Has duplicate Redmine - Defect #8507: Unable to filter by empty due date?Closed2011-06-02

Actions
Is duplicate of Redmine - Feature #9607: Filter for issues without start date (or any another field based on date type)ClosedJean-Philippe Lang2011-11-19

Actions
Actions #1

Updated by Anthony Gerrard over 14 years ago

Added issue #3600 as the more generic requirement of this one

Actions #2

Updated by Josh Galvez almost 14 years ago

#3868 is also related

Actions #3

Updated by Fri Flaj over 13 years ago

It's a very easy fix, too. I put a plugin on github that will monkey-patch it in, but it would be easy to add to RM itself

Plugin @ http://github.com/friflaj/redmine_has_due_date/

Actions #4

Updated by Holger Just over 13 years ago

This patch adds the two operators (all and none) to the date filter type. This is exactly the same as what Emiliano is doing in his plugin above.

Actions #5

Updated by pasquale [:dedalus] almost 13 years ago

+1

Actions #6

Updated by Etienne Massip over 12 years ago

  • Subject changed from add ability to filter on blank start and end date fields in Issues panel to add ability to filter on blank start and end, etc. date fields in Issues panel
  • Target version set to Candidate for next major release
Actions #7

Updated by Gerry Hawkins over 12 years ago

+1
It would tie in nicely with #6954 which also improves handling of dates

Actions #8

Updated by Mischa The Evil over 12 years ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for next major release)
  • Resolution set to Duplicate

Implemented in r7841, making this issue superseded by issue #9607 (reflected by a duplicates relation for want of anything better).

Actions

Also available in: Atom PDF