Project

General

Profile

Actions

Feature #6417

closed

Allow collapse/expand in gantt chart

Added by N G over 13 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Gantt
Target version:
Start date:
2010-09-16
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed

Description

Eric - it would be great if there was a way to collapse nested structures in the Gantt chart plugin you developed.. for example, if we don't want to see all the tasks/bugs for our versions, but just want a high level picture of what's coming up, it would be nice to be able to collapse each version to a single row that shows the due date for the version. Possible? Thanks!


Files

expand_gantt.png (346 KB) expand_gantt.png Yuichi HARADA, 2019-01-31 03:27
collapse_gantt.png (293 KB) collapse_gantt.png Yuichi HARADA, 2019-01-31 03:28
6417-collapse-expand-gantt.patch (11.1 KB) 6417-collapse-expand-gantt.patch Yuichi HARADA, 2019-01-31 03:38
virtical-alignment@2x.png (23.8 KB) virtical-alignment@2x.png Go MAEDA, 2019-02-25 14:02
6417-collapse-expand-gantt-v2.patch (11.3 KB) 6417-collapse-expand-gantt-v2.patch Yuichi HARADA, 2019-03-04 05:39
6417-collapse-expand-gantt-v3.patch (12.5 KB) 6417-collapse-expand-gantt-v3.patch Yuichi HARADA, 2019-03-05 03:42

Related issues

Related to Redmine - Feature #8897: Be able to reorder tasks/issues in the Gantt chartNew2011-07-25

Actions
Related to Redmine - Defect #32812: Clicking on a parent object in gantt wrongly collapses objects at the same levelClosedGo MAEDA

Actions
Has duplicate Redmine - Feature #13063: Make Gantt chart issues collapsible Closed

Actions
Has duplicate Redmine - Feature #11636: tree structure of GanttClosed

Actions
Has duplicate Redmine - Feature #26467: expand & collapse gantt chart listClosed

Actions
Actions #1

Updated by Eric Davis over 13 years ago

  • Category set to Gantt
  • Assignee deleted (Eric Davis)

It would be possible but it will take a lot of work because of how the Gantt chart is rendered. If someone wants to work on this, I'd be happy to review a patch for it.

Actions #2

Updated by Hans Bangkok about 13 years ago

+1 I've got a lot of Versions (non-software PM "milestones")

At least being able to collapse the Roadmap's version sections would be start - and probably easier?

Actions #3

Updated by Pierluigi Soana over 12 years ago

+1

Actions #4

Updated by Artem Tykhonov almost 12 years ago

+1

Actions #5

Updated by Cassiano Monteiro almost 12 years ago

+1!

Actions #6

Updated by Terence Mill almost 12 years ago

+1

Actions #7

Updated by Robert Johnson almost 12 years ago

+1

Actions #8

Updated by Luis Serrano Aranda over 11 years ago

+1

Actions #9

Updated by Dipan Mehta about 11 years ago

This is a duplication of #1294 which is closed in favor of #12032 + #10525.

Actions #10

Updated by Toshi MARUYAMA about 11 years ago

Dipan Mehta wrote:

This is a duplication of #1294 which is closed in favor of #12032 + #10525.

No. This issue is "collapse/expand in Gantt chart" like Redmine SCM browser.

Actions #11

Updated by Toshi MARUYAMA almost 10 years ago

Actions #12

Updated by Toshi MARUYAMA almost 10 years ago

  • Related to Feature #8897: Be able to reorder tasks/issues in the Gantt chart added
Actions #13

Updated by James H over 9 years ago

+1

Actions #14

Updated by Alexander Mikheyev about 8 years ago

Hi all,
is any progress on collapse/expand Gantt tasks hierarchy?

Actions #15

Updated by Florian Riedel over 7 years ago

+1

Actions #16

Updated by Mischa The Evil over 6 years ago

  • Has duplicate Feature #26467: expand & collapse gantt chart list added
Actions #17

Updated by Randa Bustami over 6 years ago

Hi All,
is there a chance to make it soon pls ?

Actions #18

Updated by Mizuki ISHIKAWA over 6 years ago

+1

Actions #19

Updated by Yuichi HARADA about 5 years ago

I created the function collapse/expand of the Gantt chart.
I attached a patch.

[Expand]

[Collapse]

Actions #20

Updated by Go MAEDA about 5 years ago

  • Target version set to Candidate for next major release
Actions #21

Updated by Go MAEDA about 5 years ago

  • Target version changed from Candidate for next major release to 4.1.0

LGTM. It is an excellent improvement. Setting the target version to 4.1.0.

Actions #22

Updated by Go MAEDA about 5 years ago

After applying the patch, objects in the same indentation level are not horizontally aligned. Please see the screenshot below. Could you check the patch?

Actions #23

Updated by Yuichi HARADA about 5 years ago

Go MAEDA wrote:

After applying the patch, objects in the same indentation level are not horizontally aligned. Please see the screenshot below. Could you check the patch?

I adjusted the horizontal position. #html_subject method's params is the Hash object. Because we inherited params[:indent] (Horizontal position), the calculation result of params[:indent] of the new parent hierarchy was wrong.
I rebuilt the patch.

Actions #24

Updated by Go MAEDA about 5 years ago

I confirmed that all issues in the previous patch have been fixed. Thank you for working on this. I will commit this patch within a few days.

Actions #25

Updated by Go MAEDA about 5 years ago

  • Status changed from New to Closed
  • Assignee set to Go MAEDA
  • Resolution set to Fixed

Committed the patch. Thank you for your contribution.

Actions #26

Updated by Go MAEDA about 5 years ago

  • Subject changed from Allow collapse/expand in Gantt chart to Allow collapse/expand in gantt chart
Actions #27

Updated by Go MAEDA about 5 years ago

  • Status changed from Closed to Reopened
  • Resolution deleted (Fixed)

The patch breaks GanttHelperTest. Could you fix the failing tests?

Actions #28

Updated by Yuichi HARADA about 5 years ago

Go MAEDA wrote:

The patch breaks GanttHelperTest. Could you fix the failing tests?

Sorry, I fixed the failed tests.
I rebuilt a patch.

Actions #29

Updated by Go MAEDA about 5 years ago

  • Status changed from Reopened to Closed
  • Resolution set to Fixed

Committed. Thanks.

Actions #30

Updated by Abc4329803 ZHE about 5 years ago

[root@host plugins]# patch /-p0 < 6417-collapse-expand-gantt-v3.patch
can't find file to patch at input line 5
Perhaps you used the wrong /-p or /-/-strip option?
The text leading up to this was:
-------------------------- |diff --git a/app/views/gantts/show.html.erb b/app/views/gantts/show.html.erb |index 90f6a85fa..a51abdcde 100644 |--- a/app/views/gantts/show.html.erb |+++ b/app/views/gantts/show.html.erb
--------------------------

My redmine version is 3.4.

Why I have this problem?

Actions #31

Updated by Matt M almost 5 years ago

I just applied the patch to a 4.0.2 install, I noticed an issue though collapsing, I have a very complex hierarchy and this patch completely disrupts it. I.E. a sub-project of a sub-project of a primary project gets lumped under the version of the sub-project, and is not collapsible, which causes issues with the rendering of the hierarchy and collapsing further down, I.E. collapsing a sub-project encapsulates the last sub-project within the main project. I would put pics but my layout is complex :) I got a pic to show an example.

In this pic if I collapse Mechanical Design then software will disappear, even though they are inline projects.

Actions #32

Updated by Go MAEDA about 4 years ago

  • Related to Defect #32812: Clicking on a parent object in gantt wrongly collapses objects at the same level added
Actions

Also available in: Atom PDF