Patch #6690

Redmine link to user profile

Added by Ahmad Azhar about 10 years ago. Updated over 3 years ago.

Status:ClosedStart date:2010-10-18
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Text formatting
Target version:-

Description

new redmine link keyword to user profile.

format: user#1 or user:admin

redmine-userlink.diff Magnifier (1.66 KB) Ahmad Azhar, 2010-10-18 06:49

userlink.patch Magnifier (1.81 KB) Alexander Meindl, 2012-06-12 11:34

userlink-1.4.4.patch Magnifier (1.89 KB) Vincent Metalhead, 2012-09-16 07:48


Related issues

Related to Redmine - Feature #5228: Users are just numbers Closed 2010-03-31
Duplicates Redmine - Feature #4179: Link to user in wiki syntax Closed 2009-11-08

History

#1 Updated by Jean-Baptiste Barth almost 10 years ago

  • Category set to Text formatting
  • Status changed from New to 7
  • Assignee set to Jean-Baptiste Barth
  • Target version set to 1.1.0
Good idea, but it comes with some (minor) problems:
  • it should have some unit tests
  • link_to_user helper doesn't work the same as other link_to_* ; we can't add only_path option nor css classes easily

I'll have a look at it before 1.1.0.

#2 Updated by Jean-Philippe Lang almost 10 years ago

The problem with this patch is that it breaks the users privacy. It would allow someone to see the name of any user, which is not what UsersController#show does.

#3 Updated by Jean-Philippe Lang almost 10 years ago

  • Target version changed from 1.1.0 to Unplanned backlogs

1.1 feature freeze.

#4 Updated by Etienne Massip over 9 years ago

  • Target version changed from Unplanned backlogs to Candidate for next major release

#5 Updated by Josh Nijenhuis over 8 years ago

Will this allow multiple users?

User:me,you,who

#6 Updated by Etienne Massip over 8 years ago

Josh Nijenhuis wrote:

Will this allow multiple users?

It's very unlikely, mainly for consistency with other link types.

#7 Updated by Jean-Baptiste Barth over 8 years ago

  • Assignee deleted (Jean-Baptiste Barth)

#8 Updated by Alexander Meindl over 8 years ago

I updated the patch for redmine 1.4.3

#9 Updated by Rainer Putzinger about 8 years ago

+1

This feature request, as well as a first implementation approach, seems to stick around here for quite some time now. I would greatly appreciate this feature, as we could include references to contact persons qite easily.

#10 Updated by Terence Mill about 8 years ago

+1

#11 Updated by Vincent Metalhead about 8 years ago

Updated the patch for Redmine 1.4.4-stable.

cd /path/to/redmine
wget http://www.redmine.org/attachments/download/8216/userlink-1.4.4.patch
patch -p0 < userlink-1.4.4.patch

+1

#13 Updated by Jean-Philippe Lang almost 8 years ago

  • Status changed from 7 to New

Assigned issue with no assignee back to New status.

#14 Updated by Rainer Putzinger over 7 years ago

+1
I would also greatly appreciate this enhancement. Does not seem to be a big deal! :-)

#15 Updated by Marcello Pontes about 7 years ago

+1

:)

#16 Updated by Toshi MARUYAMA about 7 years ago

  • Duplicates deleted (Feature #4179: Link to user in wiki syntax)

#17 Updated by Toshi MARUYAMA about 7 years ago

#19 Updated by Ве Fio over 6 years ago

+1

#20 Updated by Marius BALTEANU over 3 years ago

Link to user profile was committed in #4179. The following syntaxes are supported:
  • user:login
  • @login

and a new proposal was made to support also user:1.

I think that we can close this issue too.

#21 Updated by Mischa The Evil over 3 years ago

  • Related to deleted (Feature #4179: Link to user in wiki syntax)

#22 Updated by Mischa The Evil over 3 years ago

#23 Updated by Mischa The Evil over 3 years ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for next major release)

Marius BALTEANU wrote:

I think that we can close this issue too.

Indeed. Closing it as a duplicate of #4179.

Also available in: Atom PDF