Feature #7842

Creation new users by non-admin user

Added by Aliaksandr Salenka over 8 years ago. Updated 2 months ago.

Status:NewStart date:2011-03-11
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Accounts / authentication
Target version:-
Resolution:

Description

It should be very userfull to allow user creation for non-administrativ users. For example - I have redmine instance containing some projects, wana to allow user with project-management role to create new users, but don't want to grant him admin rights for whole instance.


Related issues

Duplicated by Redmine - Feature #14440: Role to create New user Closed
Duplicated by Redmine - Feature #12449: Role/permission to make new users Closed

History

#1 Updated by Daniel Herrera about 8 years ago

+1
I believe in an automanaged system without the intervention of the administrator each time the organisation require add new members or projects needs to be closed (#7100).

#2 Updated by Jacques Bodin-Hullin over 6 years ago

+1
It would be great :)

#3 Updated by Ariel Lira almost 5 years ago

Is this issue stil pending in redmine trunk? I need exactly the same: a "create user" permission.
Also note that tickets #14440 and #12449 seem duplicate of this one.

Thanks

#4 Updated by Jean-Baptiste Barth almost 5 years ago

#5 Updated by Jean-Baptiste Barth almost 5 years ago

#6 Updated by Jean-Baptiste Barth almost 5 years ago

  • Related to deleted (Feature #12449: Role/permission to make new users)

#7 Updated by Jean-Baptiste Barth almost 5 years ago

#8 Updated by Jean-Baptiste Barth almost 5 years ago

  • Related to deleted (Feature #12449: Role/permission to make new users)

#9 Updated by Jean-Baptiste Barth almost 5 years ago

  • Duplicated by Feature #12449: Role/permission to make new users added

#10 Updated by Jean-Baptiste Barth almost 5 years ago

I confirm this is still not possible in current redmine versions. It may not be really difficult to implement on the logic side, but I don't really know how to deal with that in the UI. For now "users management" views are in the admin section, which we can't expose to all users obviously. Any take on that ?

#11 Updated by Renzo Dani almost 5 years ago

+1

#12 Updated by Michael Esemplare almost 5 years ago

Jean-Baptiste Barth wrote:

I confirm this is still not possible in current redmine versions. It may not be really difficult to implement on the logic side, but I don't really know how to deal with that in the UI. For now "users management" views are in the admin section, which we can't expose to all users obviously. Any take on that ?

One idea would be extending the role paradigm to admins/user accounts. We then have system roles which would allow more granular permissions.

  • Manage projects
  • Manage users
    • Create user
    • Modify user
    • Delete user
  • Manage system settings
  • etc.

#13 Updated by Dennis Schridde over 4 years ago

Any news regarding implementation of this?

#14 Updated by strait way over 3 years ago

how can I created project for myself

#15 Updated by Hans Kaiser about 1 year ago

this feature request is 7y old, are there any updates on this feature?

#16 Updated by Ezequiel Nicolazzi 7 months ago

Any news on this?

#17 Updated by Richard Holyoak 2 months ago

Really need this as I don't want to give full administration control for the whole site to someone who should just be able to manage user accounts.

Also available in: Atom PDF