Project

General

Profile

Actions

Defect #8853

closed

Filter on subproject does not work

Added by Joshua Stein almost 13 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Issues filter
Target version:
-
Start date:
2011-07-19
Due date:
% Done:

0%

Estimated time:
Resolution:
Wont fix
Affected version:

Description

filtering an issue list based on subproject does not work.

Steps to Reproduce:
  1. Go to the Issues list for a project that has sub-projects
  2. Add a filter for "Subproject"
  3. set "Subproject" is subproject name

Notice that results are not filtered.

This bug was found on our own Redmine server running 1.0.1. It was upgraded to 1.2.1 but the bug still exists.

I then tried on the Redmine Demo site. It is still an issue there.

I saved a query for sample.
http://demo.redmine.org/projects/11111project/issues?query_id=134


Files

subprojects_query_filter_fix.patch (2.03 KB) subprojects_query_filter_fix.patch patch against 1.3-stable to fix filtering by subproject Jens Krämer, 2012-03-20 13:33

Related issues

Related to Redmine - Defect #8603: Query 'without subprojects' cannot be createdNew2011-06-14

Actions
Related to Redmine - Feature #3952: Filtering by subproject still shows current project's issuesNew2009-10-01

Actions
Is duplicate of Redmine - Defect #2512: Subproject filter do not workClosedMischa The Evil2009-01-15

Actions
Actions #1

Updated by Joshua Stein over 12 years ago

this issue may be related to Issue #8603.

Actions #2

Updated by Jens Krämer over 12 years ago

Attached is a patch against 1.3-stable that fixes the issue by only finding issues from the selected sub projects, but excluding issues from the parent project.

The patch also fixes the german translation of field_subproject (which until now was more like 'subproject of' which is wrong given the way the query works).

Actions #3

Updated by Anonymous over 11 years ago

This issue still affects new versions of Redmine (using 2.0.3-stable).

Actions #4

Updated by Олег Петрачев almost 11 years ago

I have the same issue with 2.3.0.

Actions #5

Updated by Filip Wuyts over 10 years ago

Issue still exists in 2.4.1

Actions #6

Updated by Ilya Popov over 7 years ago

Problem still exists in 3.3.1 and 3.3.0. When filtering based on subproject also getting issues from the parent project.
Environment:
Redmine version 3.3.1.stable
Ruby version 2.3.0-p0 (2015-12-25) [x86_64-linux]
Rails version 4.2.7.1
Environment production
Database adapter Mysql2

Actions #7

Updated by Go MAEDA over 7 years ago

  • Category set to Issues filter
Actions #8

Updated by Go MAEDA over 7 years ago

  • Is duplicate of Defect #2512: Subproject filter do not work added
Actions #9

Updated by Go MAEDA over 7 years ago

  • Status changed from New to Closed
  • Resolution set to Wont fix

Jean-Phillipe Lang said that "this is not a bug but a design choice" in #2512#note-3.

Actions #10

Updated by Mischa The Evil over 7 years ago

Go MAEDA wrote:

Jean-Phillipe Lang said that "this is not a bug but a design choice" in #2512#note-3.

FWIW and FTR: Jean-Phillipe Lang also expressed (in #5388-1: "Maybe we should change this behaviour.") that it might be a good time to change the current behaviour to omit the current project's issues; as was achieved by the, meanwhile, outdated patch by Jens. Therefor I'd recommend to continue discussion about this change in the current issue, tracking the proposal to change the current behaviour, which is #3952. I also recommend to transfer Jens's patch to it, so that it can be updated/refined through that issue.

Actions #11

Updated by Mischa The Evil over 7 years ago

  • Related to Feature #3952: Filtering by subproject still shows current project's issues added
Actions

Also available in: Atom PDF