Feature #5458

Extend Start/Due date to include time

Added by Vladimir Dzalbo over 7 years ago. Updated 11 months ago.

Status:NewStart date:2010-05-06
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:-
Resolution:

Description

Can a very good feature to add time fields for the Start / Due dates.

It become especially interesting when Redmine is used as a Helpdesk took (to validate against Service Level Agreements) or in projects with very short tasks.

It also becomes interesting when you use Redmine to prioritize your tasks and schedule planned activities.

use_time_in_issue_start_and_due_date.patch.gz (2.41 KB) David Mayr, 2011-03-27 16:32

5458-use_time_in_issue_start_and_due_date_2.3_stable.diff Magnifier - Patch to add time to start/due date in issues for redmine 2.3 (12 KB) Evzen Sindelar, 2013-06-05 18:11

production.log (79.7 KB) Dileep Kumar, 2013-06-25 14:48

5458-use_time_in_issue_start_and_due_date_2.3_stable.diff Magnifier - Patch to add time to start/due date in issues for redmine 2.3. (13 KB) Luis Roa, 2013-08-07 01:29

5458-use_time_in_issue_start_and_due_date_2.3_stable_v3.diff Magnifier (13.2 KB) Rupesh Helwade, 2013-08-23 11:13

5458-use_time_in_issue_start_and_due_date_2.3_stable.diff Magnifier (13.7 KB) Alex Latchford, 2013-08-29 15:23

5458-use_time_in_issue_start_and_due_date_2.3_stable_v5.diff Magnifier - v5 of the patch (18.5 KB) Alex Latchford, 2013-09-10 16:42

5458-use_time_in_issue_start_and_due_date_2.3_stable_v6.diff Magnifier (20.1 KB) Alex Latchford, 2013-09-16 16:20

5458-use_time_in_issue_start_and_due_date_2.3_stable_v7.diff Magnifier (20.9 KB) Alex Latchford, 2013-09-24 11:32

5458-use_time_in_issue_start_and_due_date_2.3_stable_v8.diff Magnifier (21 KB) Alex Latchford, 2013-09-24 12:27

5458-use_time_in_issue_start_and_due_date_2.3_stable_V9.diff Magnifier (21.4 KB) Alex Latchford, 2013-10-03 13:07

err.png (95.4 KB) Alex Latchford, 2013-10-03 13:07

5458-use_time_in_issue_start_and_due_date_2.3_stable_V9 (2).diff Magnifier - Correction at line number 132 of the patch file (21.4 KB) Rupesh Helwade, 2014-02-26 06:12

46.diff Magnifier (162 KB) Toshi MARUYAMA, 2014-11-16 23:31

custom_fields_datetime_redmine_2.5.2.patch Magnifier - patch datetimepicker custom fields 2.5.2 (153 KB) Emmanuel Hidalgo, 2014-11-27 22:43

5458-use_time_in_issue_start_and_due_date_2.3_stable_V9_3.diff Magnifier (21.2 KB) Sergey Karpushin, 2016-01-28 16:02

Test_Redmine_v3.3.0.png (67.6 KB) Víctor Farell, 2016-07-13 14:35

Prod_Redmine_v2.5.1.png (49.4 KB) Víctor Farell, 2016-07-13 14:35


Related issues

Related to Redmine - Feature #13834: Can we change the jquery file with other versions New
Related to Redmine - Feature #15021: Service Level Agreement (SLA), more user-friendly email c... New 2013-10-17
Related to Redmine - Feature #11044: Custom field types for time and datetime New
Duplicated by Redmine - Feature #13782: Date and Time for Start Date and Due Date Closed
Duplicated by Redmine - Feature #1885: Change Start from date to datetime Closed 2008-09-11
Duplicated by Redmine - Feature #20820: Time of day (not only date) as a deadline for a task. Closed

History

#1 Updated by Eraldo Girardi over 7 years ago

+1
That's just what we need in my company.
The helpdesk guys simply need to insert how many days a task will take to be accomplished.

#2 Updated by Nigel Jones over 7 years ago

+1
This would help us organise tasks without resorting to MS Project

#3 Updated by David Mayr over 6 years ago

Hi all,

we also need this for a customer so I wrote a patch against redmine-1.1.1.
Now you can choose per project if you want to be able to include the time for start_date and due_date.
Comments and improvements welcome :-)
Would be nice if this could be included in the uptream code base.

Thanks in advance,
David

#4 Updated by Kevin Thompson over 6 years ago

I would also like to see this included in the code base. I get nervous about applying a patch to my production system and coming to depend on the functionality and then have it break in future releases. Who makes the decision about whether or not this gets included and what version is gets targeted for?

#5 Updated by Anonymous over 6 years ago

I'd like to second Kevin's request - I'd like to see this included in 1.2.x and forward.

#6 Updated by John Olinger over 5 years ago

I tried to install this patch on 1.3.2 (Turnkey Linux - Redmine Appliance) and I get errors starting with....

root@redmine www/railsapp# patch p0 < use_time_in_issue_start_and_due_date.patch
patching file redmine-1.1.1_use_time_for_issues/app/helpers/application_helper.rb
Hunk #1 FAILED at 918.
1 out of 1 hunk FAILED -
saving rejects to file redmine-1.1.1_use_time_for_issues/app/helpers/application_helper.rb.rej
patching file redmine-1.1.1_use_time_for_issues/app/helpers/queries_helper.rb
Hunk #1 FAILED at 38.

My syntax for patching is from http://www.redmine.org/projects/redmine/wiki/Patch

What am I doing wrong? Or does there need to be a newer patch?

#7 Updated by Toshi MARUYAMA over 4 years ago

  • Status changed from Resolved to New

#8 Updated by Dileep Kumar over 4 years ago

Hello Toshi MARUYAMA,

could you please help me in getting it done.

Thanks in advance.

#9 Updated by Dileep Kumar over 4 years ago

Hello,

Any update from anyone???

Thanks

#10 Updated by Erik Álvarez over 4 years ago

+1
This is an important feature to have.

#11 Updated by Evzen Sindelar over 4 years ago

I tried to rewrite this patch for redmine 2.3.
So I tested it and it's functional.
Try it too.

Edi 28.6.2013t: It has some other errors - calendar, gantt diagram, relations between issues ....
I'll fix it and also try it in 2.3.1.
Hope next week.

#12 Updated by Dileep Kumar over 4 years ago

i installed 2.3.1 then applied the pathh attached. but while creating issue redmine throws error. please find attached logs.

#13 Updated by Dileep Kumar over 4 years ago

Hi,

Can anybody advise for this please !!!!!

Thanks in Advance

Dileep

#14 Updated by Jarosław Rencz over 4 years ago

+1
I wonder why it's still not there, since it's quite simple

#15 Updated by Luis Roa over 4 years ago

Evzen Sindelar wrote:

I tried to rewrite this patch for redmine 2.3.
So I tested it and it's functional.
Try it too.

Edi 28.6.2013t: It has some other errors - calendar, gantt diagram, relations between issues ....
I'll fix it and also try it in 2.3.1.
Hope next week.

Hi, thank you for the patch.

Redmine throws this error

ActionView::Template::Error (undefined method `use_datetime_for_issues' ...

my environment

Redmine version                          2.3.1.stable
Ruby version 1.9.3 (i386-mingw32)
Rails version 3.2.13
Environment production
Database adapter Mysql2

Help me please :(

#16 Updated by Luis Roa over 4 years ago

Dileep Kumar wrote:

i installed 2.3.1 then applied the pathh attached. but while creating issue redmine throws error. please find attached logs.

Hi, I solved.

1. apply patch.
2. run "rake db:migrate RAILS_ENV=production" in redmine directory.
3. test.

P.D: I am newbie in ruby on rails

#17 Updated by Luis Roa over 4 years ago

Hi,

I updated the diff file,

details:

- Now the hours range of 0 - 23. before it was 0 - 24.
- Now the minutes range of 0 - 55. before it was 0 - 60.
- I had problem, when I try update a issue, with time zone, but with this file, work fine for me.
- add in locale es.yml

adjunt file.

P.D: I am newbie in ruby, but I believe and I hope this work for you too, sorry for my english.

thank you Evzen.

#18 Updated by Rupesh Helwade over 4 years ago

Hi,
Thank you for the patch.
But I believe, it still needs refinement.
See following test case :

1. Create an issue with start and due Date and Times defined.
2. Go to issue update/edit screen
3. The selection of time hours and minutes shows time in UTC format and not in the user defined time zone.

Could you please rectify this issue as well.

#19 Updated by Daniel Felix over 4 years ago

Well the UTC problem is another edge case. This is currently not respected in many situations.

#20 Updated by Rupesh Helwade over 4 years ago

I have found a quick fix for one issue in time tags and attached is the updated patch file
Thanks

#21 Updated by Sergey Kravtsov over 4 years ago

Hello! 5458-use_time_in_issue_start_and_due_date_2.3_stable_v3.diff has bug:

line 158 malformed patch

Please, check it!

#22 Updated by Alex Latchford over 4 years ago

Hi all,

I've had a go at fixing the patch, based on the previous comments plus a few extras:
  • Time zone support
  • Time now takes into account required-ness in the workflow.
  • Changes minutes from 5-min intervals to 1-min. (need this for my project).
  • Zero pad hours/minutes.

I couldn't replicate the malformed patch error, but I've run this against the latest 2.3-stable so hopefully that's good enough :)

Cheers,
Alex

PS. I'm new to ruby, but I'd like to get this patch accepted ASAP (need it for a project!) so let me know if you have any feedback.

#23 Updated by Alex Latchford over 4 years ago

Hey what do I need to do to get this into the next version of Redmine?

#24 Updated by Toshi MARUYAMA over 4 years ago

Alex Latchford wrote:

Hey what do I need to do to get this into the next version of Redmine?

Please add tests.

#25 Updated by Alex Latchford over 4 years ago

Toshi MARUYAMA wrote:

Alex Latchford wrote:

Hey what do I need to do to get this into the next version of Redmine?

Please add tests.

Thanks for the response Toshi, I've updated the patch to fix the existing tests, could you give me some pointers on where to go next, I'm not the best with contributing tests, never quite know where to start!

Cheers,
Alex

#26 Updated by Alex Latchford about 4 years ago

Fixed a minor bug that meant the time was disappearing if the form was reloaded using ajax (i.e. if the status or tracker is changed).

Also added in a localise_date function that quickly will spit back a date/time/datetime in the correct format for the timezone the current user is in.

#27 Updated by Rupesh Helwade about 4 years ago

Can anyone also add time field of this feature to be used for an issue to become overdue
Thanks

#28 Updated by Alex Latchford about 4 years ago

Rupesh H wrote:

Can anyone also add time field of this feature to be used for an issue to become overdue
Thanks

I'm working on an SLA plugin for the work I need to do I'll try to clean it up afterwards and get it to a releasable state. This plugin has the ability to see if a ticket is overdue (well the semantics are that the SLA is in breach but the concept is the same), it also has the ability to set the due_date as a number of seconds after the start_due configurable by issue priority.

Cheers,
Alex

#29 Updated by Rupesh Helwade about 4 years ago

Hi Alex,
Thats great !
I shall be awaiting your update on this.
Rupesh

#30 Updated by pablo pablo about 4 years ago

After applying the patch the calendar stops to work : it doesn't show neither the old tasks nor the new ones...even if the time-feature is disabled in the project´s proprieties.
A fix would be very appreciated,
Thanks!!!
m

#31 Updated by Rupesh Helwade about 4 years ago

Have noticed a bug that as we keep on updating an issue- (in fact I just clicked - update and submit without actually modifying anything). The due date is automatically decremented by 1 each time.
Can others also replicate this ?

#32 Updated by Alex Latchford about 4 years ago

Rupesh H wrote:

Have noticed a bug that as we keep on updating an issue- (in fact I just clicked - update and submit without actually modifying anything). The due date is automatically decremented by 1 each time.
Can others also replicate this ?

I thought I'd fixed that in the v6 of the patch, is that the one you're using?

Cheers,
Alex

#33 Updated by Rupesh Helwade about 4 years ago

Yes, I am using V6

#34 Updated by Alex Latchford about 4 years ago

Rupesh H wrote:

Yes, I am using V6

Cool thanks for confirming, I'll take another look at that again :)

Cheers,
Alex

#35 Updated by Rupesh Helwade about 4 years ago

Thanks Alex,
Since you are already working on SLA feature.
Is it possible to take into account that a status say - feedback - Pending for information is excluded from issues being considered for lapsed times. (That is any ticket with status say "Pending for information" should not become overdue till it is actually being worked on - "in progress" ).
Share your thoughts on this.

Rupesh

#36 Updated by Alex Latchford about 4 years ago

Rupesh H wrote:

Thanks Alex,
Since you are already working on SLA feature.
Is it possible to take into account that a status say - feedback - Pending for information is excluded from issues being considered for lapsed times. (That is any ticket with status say "Pending for information" should not become overdue till it is actually being worked on - "in progress" ).
Share your thoughts on this.

Rupesh

Yes that should be possible, we're adding in a "Ticket stops" piece which will show an issue in a "Paused" sla state if the ticket is stopped. This will then be factored into the overall SLA time period. Hopefully with a few changes to language strings that should suit you :)

Cheers,
Alex

#37 Updated by Rupesh Helwade about 4 years ago

Thank you Alex.
Now I am more excited and waiting for this plugin to be available sooner.
Could you please comment by what time can it be available.
Thank you in advance.

#38 Updated by Alex Latchford about 4 years ago

Rupesh H wrote:

Thank you Alex.
Now I am more excited and waiting for this plugin to be available sooner.
Could you please comment by what time can it be available.
Thank you in advance.

Hopefully within 2-3 weeks :)

#39 Updated by Alex Latchford about 4 years ago

pablo pablo wrote:

After applying the patch the calendar stops to work : it doesn't show neither the old tasks nor the new ones...even if the time-feature is disabled in the project´s proprieties.
A fix would be very appreciated,
Thanks!!!
m

Fixed this by simply doing a to_date call if it's a datetime, not sure if this is okay but good enough for my needs for now.

Rupesh H wrote:

Have noticed a bug that as we keep on updating an issue- (in fact I just clicked - update and submit without actually modifying anything). The due date is automatically decremented by 1 each time.
Can others also replicate this ?

Hi Rupesh,

This was caused by not having a time zone selected it appears, fixed now in this version (V7) of the patch.

Cheers,
Alex

#40 Updated by Rupesh Helwade about 4 years ago

pablo pablo wrote:>Thanks!!!
Fixed this by simply doing a to_date call if it's a date time, not sure if this is okay but good enough for my needs for now.

Does not work for me too..

Getting following trace in production.log

NoMethodError (undefined method `to_date' for nil:NilClass):
lib/redmine/helpers/calendar.rb:51:in `block in events='
lib/redmine/helpers/calendar.rb:51:in `block in events='
lib/redmine/helpers/calendar.rb:51:in `each'
lib/redmine/helpers/calendar.rb:51:in `each'
lib/redmine/helpers/calendar.rb:51:in `group_by'
lib/redmine/helpers/calendar.rb:51:in `group_by'
lib/redmine/helpers/calendar.rb:51:in `events='
lib/redmine/helpers/calendar.rb:51:in `events='

app/controllers/calendars_controller.rb:51:in `show'
app/controllers/calendars_controller.rb:51:in `show'

Hi Rupesh,
This was caused by not having a time zone selected it appears, fixed now in this version (V7) of the patch.

Thanks Alex, it is fixed now.

#41 Updated by Alex Latchford about 4 years ago

Rupesh H wrote:

pablo pablo wrote:>Thanks!!!
Fixed this by simply doing a to_date call if it's a date time, not sure if this is okay but good enough for my needs for now.

Does not work for me too..

Getting following trace in production.log

NoMethodError (undefined method `to_date' for nil:NilClass):
lib/redmine/helpers/calendar.rb:51:in `block in events='
lib/redmine/helpers/calendar.rb:51:in `block in events='
lib/redmine/helpers/calendar.rb:51:in `each'
lib/redmine/helpers/calendar.rb:51:in `each'
lib/redmine/helpers/calendar.rb:51:in `group_by'
lib/redmine/helpers/calendar.rb:51:in `group_by'
lib/redmine/helpers/calendar.rb:51:in `events='
lib/redmine/helpers/calendar.rb:51:in `events='

app/controllers/calendars_controller.rb:51:in `show'
app/controllers/calendars_controller.rb:51:in `show'

Apologies, V8 should fix it :)

#42 Updated by Rupesh Helwade about 4 years ago

Thanks it works now !

#43 Updated by Rupesh Helwade about 4 years ago

Time now takes into account required-ness in the workflow.

Alex,
It is not working it seems. Also making it read only failed.
Could you confirm if it works at your end.

#44 Updated by Alex Latchford about 4 years ago

Rupesh H wrote:

Time now takes into account required-ness in the workflow.

Alex,
It is not working it seems. Also making it read only failed.
Could you confirm if it works at your end.

Are you logged in as the admin account? They can perform all activities on the workflow (not sure why, this is default Redmine behaviour it would appear).

Cheers,
Alex

#45 Updated by Rupesh Helwade about 4 years ago

I had already tried both using admin as well as normal user but it does not work.

#46 Updated by Alex Latchford about 4 years ago

Rupesh H wrote:

I had already tried both using admin as well as normal user but it does not work.

Just checked this on the latest copy of the patch and it's working.

#47 Updated by Rupesh Helwade about 4 years ago

Hi,
Thanks it works for me.
But strangely, I noticed that if the user is admin this required-ness does not work but works for non-admin users with same role.

Thanks again Alex for your time.

Rupesh

#48 Updated by Alex Latchford about 4 years ago

Rupesh H wrote:

Hi,
Thanks it works for me.
But strangely, I noticed that if the user is admin this required-ness does not work but works for non-admin users with same role.

Thanks again Alex for your time.

Rupesh

That's a Redmine thing as far as I'm aware.

#49 Updated by Johannes Petersson about 4 years ago

+1 for this feature

Since there seems to exist a well tested and working patch for this, why isn't this patch just added to the mainline releases?

//Johannes

#50 Updated by Rupesh Helwade about 4 years ago

+1

#51 Updated by Zarar Siddiqi about 4 years ago

Does this patch contemplate that the time will be taken into account when sending reminder emails?

http://www.redmine.org/projects/redmine/wiki/RedmineReminderEmails

#52 Updated by Rupesh Helwade about 4 years ago

The present version of patch does not take this into account / not working at my end.
The reminder emails for issues coming due in next few days are sent using the rake command as given in wiki page.

#53 Updated by Rupesh Helwade about 4 years ago

Hi Alex,
May I request you to let me know if there is any update on making this ("SLA") feature available as plugin?

TIA,
Rupesh

#54 Updated by Rupesh Helwade almost 4 years ago

Seems bug is re-introduced about auto decrements of date on update

"Have noticed a bug that as we keep on updating an issue- (in fact I just clicked - update and
submit without actually modifying anything). The due date is automatically decremented by 1 each
time.
Can others also replicate this ?"

This happens when Start date is day 10/01/2014 at 20:00 HRs (8:00 PM)
and Due date time is at 12/01/2014 : 02:00 HRS ( 2:00 AM )
That is whenever there is a difference in AM and PM in start and due date times
Other wise it works OK

#55 Updated by Oscar Corsvall almost 4 years ago

Any update for 2.4.2 for this patch?

#56 Updated by John Nguyen almost 4 years ago

Please make this as part of the baseline product and not as a patch.

#57 Updated by Toshi MARUYAMA almost 4 years ago

  • Related to Feature #15021: Service Level Agreement (SLA), more user-friendly email configuration, add any other notifications added

#58 Updated by Rupesh Helwade almost 4 years ago

Hi Developers of patch

Could you please help, I am getting 500 Internal Error !

It is giving error for start time (will it also for dates and Due time as well)

Seems there is an issue

at

+ @issue.start_date ||= DateTime.now if Setting.default_issue_start_date_to_creation_date?

in file

Index: app/controllers/issues_controller.rb

I am getting log as

NoMethodError (undefined method `div' for "16":String):
app/models/issue.rb:467:in `load_localised_time'
app/models/issue.rb:472:in `safe_attributes='
app/controllers/issues_controller.rb:410:in `build_new_issue_from_params'

where 16 is the minutes selected in Start time as seen in bellow log :

Started POST "/redmine/projects/itsupport/issues" for XYZ_IP_ADDRESS at 2014-02-18 19: 16 :40 +0530

Processing by IssuesController#create as HTML
Parameters: {"utf8"=>"✓",

"category_id"=>"26", "parent_issue_id"=>"", "start_date"=>"2014-02-18", "start_time"=> {"hour"=>"19", "minute"=>"16"},
"due_date"=>"", "due_time"=>{"hour"=>"", "minute"=>""},

Completed 500 Internal Server Error in 127ms

#59 Updated by Rupesh Helwade almost 4 years ago

I am not a ruby developer as such but Made correction in the patch file attached.
Seems to be working fine.

Experts please review.

#60 Updated by Roberto Viola over 3 years ago

It looks good! When will it be added officially?

#61 Updated by Bertrand FRUCHET over 3 years ago

Hi all,
I apply this patch without success, because i use redmine 2.5
However, i uninstall the patch but it still not working for existing issues.
New issue work fine.

Can someone help me :
1. to retrieve functionnal access to existing issues and project config ?
2. to adapt this patch for redmine 2.5 if it is possible ?

What i done (don't laugh, i'm newbie with ruby and redmine) :
1. Apply the patch, restart service and test -> ko for new issues
2. Remove the patch, restart service, and test -> ko for existing issues and project config
3. redownload redmine from svn, bundle install and test -> ko for existing issues and project config

The log errors for existing issues :
Started GET "/issues/31" for 172.16.11.157 at 2014-07-21 02:29:06 +0200
Processing by IssuesController#show as HTML
Parameters: {"id"=>"31"}
Current user: bertrand (id=3)
Rendered issues/_action_menu.html.erb (5.8ms)
Rendered issues/show.html.erb within layouts/base (81.9ms)
Completed 500 Internal Server Error in 250.8ms

ActionView::Template::Error (undefined method `use_datetime_for_issues' for #<Project:0x007fa2be0b5960>):
47: end
48:
49: unless @issue.disabled_core_fields.include?('start_date')
50: rows.right l(:field_start_date), (@project.use_datetime_for_issues ? format_time(@issue.start_date) : format_date(@issue.start_date)), :class => 'start-date'
51: end
52: unless @issue.disabled_core_fields.include?('due_date')
53: rows.right l(:field_due_date), (@project.use_datetime_for_issues ? format_time(@issue.due_date) : format_date(@issue.due_date)), :class => 'due-date'
app/views/issues/show.html.erb:50:in `block in app_views_issues_show_html_erb_191407975889242943_70168469341040'
app/helpers/issues_helper.rb:158:in `issue_fields_rows'
app/views/issues/show.html.erb:35:in `_app_views_issues_show_html_erb__191407975889242943_70168469341040'
app/controllers/issues_controller.rb:128:in `block (2 levels) in show'
app/controllers/issues_controller.rb:125:in `show'

The log errors for project config :
Started GET "/projects/curzay-evolution-telecom/settings" for 172.16.11.157 at 2014-07-21 02:54:13 +0200
Processing by ProjectsController#settings as HTML
Parameters: {"id"=>"curzay-evolution-telecom"}
Current user: bertrand (id=3)
Rendered projects/_form.html.erb (5.4ms)
Rendered projects/_edit.html.erb (9.4ms)
Rendered common/_tabs.html.erb (13.8ms)
Rendered projects/settings.html.erb within layouts/base (16.8ms)
Completed 500 Internal Server Error in 32.0ms

ActionView::Template::Error (undefined method `use_datetime_for_issues' for #<Project:0x007fa2bde48c40>):
11: <% end ></p>
12: <p><
= f.text_field :homepage, :size => 60 ></p>
13: <p><
= f.check_box :is_public ></p>
14: <p><
= f.check_box :use_datetime_for_issues ></p>
15:
16: <
unless @project.allowed_parents.compact.empty? >
17: <p><
= label(:project, :parent_id, l(:field_parent)) ><= parent_project_select_tag(@project) %></p>
lib/redmine/views/labelled_form_builder.rb:34:in `check_box'
app/views/projects/_form.html.erb:14:in `_app_views_projects__form_html_erb___1903734829855056759_70168474322660'
app/views/projects/_edit.html.erb:2:in `block in app_views_projects_edit_html_erb___2186228600278077446_70168474253580'
app/helpers/application_helper.rb:1079:in `labelled_form_for'
app/views/projects/_edit.html.erb:1:in `_app_views_projects__edit_html_erb___2186228600278077446_70168474253580'
app/views/common/_tabs.html.erb:22:in `block in app_views_common_tabs_html_erb___1615134534336553850_70168474088860'
app/views/common/_tabs.html.erb:21:in `each'
app/views/common/_tabs.html.erb:21:in `_app_views_common__tabs_html_erb___1615134534336553850_70168474088860'
app/helpers/application_helper.rb:318:in `render_tabs'
app/views/projects/settings.html.erb:3:in `_app_views_projects_settings_html_erb__1934406188195170077_70168474045980'

Thanks in advance,
Bertrand

#62 Updated by Bertrand FRUCHET over 3 years ago

Apologizes for the previous post.
the patch remove command didn't work at first time. I rerun the uninstall patch and all works well now.

I search for make this patch compatible with redmine 2.5. If anyone can help me ?

Thanks,
Bertrand

#63 Updated by Jérôme BATAILLE over 3 years ago

+1

I have made a patch to have a DateTime CustomField (would be very usefull !)
But a DateTime picker is mandatory.

#64 Updated by Bertrand FRUCHET over 3 years ago

Jérome,

Thanks for correcting quickly. I'm new to redmine and also to ruby.
What do you mean where you say ?

a DateTime picker is mandatory

Can you tell me how to add this to my redmine.
Thanks in advance..

#65 Updated by Jérôme BATAILLE over 3 years ago

Bertrand FRUCHET wrote:

Can you tell me how to add this to my redmine.
Thanks in advance..

Hi Bertrand,
The Redmine jquery DatePicker does not include time. I have not searched for a compatible DateTimePicker.
I suppose that the developer that maintains the DatePicker (JPL ?) will be more efficient in this task.

#66 Updated by Daniel Felix over 3 years ago

Well, as far as i know, Redmine uses the jquery UI datepicker. This way you can extend the datepicker like the normal jquery ui datepicker with datetime.

Or maybe a switch to another jQuery based timepicker like this one: http://plugins.jquery.com/datetimepicker/
Which seems pretty okay for the task searched.

But on the other hand...
Modern browsers support a native date and a native datetime picker out of the box. This solution is just needed for oldschool browsers which don't know these features. They will gracefully fall back to a text input field which could be extended by the script.

Hope this helps?

#67 Updated by Toshi MARUYAMA over 3 years ago

  • Related to Feature #11044: Custom field types for time and datetime added

#68 Updated by Toshi MARUYAMA over 3 years ago

  • Duplicated by Feature #1885: Change Start from date to datetime added

#69 Updated by Carlos C.C. over 3 years ago

Hi,

As Bertrand, I am trying to run this patch on 2.5.2. What must we change to get patch run on this version?

Thanks,
Carlos.

#70 Updated by Emmanuel Hidalgo about 3 years ago

Hi,

I will wish to participate in the project by providing the option of adding hours in the fields customizable time.
I already made the local development and I would like to know the procedure for my code committer.

Can you help me?

#71 Updated by Mischa The Evil about 3 years ago

Emmanuel Hidalgo wrote:

I already made the local development and I would like to know the procedure for my code committer.

Can you help me?

See Contribute and Submissions.

#72 Updated by Emmanuel Hidalgo about 3 years ago

Thank you,

I sent the changes on github

https://github.com/redmine/redmine/pull/46

#73 Updated by Toshi MARUYAMA about 3 years ago

  • % Done changed from 100 to 0

#74 Updated by Toshi MARUYAMA about 3 years ago

Emmanuel Hidalgo wrote:

Thank you,

I sent the changes on github

https://github.com/redmine/redmine/pull/46

For r13608.

#75 Updated by Emmanuel Hidalgo about 3 years ago

Hi Toshi,

unfortunately, but changes have not been integrated because i'm not a core developer -> I understand
the ticket has been rejected.

Do you know how I can do for these development'm considered?

Should I create a patch or rather a plugin ...

Thanks in advance,
Emmanuel

#76 Updated by Toshi MARUYAMA about 3 years ago

Emmanuel Hidalgo wrote:

Hi Toshi,

...

Why did not you read Contribute suggested in note-71 ?

#77 Updated by Emmanuel Hidalgo about 3 years ago

Hi,
I read this page.
but I'm developing a core, while the more judicious to have been a plugin.
I'll see to the development of a plugin.
I'll let you know if I can make changes with a plugin.
Thanks

#78 Updated by Toshi MARUYAMA about 3 years ago

Emmanuel Hidalgo wrote:

Hi,
I read this page.

Really?

Contribute

Do not send a pull request on GitHub.

Why did you send pull request on GitHub?

#79 Updated by Emmanuel Hidalgo about 3 years ago

Hi,
I saw that you had put the link in red.
My confusion was on the patch-term or item 4.
Being given that, I did not want to patch, I do not think be affected by this ban.
May be, would it make sense out of this term poitn 4, to put it at the root, the same level as "Basic process for Contributing code" ?

You have a link with documentation on the development of plug-in?

#81 Updated by Koronics Norbert about 3 years ago

Helló

I would like to apply this patch in our redmine, but i can't. Is this work with 2.5.2.stable?

My system info is:
Redmine version 2.5.2.stable
Ruby version 1.9.3-p484 (2013-11-22) [i686-linux]
Rails version 3.2.19
Environment production
Database adapter Mysql2
SCM:
Subversion 1.8.8
Git 1.9.1

Thanks for helping

#82 Updated by Emmanuel Hidalgo about 3 years ago

Hi,

Here is a patch from 2.5.2

Cheers,
Emmanuel

#83 Updated by Koronics Norbert about 3 years ago

Emmanuel Hidalgo wrote:

Hi,

Here is a patch from 2.5.2

Cheers,
Emmanuel

Thanks a lot, its works! Any idea how could it work with ics export? i would like to use this custom field for specifying the calendar alarm time.

Cheers,
Norbi

#84 Updated by Emmanuel Hidalgo about 3 years ago

Hi,

This patch only customFields modified.
If you want to use the hours in another context, you must do so by changing the code.

You have an example in application.js line 167-171.

Cheers,
Emmanuel

#85 Updated by [ Desperados ] over 2 years ago

I've tried patch with 2.6.x and it fails

#86 Updated by Roman Khaleev over 2 years ago

Whether it is planned to add this feature in the new 3.x version?

#87 Updated by Peter Drábik over 2 years ago

Roman Khaleev wrote:

Whether it is planned to add this feature in the new 3.x version?

Hi, I have 3.1.0 and version 5458-use_time_in_issue_start_and_due_date_2.3_stable_V9 (2).diff works for me fine.

In the part when I edit app/helpers/queries_helper.rb

I add this

+      when 'Time'
+      if ( column.name == :start_date or column.name == :due_date ) and
+        ( !issue.project.use_datetime_for_issues or value.strftime('%H%M')=='0000' )
+        format_date(value)
+      else
+        format_time(value)
+      end
+     when 'Date'
+      format_date(value)

      when 'Fixnum'

after add patch, you must use command RAILS_ENV=production bundle exec rake db:migrate - this solve problems posted from Bertrand FRUCHET

Sorry for my bad english

#88 Updated by Go MAEDA about 2 years ago

  • Duplicated by Feature #20820: Time of day (not only date) as a deadline for a task. added

#89 Updated by Erik Álvarez about 2 years ago

+1 can it be planned for 3.2 or 4.0 release?

#90 Updated by Sergey Karpushin almost 2 years ago

Hi All.
Here is modified patch for 3.2.0 (5458-use_time_in_issue_start_and_due_date_2.3_stable_V9_3.diff)
there are many offsets when apply it, but all Hunk succeeded.

#91 Updated by Mario Labate almost 2 years ago

That's great.
But how I can add hours in projects issues? I didn't found time entries in issues new/edit pages.

#92 Updated by Richard Krieg almost 2 years ago

It's been 6 years, how can it be a much needed and easy feature like this hasn't made it into a stable release yet?
Instead Contributors prefer newbie bashing... Open Source projects with developers and an attitude like this always make me sad.

#93 Updated by Roman Khaleev over 1 year ago

Sergey Karpushin wrote:

Hi All.
Here is modified patch for 3.2.0 (5458-use_time_in_issue_start_and_due_date_2.3_stable_V9_3.diff)
there are many offsets when apply it, but all Hunk succeeded.

I find error.

add_start_and_due_time method is not found

#94 Updated by Roman Khaleev over 1 year ago

Sergey Karpushin wrote:

Hi All.
Here is modified patch for 3.2.0 (5458-use_time_in_issue_start_and_due_date_2.3_stable_V9_3.diff)
there are many offsets when apply it, but all Hunk succeeded.

And another problem - where i could set start or due time? there are only Date picker in Redmine interface

#95 Updated by Víctor Farell over 1 year ago

We have just installed the latest version of Redmine (v3.3.0) where we wanted to continue to use this patch. We have carried out the installation (v9) and has installed and implemented well, but when you run Redmine does not appear, the hours are not shown in the date field.

I think it's the same case described by Roman Khaleev (#5458#note-94).

Then I leave informed our current installation data in the production environment:
  • Environment:
    • Redmine version 2.5.1.stable
    • Ruby version 1.9.3-p0 (2011-10-30) [x86_64-linux]
    • Rails version 3.2.17
    • Environment production
    • Database adapter Mysql2
  • SCM:
    • Subversion 1.6.17
    • Filesystem
  • Redmine plugins:
    • redmine_agile 1.1.1-light
    • redmine_backlogs v1.0.6
    • redmine_lightbox 0.0.1
    • redmine_mylyn_connector 2.8.2.stable
    • timelog_timer 2.0.0

#96 Updated by Benjamin J about 1 year ago

+1

#97 Updated by Hernan Leder about 1 year ago

Hi guys,
I have a Bitnami Redmine 3.3.x stable and I need to undestand step by ste how should I have to apply these "diff" files!...could you please help me?

Thanks in advance
Hernan

#98 Updated by Kush Suryavanshi about 1 year ago

We really need this feature. Setting up the time(along with dates) for deadlines is crucial to us. Hope this gets integrated in redmine soon.

#99 Updated by Kush Suryavanshi about 1 year ago

I have tried this patch - 5458-use_time_in_issue_start_and_due_date_2.3_stable_V9_3.diff
I second what Roman and Victor said earlier. DateTimepicker doesn't show up in UI. This is probably what Jérôme & Daniel mentioned earlier in the thread. Can anyone point me how to include this in UI? I think I have to play around with jQuery\JavaScript files - if anyone has instructions already, that will be useful. Thanks.

#100 Updated by Kush Suryavanshi 11 months ago

For what it's worth, I gave up on these patches and I am using following plugin - https://github.com/nanego/redmine_datetime_custom_field/issues
It only works with custom fields but that solves many of my issues and I don't have to worry about patches. I humbly request to consider time(at least for due date) in future. Most of redmine alternatives(Trello etc.) use it. Thank you.

Also available in: Atom PDF