Feature #11963

Hide the estimated times on issues for certain roles

Added by Jiří Křivánek almost 7 years ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues permissions
Target version:-
Resolution:Duplicate

Description

Hello,

we are successfully using Redmine for years. But in a very complex way - hundreds of projects and sub-projects, thousands of tasks, hundreds of users.

At this moment we would like to let some of our customers to enter the Redmine as well - for the classical bug reporting/tracing workflow.

To be able to do that, we need to hide some internal information (particularly all the information which could be misinterpreted by them - like time estimates, spent time records, etc.) from the customers. We spent a few days with trying to create the role for the customer - quite successfully but not completely - that is why I am posting here.

We did the tests on both 1.3x and 2.0.x versions...


Currently, the only thing we need to hide before we let our customers to enter the Redmine is demonstrated by the attached screenshots below:
  • The red highlight point out what our customers cannot see and we were not able to get rid of it.
  • The second screenshot details the role settings (perhaps you point us to something which we are still missing after all those tests).


2012-09-27_08-57-41.png (208 KB) Jiří Křivánek, 2012-09-27 09:09

2012-09-27_08-54-03.png (166 KB) Jiří Křivánek, 2012-09-27 09:09

2012-10-02_09-52-54.png (195 KB) Jiří Křivánek, 2012-10-02 09:56


Related issues

Duplicates Redmine - Feature #12005: Mightful workflow field enhancement: hide New
Duplicates Redmine - Feature #3088: Estimated hours field able to hide role based New 2009-04-01

History

#1 Updated by Jiří Křivánek almost 7 years ago

I have just realized one more consequence of fixing this problem:

#2 Updated by Jean-Philippe Lang almost 7 years ago

  • Tracker changed from Defect to Feature
  • Subject changed from Cannot hide the estimated times on issues to Hide the estimated times on issues for certain roles

#3 Updated by Dominique Lederer about 6 years ago

+1

i created a plugin that hides "estimated_hours" from most of this views, take a look at https://github.com/return1/redmine_hide_estimated_hours

i would really like to see this in Redmine, because for some stuff i am not able to do this with a plugin, for example to completely hide estimated_hours from the Issues Journal. Also hiding from the Issue PDF via Plugin is not really efficient at the moment.

#4 Updated by Alexis Romagnoli about 6 years ago

+1

#5 Updated by Filou Centrinov about 6 years ago

Duplicate of #12005 ?

#6 Updated by Terence Mill about 6 years ago

Yes it is a duplicate #12005, which allows hiding optionally for every field (except topic and status).

#7 Updated by Filou Centrinov about 6 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

#8 Updated by Martin Dubé about 6 years ago

I would also like to be able to hide estimated time.

Since Jean-Philippe Lang stated that proposed changes in #12005 will not get implemented in the near future (http://www.redmine.org/issues/12005#note-62) maybe this one could be reopened. Implementing a new right (or even used the current one allowing to see spent time) would be fine in my opinion.

#9 Updated by Rick Boyer almost 6 years ago

+1

This really is a show stopping issue for client access. Redmine is otherwise a great product (with plugins).

#10 Updated by Jeremy Bailey almost 6 years ago

+1

Also +1-ing #12005, since that seems more ambitious and will probably take longer to implement.

#11 Updated by Pavel Potcheptsov over 5 years ago

+ 1

#12 Updated by Christian S. over 5 years ago

+1 this is needed if you want to give access to your customers, to report issues.

#13 Updated by Guillaume C over 5 years ago

+1

#14 Updated by Richard Gunn over 5 years ago

+1 I logged a similar request Issue #16095

The issue was set to invalid (i.e. ignored). Without such an enhancement we cannot provide customer access.

#15 Updated by minkbear minkbear over 5 years ago

+1 for this feature

#16 Updated by alio kero about 5 years ago

+ 1

#17 Updated by Javi Ferrer almost 5 years ago

+1

I forked the Dominique Lederer's plugin and I added a new permission called hide estimated time. This new permission allow user to see spent time but not the estimated time.

https://github.com/javiferrer/redmine_hide_estimated_hours

#18 Updated by Pavel Potcheptsov over 4 years ago

+ 1

#19 Updated by Christoph Weygand over 3 years ago

+1

#20 Updated by Istvan Heckl over 3 years ago

+1, it is a must have

#21 Updated by Manuel Bernhardt almost 3 years ago

+1, it is a must have

#22 Updated by Vladimir Gorin almost 3 years ago

+1

#23 Updated by Benoit Duffez over 2 years ago

+1

#24 Updated by Carlos Meyer about 1 year ago

I forked the Dominique Lederer's plugin and patch it for version 3.4.4 https://github.com/protos1575/redmine_hide_estimated_hours
+1

#25 Updated by Stefaan Ellebaut 8 months ago

+1

#26 Updated by Ivan Rapekas 6 months ago

+1

#27 Updated by Jesus Broceno 6 months ago

+1

#28 Updated by Go MAEDA 6 months ago

  • Duplicates Feature #3088: Estimated hours field able to hide role based added

#29 Updated by Thierry Brochu 3 months ago

+1

Also available in: Atom PDF