Project

General

Profile

Actions

Feature #13814

open

No more comments when ticket closed

Added by Sven Culley about 11 years ago. Updated over 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

Is there a possibility to prevent users from commenting on closed tickets?


Files

redmine-2.4.6-add_closed_issue_notes.patch (1.49 KB) redmine-2.4.6-add_closed_issue_notes.patch Michał Rzechonek, 2015-02-26 20:46
Redmine Forum.pdf (26.7 KB) Redmine Forum.pdf Martina A., 2017-11-09 11:21

Related issues

Related to Redmine - Feature #7557: Deny editing of descriptions of closed issuesClosed2011-02-05

Actions
Related to Redmine - Patch #2685: Display notice when commenting on closed ticketsNew2009-02-06

Actions
Related to Redmine - Feature #3521: Permissions for roles to change fields per tracker/statusClosedJean-Philippe Lang2009-06-22

Actions
Related to Redmine - Feature #33868: Prevent adding notes to closed issuesNew

Actions
Has duplicate Redmine - Feature #18382: Disable closed issues for commentingClosed

Actions
Has duplicate Redmine - Feature #27036: Ticket status closedClosed

Actions
Actions #1

Updated by Toshi MARUYAMA about 11 years ago

  • Category changed from Permissions and roles to Issues
Actions #2

Updated by Toshi MARUYAMA about 11 years ago

  • Status changed from New to Closed
Actions #3

Updated by Toshi MARUYAMA about 11 years ago

  • Status changed from Closed to Reopened
Actions #4

Updated by Sven Culley over 10 years ago

Any news on this or maybe a patch which could handle this?

Actions #5

Updated by Toshi MARUYAMA over 10 years ago

  • Status changed from Reopened to New
Actions #6

Updated by benoit deleris almost 10 years ago

"No more comments when ticket closed" according to the role in fields permissions.
why not fixing this feature?

Actions #7

Updated by Toshi MARUYAMA over 9 years ago

  • Related to Feature #18382: Disable closed issues for commenting added
Actions #8

Updated by Ivan Cenov over 9 years ago

In my opinion, this could be implemented with option 'comments allowed' and 'comments disallowed' when an issue is closed. This could be done for each issue and/or globally and/or per project.

Actions #9

Updated by Sven Culley over 9 years ago

A first patch would help me ... ;)

Actions #10

Updated by Ivan Cenov over 9 years ago

To get this idea widely...

There could be added a new member in the issues table, par example 'comments_allowed' of type TINYINT(1) and it should be set to TRUE when creating new issue. Then

  • associate a checkbox in the edit issue dialog
  • associate permissions for access of 'comments_allowed'.
  • add a menu item in the context menu for allow / disallow.
  • add a global configuration option about 'disallow comments on closing issues'.
  • add a project configuration option about 'disallow comments on closing issues'.
  • add a project configuration option about which setting is with bigger priority: the global one or project one. (is needed?)
  • add code that calculates above conditions and sets or clears 'comments_allowed'.
Actions #11

Updated by Toshi MARUYAMA over 9 years ago

  • Related to deleted (Feature #18382: Disable closed issues for commenting)
Actions #12

Updated by Toshi MARUYAMA over 9 years ago

  • Has duplicate Feature #18382: Disable closed issues for commenting added
Actions #13

Updated by Michał Rzechonek over 9 years ago

I needed that recently, attaching a simplistic patch adding a permission.

For the record, I don't know a thing about Rails, just needed a quick hack.

Actions #14

Updated by Alexander Meindl almost 9 years ago

I have added this feature to the plugin Redmine tweaks.

Actions #15

Updated by Go MAEDA almost 7 years ago

Actions #16

Updated by Martina A. over 6 years ago

Hello

We need some help to this topic again.

Installing the patch with the command written above works.
After the installation and a restart of the server it is still possible to comment on closed issues…
I tried to understand “what the patch” is doing and check if that worked.

Due to formatting problems, please see attached pdf-file.

Thanks in advance for further tips.

Actions #17

Updated by Yuuki NARA about 5 years ago

+1

Actions #18

Updated by Yuuki NARA almost 5 years ago

We created a workaround using the view customize plugin.
I hope this helps.

https://redmine.tokyo/issues/235#note-9

Actions #19

Updated by Go MAEDA over 3 years ago

  • Related to Feature #33868: Prevent adding notes to closed issues added
Actions #20

Updated by Marji Cermak over 2 years ago

I've been looking for this as well.
And I just realised the additionals plugin actually implements this functionality: https://www.redmine.org/plugins/additionals
I can confirm it works. Make sure role you want to prevent from editing closed issues does not have "Edit closed issues" permission assigned.
Configure the additionals plugin at: /settings/plugin/additionals?tab=rules
The option is called "Disallow editing of closed issues (Freeze)".

Actions #21

Updated by Padraig FItzgerald over 2 years ago

Marji Cermak wrote:

I've been looking for this as well.
And I just realised the additionals plugin actually implements this functionality: https://www.redmine.org/plugins/additionals
I can confirm it works. Make sure role you want to prevent from editing closed issues does not have "Edit closed issues" permission assigned.
Configure the additionals plugin at: /settings/plugin/additionals?tab=rules
The option is called "Disallow editing of closed issues (Freeze)".

Agreed. I have been using the plugin for last few weeks for this specific reason and it does exactly what OP asks for.

Actions

Also available in: Atom PDF