Project

General

Profile

Actions

Feature #4885

closed

Option to make time log comments field mandatory

Added by Waleed Riaz about 14 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Time tracking
Target version:
-
Start date:
2010-02-20
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

the "comment" field while logging time for any issue should be mandatory. It would be highly profitable for us if this can be achieved in the next version.

thanks!

p.s. This is a fantastic application, really appreciate the work you guys are doing here!


Related issues

Is duplicate of Redmine - Feature #24577: Settings to make the issue and/or comment fields mandatory for time logsClosedJean-Philippe Lang

Actions
Actions #1

Updated by Jean-Philippe Lang about 14 years ago

  • Subject changed from Comments field should be mandatory to Option to make time log comments field mandatory

I think that making it optional would be better.

Actions #2

Updated by Waleed Riaz about 14 years ago

Jean-Philippe Lang wrote:

I think that making it optional would be better.

or at least we can make it mandatory from application settings or something. We in our organization need all time loggers to submit comments...

Actions #3

Updated by Jean-Philippe Lang about 14 years ago

That's what I was saying, an option in application settings to make comments mandatory.

Actions #4

Updated by Slava Karg over 13 years ago

  • Assignee set to Jean-Philippe Lang

Our organization needs this option too. Is it available in 1.0.1 version?

Actions #5

Updated by Eric Davis over 13 years ago

  • Assignee deleted (Jean-Philippe Lang)

Slava Karg:

Please don't assign issues to people.

I've written a plugin that makes all comments required on time entries. It should be a good enough workaround for the next several months at least.

http://github.com/edavis10/redmine_require_time_entry_comments

Actions #6

Updated by Jos Accapadi about 12 years ago

+1, while a plugin is fine, since comments are used in details in reports, and other plugins use the same comment capabilities for other time entry plugins, it would be nice, if it is a minor change to have this as part of core, otherwise plugins have to be aware of other plugins. As an example, the plugin Eric has won't work with the issue hot buttons plugin which can have an option to include comments for time entry.

Actions #7

Updated by Christoph Klesser over 10 years ago

+1

Actions #8

Updated by Y Z almost 10 years ago

+1

Actions #9

Updated by Adam Jenson almost 10 years ago

+1

Actions #10

Updated by Richard Bergoin almost 10 years ago

+1

I often forgot to log my time when updating an issue. If I don't want to log time, could "0" value be accepted to log "no time" ?

Actions #11

Updated by Michael Sanders over 9 years ago

+1
Has there been any update on this functionality yet? Eric's plugin for 4 years ago was made for Redmine 1.x, and does not work for Redmine 2.x

Actions #12

Updated by Stéphane Klein almost 9 years ago

+1

Actions #13

Updated by Gustavo Regal over 8 years ago

I would appreciate if I could make, instead of comments, the issue id mandatory.
In my company, people sometimes forget to select the issue and the time entry gets not-associated to anything.

Actions #14

Updated by Marius BĂLTEANU over 7 years ago

Jean-Philippe Lang wrote:

That's what I was saying, an option in application settings to make comments mandatory.

I've added a patch in #24577 which implements this.

Actions #15

Updated by Go MAEDA over 7 years ago

  • Is duplicate of Feature #24577: Settings to make the issue and/or comment fields mandatory for time logs added
Actions #16

Updated by Go MAEDA over 7 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

A patch to implement this feature was submitted as #24577.
Closing this issue.

Actions

Also available in: Atom PDF