Feature #9992

Ability to filter issue subtasks in issue form

Added by Luis Serrano Aranda over 5 years ago. Updated over 2 years ago.

Status:NewStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues
Target version:Candidate for next major release
Resolution:

Description

It would be interesting to see the filters in a task and its subtasks


Related issues

Related to Redmine - Feature #6118: Filter by parent task or subtasks Closed 2010-08-12
Related to Redmine - Feature #5325: Add Parent Task to 'Group Results By' drop down New 2010-04-15
Duplicated by Redmine - Feature #12860: add filter to hide sub-tasks in tickets view Closed
Duplicated by Redmine - Feature #10927: Add a filter on the "Issues" page to hide subtasks Closed
Duplicated by Redmine - Feature #10553: Filter tasks by parent task ID Closed

History

#1 Updated by Etienne Massip over 5 years ago

What filters?

#2 Updated by Luis Serrano Aranda over 5 years ago

If I want look only a task with yours subtasks

#3 Updated by Etienne Massip over 5 years ago

  • Subject changed from New filter to Ability to filter issue subtasks in issue form

Is this OK to you?

#4 Updated by Etienne Massip over 5 years ago

Or is it the ability to filter the issue list with a "Parent task" filter to get all subtasks of a specific issue?

#5 Updated by Luis Serrano Aranda over 5 years ago

I wish I could see only one issue and all its subtasks

#6 Updated by Luis Serrano Aranda over 5 years ago

I wish I could see only one request and all its subtasks

#7 Updated by Ewan Makepeace about 5 years ago

Do you not see the subtasks summarised on the parent issue itself?

#8 Updated by Daniel Felix over 4 years ago

  • Target version set to Candidate for next major release

I added the duplicate relations to #10553, #10927 and #12860.

This seems to be realy interesting to the community.

What do you think about my idea at #12860?

This could be solved by adding some filter by parent task which provides: 1.filter by parent task id is equal to
2.filter by parent task id is not equal to
3.filter by parent task id is not null (has parent tasks)
4.filter by parent task id is null (no parent tasks)

What do you think about this?

#9 Updated by Luis Serrano Aranda over 4 years ago

It's a good solution

#10 Updated by Jiří Křivánek over 4 years ago

As you closed my issue as the duplicate of this one, I am copying my request inside - just to be completely sure...

And yes, if I understand your logic in post 8 hereby then your solution should work to me... thank you...

Jiří Křivánek wrote:

Request:
  • Add support for filtering tasks also by the parent task ID.
  • It should support
    1. Any exact value (as entered).
    2. Empty/not empty (i.e. only subtasks or only top level parent tasks).
    3. Matching and NOT matching.
Motivation:
  • The management in my company where I established the Redmine is multi-level.
  • Higher level manager enters the overall task on the project, containing the list of feature requirements.
  • Lower level manager makes a specification and plans the works by creating a lot of sub-tasks for the above entered parent task.
  • The higher level manager needs the custom view of tasks on the project where only the top-level tasks are visible.

#11 Updated by Florian S. over 4 years ago

I also think this might be a good solution (#12860) !

#12 Updated by Mischa The Evil over 4 years ago

+1 for a filter proposed by Daniel Felix in note-8.

#13 Updated by Lorenz W. about 4 years ago

Daniel Felix wrote:

4.filter by parent task id is null (no parent tasks)

see also #12860

I consider this as very important. When I need an summary on what is still outstanding I dont want subtasks to flood the list.

#14 Updated by Lorenz W. about 4 years ago

Lorenz W. hit the wrong button.

#15 Updated by Lorenz W. about 4 years ago

Lorenz W. hit the wrong button again.

#16 Updated by Mikhail Sviridov about 4 years ago

May be it will be better to fold/unfold tasks to allow user to expand only interesting tasks to access it's subtasks? If someone wants to see all the tasks and it's subtasks visible in the issue list it can be done by setting a tick "Expand all". It can be the setting for each project or for each user or global.

Another way is to switch between list and hierarhical views of issues.
So the same operations will be different for these views:
  • sort
    • will sort all the issues in list view regardless of it is subtask or not
    • will sort on each level (1st level tasks are sorted first, then 2nd level tasks inside the group made by it's parent tasks)
  • filter
    • will filter from all the issues in list view
    • will filter from all the issues, but the result will be in form of:
      filtered tasks (those are before A by sorting)
      A
       -> filtered subtasks of A (those are before B by sorting)
       -> B (has it's ranges of each field collected from subtasks)
           -> filtered subtasks of the B
       -> filtered subtasks of A (those are after B by sorting)
      filtered tasks (those are after A by sorting)
      

About list view
It is already implemented - so I don't need to do any comments here.

About hierarhical view
If it is very complex to implement and may be it is useless in most cases so you can perform operations (sort, filter) on the 1st level tasks only. To do sorting or filtering of subtasks of some task you should go into the task and inside it's subtasks list perform suitable operations again. So task have to have the same widget for subtask as issues page of the project or the issues list of the project have to have the title of the path "A -> B -> C" like wiki pages have.

Feel free to question me if something is unclear (probably, my english is dirty).

#17 Updated by Florian Kaiser over 3 years ago

Also +1 from me.

#18 Updated by Alfredo Mezquita about 3 years ago

+1

#19 Updated by Ronny Kiessling almost 3 years ago

+1

#20 Updated by Vjacheslav Ryzhov over 2 years ago

+1

#21 Updated by Toshi MARUYAMA over 2 years ago

  • Related to Feature #5325: Add Parent Task to 'Group Results By' drop down added

#22 Updated by Toshi MARUYAMA over 2 years ago

  • Related to deleted (Feature #10559: Add Parent Task to 'Group Results By' drop down )

Also available in: Atom PDF