Feature #1091

Disabling default ticket fields per tracker

Added by girish konnur over 6 years ago. Updated 3 months ago.

Status:ClosedStart date:2008-04-23
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Issues
Target version:2.1.0
Resolution:Fixed

Description

I want to create a tracker with all the custom fields. I don't want any default fields to be displayed in it

standard_fields.png (6.31 KB) Jean-Philippe Lang, 2012-07-05 14:21


Related issues

Related to Feature #703: Configurable required fields per tracker/status/role Closed 2008-02-21
Related to Feature #9700: Allow to configure the visibility of the fields of the “N... Closed
Related to Defect #12707: Typo in app/models/tracker.rb Closed
Duplicated by Feature #4434: Hide target version in ticket mask Closed 2009-12-17
Duplicated by Feature #4387: Managing "description" field Closed 2009-12-11
Duplicated by Feature #1296: Allow trackers to hide issue fields Closed 2008-05-25
Duplicated by Feature #3737: Enabling to Remove Default Fields in New Project Creation Closed 2009-08-14
Duplicated by Feature #3154: Remove default fields on new issue form Closed 2009-04-10
Duplicated by Feature #5032: Ability to remove "Assigned to" field from particular tra... Closed 2010-03-10
Precedes Defect #14584: Standard fields disabled for certain trackers still appea... Closed

Associated revisions

Revision 9912
Added by Jean-Philippe Lang over 2 years ago

Ability to disable standard fields on a per tracker basis (#1091).

Revision 9914
Added by Toshi MARUYAMA over 2 years ago

generate translation files (#1091)

History

#1 Updated by Jean-Philippe Lang over 6 years ago

  • Subject changed from How to create a tracker with all custom fields to Disabling default ticket fields
  • Category changed from Custom fields to Issues
  • Target version deleted (0.7)

Default fields can not be disabled for now.

#2 Updated by Kamil . almost 5 years ago

Default fields can not be disabled for now

Are you going to provide the solution in the future?

#3 Updated by Mischa The Evil almost 5 years ago

Fixed the issue-relationships...

#4 Updated by Jan Ivar Beddari almost 5 years ago

Mischa The Evil wrote:

Fixed the issue-relationships...

Mischa, how about changing or adding to the title of this feature so that it describes the ones it duplicates also, more accurately.. ? I'm thinking a solution to this is more general than disabling the default ticket fields?

#5 Updated by Jan Ivar Beddari almost 5 years ago

Sorry, I see now that this is related to #703 and together these are enough. Feel free to remove/delete these non-productive comments :)

#6 Updated by mythos mint about 4 years ago

+1

#7 Updated by Elmer Thomas almost 4 years ago

+1

#8 Updated by James Brown almost 4 years ago

+1

I need to have a new issues interface that can be used by external parties. I don't want them to be able to see the "Assigned to" or "Due date" etc fields.

I am running 1.0.5 and I made the following changes to redmine/app/views/issues/_form.rhtml
-------------------------------------------------------------------------------
24,26c24,28
< <div id="attributes" class="attributes">
< <%= render :partial => 'issues/attributes' %>
< </div>
---

<% if User.current.roles_for_project(@project).length != 1 || User.current.roles_for_project(@project)[0].name != "Reporter" >
<div id="attributes" class="attributes">
<
= render :partial => 'issues/attributes' >
</div>
<
end %>


This will render the issue attributes IF AND ONLY IF the user is a "Reporter" role. This will also remove access to any custom fields.
It is a quick and VERY dirty hack but it is enough to keep me going until this issue is solved.

#9 Updated by Terence Mill almost 4 years ago

+1

#10 Updated by Amit Ben Shahar almost 4 years ago

+1

#11 Updated by Daniel Thornton over 3 years ago

+1

#12 Updated by Kurt Hilsmeier over 3 years ago

This capability would be huge.

#13 Updated by Terence Mill over 3 years ago

I openeda feature request a time ago, which will include all this kind of field configuration.

See here Issue #8050

#14 Updated by Joshua Stein over 3 years ago

+1

#15 Updated by Aidin Abedi over 3 years ago

+1

#16 Updated by Olivier Pierard over 3 years ago

+1

#17 Updated by Julien Purjuju over 3 years ago

+1

#18 Updated by Chris Lockwood about 3 years ago

+1

#19 Updated by Damien Brugne about 3 years ago

+1

#21 Updated by Glauber Matos almost 3 years ago

+1

#22 Updated by Sebastián Lara almost 3 years ago

+1

#23 Updated by Julien Purjuju almost 3 years ago

+1

#24 Updated by Roman E. over 2 years ago

+1

#25 Updated by Terence Mill over 2 years ago

duplicate of #8050

#26 Updated by Rabbit Seagraves over 2 years ago

+1

#27 Updated by Ben Flaumenhaft over 2 years ago

+1 !!!!!!!!!!

#28 Updated by Lev D over 2 years ago

+1 Yes, indeed!

No reason not to include this feature. Arranging the form to your liking would also be quite useful. Right now, I added 4 extra fields and my eyes are already jumping around the form looking for the the ones I need to fill in and for those I want to skip.

#29 Updated by Jean-Philippe Lang over 2 years ago

  • File standard_fields.png added
  • Subject changed from Disabling default ticket fields to Disabling default ticket fields per tracker
  • Status changed from New to Closed
  • Assignee set to Jean-Philippe Lang
  • Target version set to 2.1.0
  • Resolution set to Fixed

Feature added in r9912. You can now disable regular fields on the tracker form:

#30 Updated by Terence Mill over 2 years ago

That's required in issue #8417

+1 Yes, indeed!

No reason not to include this feature. Arranging the form to your liking would also be quite useful. Right now, I added 4 extra fields and my eyes are already jumping around the form looking for the the ones I need to fill in and for those I want to skip.

#31 Updated by joseph john about 2 years ago

IS this feature also will be enabled on the 1.4 world?

#32 Updated by Bruno Medeiros about 2 years ago

joseph john wrote:

IS this feature also will be enabled on the 1.4 world?

Sure not.

#33 Updated by Wan Zhenhuan almost 2 years ago

Why do I still can't disable the "Status/Priority/File attaching/Watchers" field? People wanna add a complete new issue tracker things like meeting/billing/sales...
Badly need to need this feature!

#34 Updated by Daniel Felix almost 2 years ago

Wan Zhenhuan wrote:

Why do I still can't disable the "Status/Priority/File attaching/Watchers" field? People wanna add a complete new issue tracker things like meeting/billing/sales...
Badly need to need this feature!

Well, this could be solved after this patch is applied to the core #12005.

Best regards,
Daniel

#35 Updated by Mischa The Evil over 1 year ago

  • Precedes Defect #14584: Standard fields disabled for certain trackers still appear in email notifications added

#36 Updated by Toshi MARUYAMA about 1 year ago

#37 Updated by Damon Tabb 3 months ago

But the "priority" field still seems permanent. Is there a way to include that in the list of default fields that can be disabled? I have a specific tracker that doesn't need this field and it's causing some mild confusion with issue reporters.

Also available in: Atom PDF