Feature #3967

Ability to define default columns to display based on project

Added by Vitaly Klimov almost 7 years ago. Updated 11 days ago.

Status:ReopenedStart date:2009-10-04
Priority:NormalDue date:
Assignee:Jean-Philippe Lang% Done:

0%

Category:Projects
Target version:-
Resolution:

Description

It would be great if there would be possibility to define default columns to display for each project separately. Right now it is very unconvenient to have one setting for all projects. We have projects for different areas and thus default fields should be different for each area.

BTW, it is idea for plugin. I believe this one would be relatively easy to implement.


Related issues

Related to Redmine - Feature #4015: Make app settings overridable at project level New 2009-10-10
Related to Redmine - Feature #1853: Make Projects truly independent of each other New 2008-09-04
Duplicates Redmine - Feature #1943: Issue list > Column selection independant between projects Closed 2008-09-24
Duplicates Redmine - Feature #2022: Configure issues columns per project Closed 2008-10-11
Duplicates Redmine - Feature #3318: "Issue tracking" on project basis Closed 2009-05-07

History

#1 Updated by Stefaan Ellebaut almost 7 years ago

Any news on this one, this would help us a lot!

#2 Updated by Mischa The Evil almost 7 years ago

+1 from me...

#3 Updated by Mischa The Evil almost 7 years ago

  • Status changed from New to Closed

Closed as a duplicate of #3967.

#4 Updated by Mischa The Evil almost 7 years ago

  • Status changed from Closed to Reopened

Mischa The Evil wrote:

Closed as a duplicate of #3967.

Reverted incorrect closure due to difficult to follow issue relationships.

#5 Updated by Richard Schulte almost 7 years ago

+ 1

I wish I could help, though my RoR dev knowledge is very limited... however, willing to run tests

#6 Updated by Vitaly Klimov over 6 years ago

I have wrote small plugin which implements this feature. Details can be found on the forum: http://www.redmine.org/boards/3/topics/11764

#7 Updated by John Dell about 6 years ago

+1 for this feature. This seems like something that should be a core feature. I will give Vitaly's plugin a try.

#8 Updated by Sebastian Herbermann almost 6 years ago

+1

I really need this to use Redmine for different groups of users!

#9 Updated by Nicklas Westerholm over 5 years ago

+1

I'm in need of this feature as well. Any progress?

#10 Updated by Vitaly Klimov over 5 years ago

Please check latest version of my plugin:

http://www.redmine.org/plugins/redmine_default_columns

I have ability to define filters/columns based on user preferences.

#11 Updated by Ben Asher over 4 years ago

+1
I think this would work a lot better as a core feature. The plugin above (redmine_default_columns) probably doesn't work out of the box with the latest Redmine (currently 1.3.2) anymore (I've patched the plugin a lot). It also breaks some functionality in Redmine 1.3+ (e.g. modal dialog box for CSV export).

#12 Updated by Bruno Passos about 4 years ago

+1 to a core feature as well

#13 Updated by Massimo Rossello over 2 years ago

+1

#14 Updated by Vincent Lizzi over 2 years ago

+1

Every project (for me) needs different defaults for the Issues page. I'm using the default queries per project plugin, but its not intuitive for new users and I'm not sure if it works with the Redmine versions newer than 2.0. This would be helpful to have as a core feature.

This feature could be a new field on the project settings page, possibly labeled "Issues default query" with a dropdown of custom queries defined in the project. The Issues tab would by default open the custom query specified by this setting, or if it is not set then use the global defaults.

#15 Updated by Jānis Rozefelds over 2 years ago

+1!

#16 Updated by Oscar Corsvall over 2 years ago

+1

Would be really great

#17 Updated by Evan Wolf over 2 years ago

I would Love Love Love Love Love Love Love Love this feature! Currently needs a plugin, and my admin will not install it! If this functionality was built in I would kiss the devs. It's the only thing missing from Redmine, from a usability standpoint.

#18 Updated by Hans Bangkok over 2 years ago

+1 ideally for core

or at least get plugin updated

#19 Updated by Enmos Proje over 2 years ago

+1

#20 Updated by Bahri Yardim almost 2 years ago

+1

#21 Updated by Anton Gillert over 1 year ago

+1

#22 Updated by Aron Rotteveel over 1 year ago

+1. This would really improve things a lot.

#23 Updated by Quan VN over 1 year ago

I think this plugins can help
http://www.redmine.org/plugins/redmine_default_custom_query
The desired columns could be set in the query

#24 Updated by Michael Schaefer 3 months ago

+1. that would be very useful!

#25 Updated by regs - about 1 month ago

- seems to be already possible

#26 Updated by Toshi MARUYAMA 11 days ago

regs - wrote:

- seems to be already possible

AFAIK no.

Also available in: Atom PDF