XLS export plugin

Added by Vitaly Klimov over 7 years ago

Up to date plugin page

http://www.redmine.org/plugins/redmine_xls_export

XLS export plugin

With the help of this plugin you can export issues list with all information to XLS file. Also it is possible to export issues with attachments as a ZIP archive.

Requirements

Plugin requires Redmine version 1.3.0 or higher.

Plugin relies on spreadsheet gem for XLS based operations. Please install this gem before running plugin. Also if you want to use attachments export you should install rubyzip gem.

Features

  • Export active or all columns
  • Export issue descriptions
  • Export journal entries - both inline or as separate file per each issue
  • Export relations information
  • Export spent time data
  • List attachments information
  • Export attachments
  • Export watchers
  • Split information by sheets based on grouping criteria
  • Correct formatting and width of worksheet cells

Details

Plugin adds following links with 'XLS export:' prefix at the bottom of the page under 'Also available in' bar:

  • Quick
    One click export to XLS using default export settings from plugin configuration screen
  • Detailed
    Brings up dialog where user can choose export options before export

Installation and Setup

  1. Install spreadsheet gem ('gem install spreadsheet')
  2. Install rubyzip gem if you want to use export attachments feature
  3. Install plugin Plugin views with revisions if you do not have it installed
  4. Follow the Redmine plugin installation steps at: http://www.redmine.org/wiki/redmine/Plugins
  5. Run rake task
    rake redmine:plugins:process_version_change RAILS_ENV=production
  6. Login and configure the plugin (Administration > Plugins > Configure)

Replies (276)

RE: XLS export plugin Dare format - Added by Joji Okuyama about 6 years ago

Hellow.

I want to use Date format in "YYYY/MM/DD". but in the facts , "DD.MM.YYYY" was used in the XLS files.

Can I customize it ?

WS000329.png (5.41 KB)

RE: XLS export plugin Dare format - Added by Joji Okuyama about 6 years ago

Can I customize it ?

Not excel customize, on XLS export plugin's customize.

Joji Okuyama wrote:

Hellow.

I want to use Date format in "YYYY/MM/DD". but in the facts , "DD.MM.YYYY" was used in the XLS files.

Can I customize it ?

RE: XLS export plugin Dare format - Added by Tatsuya Saito about 6 years ago

Hi Joji,

I added function which specifies date format like Excel.
Please try following:
https://github.com/two-pack/redmine_xls_export

Italian translation - Added by Riccardo Rocca about 6 years ago

here it is
Bye

it.yml Magnifier (1.19 KB)

RE: Italian translation - Added by Marco Lima about 6 years ago

Riccardo Rocca wrote:

here it is
Bye

Hi Riccardo,

I previously sent to two-pack (github repo https://github.com/two-pack/redmine_xls_export) a different Italian translation; attached you can see my translation modified using a few suggestions from your it.yml.

If you find useful we can merge the two locales in order to have only one 'official' Italian locale. Let me know for any suggestion about it.

Best regards.

it.yml Magnifier (1.36 KB)

RE: XLS export plugin - Added by Ziv Shenhav about 6 years ago

hi,
Using redmine_xls_export plugin ver 0.1.2 on redmine 1.0.5.
I want to export the relations of each issue, so I check Export relations in the global settings.
I don't see "relations" column in the exported file.
Am I missing something? anyone seen this working?
Thanks!
Ziv

RE: XLS export plugin - Added by steven gebbie about 6 years ago

I have just installed a clean Ubuntu, redmine 1.2.1 and this plugin does not work
I have 013 and after migrating the plugins & restarting apache I immediately get an error:

A source file that the application requires, is missing.
Error message:
Could not find RubyGem ruby-ole (>= 1.0)

Any ideas? redmine is going live in 2 weeks & i'd like to have the ability to export

calypso@calypso:~$ gem list

  • LOCAL GEMS ***

actionmailer (2.3.11, 2.3.4)
actionpack (2.3.11, 2.3.4)
activerecord (2.3.11, 2.3.4)
activeresource (2.3.11, 2.3.4)
activesupport (2.3.11, 2.3.4)
cgi_multipart_eof_fix (2.5.0)
choice (0.1.4)
daemon_controller (0.2.6)
daemons (1.1.4)
fastthread (1.0.7)
gem_plugin (0.2.3)
google-spreadsheet-ruby (0.1.5)
i18n (0.4.2)
log4r (1.1.9)
mongrel (1.1.5)
mysql (2.8.1)
nokogiri (1.5.0)
oauth (0.4.5)
passenger (3.0.9)
rack (1.1.2, 1.0.1)
rails (2.3.11, 2.3.4)
rake (0.8.7)
roo (1.10.0)
ruby-ole (1.2.11.2)
rubygems-update (1.8.11)
spreadsheet (0.6.5.9)
todonotes (0.1.0)

RE: XLS export plugin - Added by steven gebbie about 6 years ago

all fixed.
this was a permissions issue on the /var/lib/gems/1.8/ folder.

steven gebbie wrote:

I have just installed a clean Ubuntu, redmine 1.2.1 and this plugin does not work
I have 013 and after migrating the plugins & restarting apache I immediately get an error:

A source file that the application requires, is missing.
Error message:
Could not find RubyGem ruby-ole (>= 1.0)

Any ideas? redmine is going live in 2 weeks & i'd like to have the ability to export

calypso@calypso:~$ gem list

  • LOCAL GEMS ***

actionmailer (2.3.11, 2.3.4)
actionpack (2.3.11, 2.3.4)
activerecord (2.3.11, 2.3.4)
activeresource (2.3.11, 2.3.4)
activesupport (2.3.11, 2.3.4)
cgi_multipart_eof_fix (2.5.0)
choice (0.1.4)
daemon_controller (0.2.6)
daemons (1.1.4)
fastthread (1.0.7)
gem_plugin (0.2.3)
google-spreadsheet-ruby (0.1.5)
i18n (0.4.2)
log4r (1.1.9)
mongrel (1.1.5)
mysql (2.8.1)
nokogiri (1.5.0)
oauth (0.4.5)
passenger (3.0.9)
rack (1.1.2, 1.0.1)
rails (2.3.11, 2.3.4)
rake (0.8.7)
roo (1.10.0)
ruby-ole (1.2.11.2)
rubygems-update (1.8.11)
spreadsheet (0.6.5.9)
todonotes (0.1.0)

RE: XLS export plugin - Added by Daniel Morgan almost 6 years ago

Hello,

I'm using the latest redmine_xls_export plugin from GitHub with Redmine 1.2.2.
I get the following error when using Quick Export:

TypeError (can't convert false into String):
  spreadsheet (0.6.5.4) lib/spreadsheet/encodings.rb:29:in `iconv'
  spreadsheet (0.6.5.4) lib/spreadsheet/encodings.rb:29:in `internal'
  spreadsheet (0.6.5.4) lib/spreadsheet/excel/writer/biff8.rb:43:in `_unicode_string'
  spreadsheet (0.6.5.4) lib/spreadsheet/excel/writer/biff8.rb:36:in `unicode_string'
  spreadsheet (0.6.5.4) lib/spreadsheet/excel/writer/workbook.rb:377:in `write_formats'
  spreadsheet (0.6.5.4) lib/spreadsheet/excel/writer/workbook.rb:372:in `each'
  spreadsheet (0.6.5.4) lib/spreadsheet/excel/writer/workbook.rb:372:in `write_formats'
  spreadsheet (0.6.5.4) lib/spreadsheet/excel/writer/workbook.rb:423:in `write_from_scratch'
  spreadsheet (0.6.5.4) lib/spreadsheet/excel/writer/workbook.rb:620:in `write_workbook'
  spreadsheet (0.6.5.4) lib/spreadsheet/writer.rb:12:in `write'
  spreadsheet (0.6.5.4) lib/spreadsheet/workbook.rb:106:in `write'
  thin (1.3.1) lib/thin/connection.rb:80:in `pre_process'
  thin (1.3.1) lib/thin/connection.rb:78:in `catch'
  thin (1.3.1) lib/thin/connection.rb:78:in `pre_process'
  thin (1.3.1) lib/thin/connection.rb:53:in `process'
  thin (1.3.1) lib/thin/connection.rb:38:in `receive_data'
  C:/Ruby/lib/ruby/gems/1.8/gems/eventmachine-1.0.0.beta.4.1-x86-mingw32/lib/eventmachine.rb:179:in `run_machine'
  C:/Ruby/lib/ruby/gems/1.8/gems/eventmachine-1.0.0.beta.4.1-x86-mingw32/lib/eventmachine.rb:179:in `run'
  thin (1.3.1) lib/thin/backends/base.rb:61:in `start'
  thin (1.3.1) lib/thin/server.rb:159:in `start'
  thin (1.3.1) lib/thin/controllers/controller.rb:86:in `start'
  thin (1.3.1) lib/thin/runner.rb:185:in `send'
  thin (1.3.1) lib/thin/runner.rb:185:in `run_command'
  thin (1.3.1) lib/thin/runner.rb:151:in `run!'
  thin (1.3.1) bin/thin:6
  C:/Ruby/bin/thin:19:in `load'
  C:/Ruby/bin/thin:19

I'm guessing something is failing before the encoding takes place since "false" is being set to be converted.
The strange thing is that Detailed Export does not fail.
Any ideas?

RE: XLS export plugin - Added by Anonymous almost 6 years ago

Hi
I am using latest version of redmine with spent time collumn (https://github.com/MischaTheEvil/redmine_spent_time_column) plugin and after installing xls export plugin spent time column disapeared, could someone had simmilar problem and maybe know solution?

Cheers!

RE: XLS export plugin - Added by Mischa The Evil almost 6 years ago

Szymon Zalewski wrote:

[...] with spent time collumn (https://github.com/MischaTheEvil/redmine_spent_time_column) plugin

I wouldn't recommend using my fork of that plugin, since I don't provide support for it. Especially not now the initial feature of the plugin has been integrated within the Redmine core.

and after installing xls export plugin spent time column disapeared, could someone had simmilar problem and maybe know solution?

That's caused by the fact that both plugins utilize the same API hook. I don't know a simple way to fix this nor I have available time to dive into this any deeper.

RE: XLS export plugin - Added by Daniel Morgan almost 6 years ago

Jens Krämer wrote:

@Daniel here's the fix for the TypeError with Quick Export:

https://github.com/planio-gmbh/redmine_xls_export/commit/b6bfa0113cf19b9d22728ce38fa7f5a28dff5bf1

Thank you for supplying a fix!

On the other hand, there is another issue I've found with the plugin.

In xls_export.rb:

  if issue.children? and sort_parent then
    fmt = Spreadsheet::Format.new :weight => :bold
  else
    fmt = Spreadsheet::Format.new
  end

  issue_columns.each_with_index do |c, j|
    v = if c.is_a?(QueryCustomFieldColumn)

I'm still very much a Ruby newbie, but it seems that a single fmt Object cannot be dynamically set for several Excel cells.
Once the number_format is set, it gets applied to all following cells in the row even when set to a different format.

I made a change to the code:

  issue_columns.each_with_index do |c, j|
    if issue.children? and sort_parent then
      fmt = Spreadsheet::Format.new :weight => :bold
    else
      fmt = Spreadsheet::Format.new
    end
    v = if c.is_a?(QueryCustomFieldColumn)

This created a fmt Object for every cell and resulted in the formats being set correctly for each cell.
However, when exporting 2000+ issues, it took over 50 minutes to process.
The plugin version without format setting took less than 5 minutes to process.

For the time being, I've disabled the format setting portions of the plugin.

RE: XLS export plugin - Added by Vitaly Klimov over 5 years ago

Plugin updated to version 0.1.4 and compatible with the Redmine 1.3.x

Download it from the plugin page: http://www.redmine.org/plugins/redmine_xls_export

Please do remove plugin folder completely before installing new version!

RE: XLS export plugin - Added by Steven Wong over 5 years ago

I tested it in redmine 1.3.1

but unfornately, I found it could not start server...

the error information is

=> Booting Mongrel
=> Rails 2.3.14 application starting on http://0.0.0.0:3000
NOTE: SourceIndex.new(hash) is deprecated; From C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/r
ails/vendor_gem_source_index.rb:100:in `new'.
C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_require': no such f
ile to load -- spreadsheet (MissingSourceFile)
from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.
rb:184:in `require'
from E:/redmine-1.3/vendor/plugins/redmine_xls_export/lib/xls_export.rb:3
from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_requir
e'
from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.
rb:184:in `require'
from E:/redmine-1.3/vendor/plugins/redmine_xls_export/init.rb:5:in `evaluate_init_rb'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:158:in `evaluate_ini
t_rb'
from C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/core_ext/kern
el/reporting.rb:11:in `silence_warnings'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:154:in `evaluate_ini
t_rb'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:48:in `load'
from E:/redmine-1.3/config/../vendor/plugins/engines/lib/engines/plugin.rb:44:in `load'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:38:in `load_p
lugins'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:37:in `each'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:37:in `load_p
lugins'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:369:in `load_plugins'

from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:165:in `process'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `send'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `run'
from E:/redmine-1.3/config/environment.rb:24
from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_requir
e'
from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.
rb:182:in `require'
from C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.
rb:547:in `new_constants_in'
from C:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.
rb:182:in `require'
from C:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/commands/server.rb:84
from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `gem_original_requir
e'
from C:/Ruby187/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from script/server:3

RE: XLS export plugin - Added by Steven Wong over 5 years ago

and this is my enviroment

===================================
Redmine 1.3.1.stable (MySQL)

Ruby version 1.8.7 (i386-mingw32)
RubyGems version 1.7.2
Rack version 1.1
Rails version 2.3.14
Active Record version 2.3.14
Active Resource version 2.3.14
Action Mailer version 2.3.14
Active Support version 2.3.14
Application root E:/redmine-1.3
Environment production
Database adapter mysql
Database schema version 20120220042638

RE: XLS export plugin - Added by Vitaly Klimov over 5 years ago

It seems you do not have spreadsheet gem installed. Please install it before running this plugin.

RE: XLS export plugin - Added by Steven Wong over 5 years ago

Oh, I checked it. Now it's OK.

Nice plugin, Thanks.

RE: XLS export plugin - Added by Sławomir Kaimakami over 5 years ago

Please tell us, how to export issues relations?
Is it working for anybody?

I checked 'export relations' but I don't see any relations column in exported XLS file

RE: XLS export plugin - problems in Redmine 1.4 - Added by Ivan Cenov over 5 years ago

This plugin, version 0.1.4 works correctly in Redmine 1.3.2, however it causes Redmine 1.4 to not start completely. Here is the log:

D:\biz\apps\redmine_trunk>ruby script\server -e production
=> Booting WEBrick
=> Rails 2.3.14 application starting on http://0.0.0.0:3000
d:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require': no such file
 to load -- spreadsheet (MissingSourceFile)
        from d:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require'
        from D:/biz/apps/redmine_trunk/vendor/plugins/redmine_xls_export/lib/xls_export.rb:3
        from d:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:184:in `require'
        from D:/biz/apps/redmine_trunk/vendor/plugins/redmine_xls_export/init.rb:5:in `evaluate_init_rb'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:158:in `evaluate_init_rb'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/core_ext/kernel/reporting.rb:11:i
n `silence_warnings'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:154:in `evaluate_init_rb'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin.rb:48:in `load'
        from D:/biz/apps/redmine_trunk/config/../vendor/plugins/engines/lib/engines/plugin.rb:44:in `load'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:38:in `load_plugins'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:37:in `each'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/plugin/loader.rb:37:in `load_plugins'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:369:in `load_plugins'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:165:in `process'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `send'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/initializer.rb:113:in `run'
        from D:/biz/apps/redmine_trunk/config/environment.rb:21
        from d:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:547:in `new_const
ants_in'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/activesupport-2.3.14/lib/active_support/dependencies.rb:182:in `require'
        from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/commands/server.rb:84
        from script/server:3:in `require'
        from script/server:3

D:\biz\apps\redmine_trunk>bundle install --without development test rmagick
Using rake (0.9.2.2)
Using activesupport (2.3.14)
Using rack (1.1.3)
Using actionpack (2.3.14)
Using actionmailer (2.3.14)
Using activerecord (2.3.14)
Using activeresource (2.3.14)
Using coderay (1.0.6)
Using fastercsv (1.5.4)
Using i18n (0.4.2)
Using mysql (2.8.1)
Using net-ldap (0.3.1)
Using pg (0.11.0)
Using rails (2.3.14)
Using ruby-openid (2.1.8)
Using sqlite3 (1.3.5)
Using tzinfo (0.3.31)
Using bundler (1.1.3)
Your bundle is complete! Use `bundle show [gemname]` to see where a bundled gem is installed.

List of installed gems (we can see that spreadsheet gem is installed, Redmine 1.3.2 loads it.):
D:\biz\apps\redmine_1_3_stable>gem list --local

*** LOCAL GEMS ***

actionmailer (3.2.3, 3.1.3, 2.3.14)
actionpack (3.2.3, 3.1.3, 2.3.14)
activemodel (3.2.3, 3.1.3)
activerecord (3.2.3, 3.1.3, 2.3.14)
activeresource (3.2.3, 3.1.3, 2.3.14)
activesupport (3.2.3, 3.1.3, 2.3.14)
acts-as-taggable-on (2.1.1)
arel (3.0.2, 2.2.1)
builder (3.0.0)
bundler (1.1.3, 1.0.22)
coderay (1.0.6, 1.0.5)
edavis10-object_daddy (0.4.3)
erubis (2.7.0)
fastercsv (1.5.4)
highline (1.5.2)
hike (1.2.1)
htauth (1.0.3)
i18n (0.6.0, 0.4.2)
journey (1.0.3)
json_pure (1.6.5)
mail (2.4.4, 2.3.0)
mime-types (1.17.2)
multi_json (1.0.4)
mysql (2.8.1 x86-mingw32)
net-ldap (0.3.1)
pg (0.11.0 x86-mingw32, 0.9.0 x86-mingw32)
polyglot (0.3.3)
rack (1.4.1, 1.3.6, 1.1.3, 1.1.2)
rack-cache (1.2, 1.1)
rack-mount (0.8.3)
rack-ssl (1.3.2)
rack-test (0.6.1)
rails (3.2.3, 2.3.14)
rake (0.9.2.2)
rbx-require-relative (0.0.9)
ruby-debug-ide (0.4.17.beta8)
ruby-graphviz (1.0.5)
ruby-ole (1.2.11.2)
ruby-openid (2.1.8)
rubyrep (1.2.0)
spreadsheet (0.6.8)
sprockets (2.1.2, 2.0.3)
sqlite3 (1.3.5 x86-mingw32)
thor (0.14.6)
tilt (1.3.3)
treetop (1.4.10)
tzinfo (0.3.32, 0.3.31)

RE: XLS export plugin - Added by Ivan Cenov over 5 years ago

Above problem is because of bundler is introduced in Redmine 1.4. The same as with mongrel.

spreadsheet gem must be included Gemfile.local:

gem "spreadsheet" 

I don't know if the following is related to this plugin so I post it here for information, if it is related:
D:\biz\apps\redmine_trunk>ruby script\server -e production
=> Booting WEBrick
=> Rails 2.3.14 application starting on http://0.0.0.0:3000
NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
Gem.source_index called from d:/Ruby187/lib/ruby/gems/1.8/gems/rails-2.3.14/lib/rails/gem_dependency.rb:21.
=> Call with -d to detach
=> Ctrl-C to shutdown server
[2012-04-15 14:47:38] INFO  WEBrick 1.3.1
[2012-04-15 14:47:38] INFO  ruby 1.8.7 (2010-08-16) [i386-mingw32]
[2012-04-15 14:47:38] INFO  WEBrick::HTTPServer#start: pid=804 port=3000

RE: XLS export plugin - Added by Karel Pičman over 5 years ago

Vitaly Klimov wrote:

Karel, thank you for the patch, i will integrate it into next release of the plugin

Vitaly,
Why you haven't included export_history.patch providing issue history options into the new release v014?

RE: XLS export plugin - Added by Bhavin Shah over 5 years ago

Hi Vitaly,

I am running Redmine 1.3.2. Your Plugin is working cool.

Need some help. I am working on my plugin where i have created index page with one of the tracker items. I want those details to be exported in XLS format.

Can you guide me how can i do that using your plugin?

Thanks,
Bhavin

RE: XLS export plugin - Added by Vitaly Klimov over 5 years ago

Bhavin Shah wrote:

Hi Vitaly,

I am running Redmine 1.3.2. Your Plugin is working cool.

Need some help. I am working on my plugin where i have created index page with one of the tracker items. I want those details to be exported in XLS format.

Can you guide me how can i do that using your plugin?

There are two ways you can do it, depending on how you made those extra issue details appear. If you organized your data as a extra column in Redmine, you have to do nothing, otherwise you may look in the lib/xls_export.rb file and create your own custom column class and add it before export.

RE: XLS export plugin - Added by Vitaly Klimov over 5 years ago

Karel Picman wrote:

Vitaly,
Why you haven't included export_history.patch providing issue history options into the new release v014?

I do sorry about that - it has slipped my attention. I will try to include it in the next release, i promise :)

1 ... 4 5 6 7 8 ... 12 (126-150/276)