Project

General

Profile

Actions

Feature #2585

open

Add Modules to hide/display Overview, Activity, Roadmap

Added by Ben Blanco over 15 years ago. Updated about 3 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Projects
Target version:
-
Start date:
2009-01-26
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

When opening Projects to clients, in some cases one may not want to display Activity or Overview. The Project Settings' Modules covers most of a Project's tabs, but not:

  • Overview
  • Activity
  • Roadmap

Could tick boxes be added here, so that Admins can 100% customize the look & feel of each project according to its requirements (confidentiality, etc..).


Files

Project_Settings_Modules.png (22.7 KB) Project_Settings_Modules.png Ben Blanco, 2009-01-26 12:15

Related issues

Related to Redmine - Defect #27902: Overview page is very slow for private projects with large number of membersNew

Actions
Has duplicate Redmine - Feature #9930: Removable Overview / Activity menusClosed

Actions
Has duplicate Redmine - Feature #4955: How to simplify the interface as much as possibleClosed2010-03-01

Actions
Has duplicate Redmine - Feature #34881: Activity page blockClosed

Actions
Actions #1

Updated by Ben Blanco over 15 years ago

Screenshot of currently available Modules:

Actions #2

Updated by colin moock over 15 years ago

+1

Actions #3

Updated by Sami Isomäki about 15 years ago

+1

Actions #4

Updated by Ali Entezari over 14 years ago

+1

Actions #5

Updated by Ali Entezari about 14 years ago

To Hide Activity Tab, remove the following line from redmine\lib\redmine.rb
menu.push :help, Redmine::Info.help_url, :last => true

Actions #6

Updated by Ali Entezari about 14 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
Actions #7

Updated by Jean-Philippe Lang about 14 years ago

  • Status changed from Resolved to New
  • % Done changed from 100 to 0

This is not resolved. Hiding the links won't disable the views.

Actions #8

Updated by Davide Setti over 13 years ago

+1

Actions #9

Updated by Matthias Michelsburg over 13 years ago

+1

Actions #10

Updated by Joshua Villagomez over 13 years ago

I too would like to see this feature added.

Actions #11

Updated by Bernd Vogt almost 13 years ago

+1

Actions #12

Updated by Aidin Abedi almost 13 years ago

+1

Actions #13

Updated by Aidin Abedi almost 13 years ago

I just tried a this module plugin for Activity with my redmine 1.2.1 and it works! https://github.com/finnlabs/redmine_activity_module

I then tried to copy it and rewrite it for Roadmap but the copy doesn't play nice with the original so I can't make them work simultaneously.

Actions #14

Updated by Terence Mill almost 13 years ago

There is the plugin redmine blocks which can show hide elemnts on overview page.
The Roadmap shall be sparated from issue module in core
+1

Actions #15

Updated by Line Bourdages over 12 years ago

+1

Actions #16

Updated by Terence Mill over 12 years ago

+1

Actions #17

Updated by llorbinshane aifseng over 12 years ago

  • Assignee set to Maxim Krušina
Actions #18

Updated by Etienne Massip over 12 years ago

  • Assignee deleted (Maxim Krušina)
Actions #19

Updated by Dimitri Sapunou over 11 years ago

+1

Actions #20

Updated by Arthur Zalevsky over 11 years ago

Same here. Is it possible to implement this feature in Redmine 2.*?

Actions #21

Updated by Pawel Orzechowski over 11 years ago

+1

Actions #22

Updated by Vitaliy Shestunov almost 11 years ago

+1

Actions #23

Updated by Bishoy Medhat almost 11 years ago

+1

Actions #24

Updated by Daniel Felix almost 11 years ago

Another idea could be to define permissions to disable this items for certain usergroups.

Actions #25

Updated by Muditha Jayawardana about 10 years ago

Is there any plugging or a patch to do this.
hide overview and road map module for specific role.

Actions #26

Updated by Vinicius Ferreira about 10 years ago

+1

Actions #27

Updated by F Abu-Nimeh about 10 years ago

+1

Actions #28

Updated by Daniel Felix about 10 years ago

Hi there,

if I'm not too wrong, this could already be done. If you remove the rights to see the activities and so on for a special role, the user won't see the menu item, doesn't it?

Actions #29

Updated by Daniel Felix about 10 years ago

Yes I'm wrong. The Activity is displayed at all. But the Gantt and the roadmap should be hidden if there were insufficient rights. Maybe this could be solved via a simple additional right "can see activity"?

Actions #30

Updated by Heinrich Danderfer almost 10 years ago

+1

Actions #32

Updated by Go MAEDA over 9 years ago

  • Has duplicate Feature #4955: How to simplify the interface as much as possible added
Actions #33

Updated by David Nielsen over 9 years ago

+1

Actions #34

Updated by Cédric Brancourt over 9 years ago

Well I can provide easy instructions to disable some menu items.

It can be used in plugins:

  Redmine::MenuManager.map(:project_menu).delete(:activity)

Redmine is easy to extend and customize through plugins avoid temptation to edit it's files and write plugin instead ! This way you can follow versions.

A plugin that disable the activity tab is a single file plugin :

# plugins/disable_activity/init.rb

Redmine::Plugin.register :disable_activity do

  name 'Disable Activity'
  author 'Cedric Brancourt'
  version '0.0.1'
  description 'Disable activity tab'

  Redmine::MenuManager.map(:project_menu).delete(:activity)
end


And you're done.
Actions #35

Updated by Cédric Brancourt over 9 years ago

By the way if you wish to forbid access to activities this can be a 2 files plugin :

# plugins/disable_activity/init.rb

require 'activities_controller_override'

Redmine::Plugin.register :disable_activity do

  name 'Disable Activity'
  author 'Cedric Brancourt'
  version '0.0.1'
  description 'Disable activity tab'

  Redmine::MenuManager.map(:project_menu).delete(:activity)

  permission :view_activities, custom_activities: :index
  ActivitiesController.send(:include, ActivitiesControllerOverride)

end

# plugins/disable_activities/lib/activities_controller_override

module ActivitiesControllerOverride
  def self.included(activity_controller)
    activity_controller.send(:include, InstanceMethods)
    activity_controller.class_eval do
      alias_method_chain :index, :custom_authorize
    end
  end

  module InstanceMethods
    def index_with_custom_authorize
      authorize :custom_activities, :index, false
      index_without_custom_authorize
    end
  end

end

Actions #36

Updated by 4wk_ _ about 9 years ago

Really need this feature without plugin (cause it hide it for everyone / for every project) : just another checkbox on the admin panel !
+1

Actions #37

Updated by Subash Manickam almost 9 years ago

Yes I am looking the same kind of functionality for Clients, So giving a checkbox "Show Overview Tab" on User roles would be great

Actions #38

Updated by Tomohisa Kusukawa almost 9 years ago

+1

Actions #39

Updated by Mathieu Hicauber almost 9 years ago

+1

Actions #40

Updated by Yaroslav Lavitskas over 8 years ago

+1

Actions #41

Updated by Filip Sabo over 8 years ago

+1

Actions #42

Updated by Donald Martin about 8 years ago

+1

Actions #43

Updated by Donald Martin about 8 years ago

Otherwise if it can't be an option per project to remove overview I'd like to be able to change the default page per project. If you go to a project, on some I'd like to go straight to issues on others I'd like to go straight to Documents - etc etc

Actions #44

Updated by Leszek Koltunski about 8 years ago

+1. Come on guys - can we have this implemented?

Actions #45

Updated by Robert Redl almost 8 years ago

Cédric Brancourt wrote:

Well I can provide easy instructions to disable some menu items.

It can be used in plugins:

[...]

Redmine is easy to extend and customize through plugins avoid temptation to edit it's files and write plugin instead ! This way you can follow versions.

A plugin that disable the activity tab is a single file plugin :

[...]
And you're done.

This method works very well for the activity page, but how to remove the Overview?

Actions #46

Updated by George Notaras almost 8 years ago

I needed to minimize the amount of public web pages generated by Redmine so as to reduce the load on the server when the application is hit by bots. The goal is to keep only the overview/wiki/files tabs publicly available per project, since they are the only ones that are actually used.

I did a quick test with the plugin code posted above and it seems to work. The Activity page redirects to the login page. However, there are still some issues with the activity Atom feeds:

1) The feed for the overall activity returns a 500 error. The following errors are recorded in the log:

AbstractController::DoubleRenderError (Render and/or redirect were called multiple times in this action. Please note that you may only call render OR redirect, and at most once per action. Also note that neither redirect nor render terminate execution of the action, so if you want to exit an action after redirecting, you need to do something like "redirect_to(...) and return".):
  app/controllers/application_controller.rb:526:in `render_feed'
  app/controllers/activities_controller.rb:71:in `block (2 levels) in index'
  app/controllers/activities_controller.rb:59:in `index'
  plugins/disable_activity/lib/activities_controller_override.rb:13:in `index_with_custom_authorize'
  lib/redmine/sudo_mode.rb:63:in `sudo_mode'

AbstractController::DoubleRenderError (Render and/or redirect were called multiple times in this action. Please note that you may only call render OR redirect, and at most once per action. Also note that neither redirect nor render terminate execution of the action, so if you want to exit an action after redirecting, you need to do something like "redirect_to(...) and return".):
  app/controllers/application_controller.rb:526:in `render_feed'
  app/controllers/activities_controller.rb:71:in `block (2 levels) in index'
  app/controllers/activities_controller.rb:59:in `index'
  plugins/disable_activity/lib/activities_controller_override.rb:13:in `index_with_custom_authorize'
  lib/redmine/sudo_mode.rb:63:in `sudo_mode'

2) The activity feed of each individual project continues to work as if the Activity page was publicly available.

In my opinion the expected behavior regarding both types of activity feeds (overall & per project) would be to redirect to the login screen, like it happens with the activity pages.

Any ideas about how to address the above issues are very welcome.

Update: +1 for the implementation of this feature in the Redmine core.

Actions #47

Updated by luigifab ! over 7 years ago

+10 :)

Actions #48

Updated by Jules Bowie almost 7 years ago

+1

- want to disable the overview and activity for a 'read-only' project that has a wiki and news modules. I don't want users to see other members' names (except for those with edit rights)

Actions #49

Updated by simon butcher over 6 years ago

for private projects, the users are shown on the overview page as members. when you have 3000+ members this slows everything down hideously when viewing overview page. an option to hide overview would be good.

Actions #50

Updated by Toshi MARUYAMA over 6 years ago

  • Related to Defect #27902: Overview page is very slow for private projects with large number of members added
Actions #51

Updated by Aleksandar Pavic almost 4 years ago

+1

Actions #52

Updated by Go MAEDA over 3 years ago

Actions #53

Updated by Alexandr Chernyaev about 3 years ago

+1

Actions

Also available in: Atom PDF