Defect #26853

Fix hardcoded project-index width for webkit and mozilla browsers

Added by Ilya Malahovskiy about 4 years ago. Updated almost 3 years ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Projects
Target version:-
Resolution:Fixed Affected version:

Fix_hardcoded_project-index-width.diff Magnifier (634 Bytes) Ilya Malahovskiy, 2017-09-07 13:55

before.png (11.8 KB) Toshi MARUYAMA, 2017-09-07 18:04

after.png (13.2 KB) Toshi MARUYAMA, 2017-09-07 18:04

redmine_before.png - Before fix (47.6 KB) Ilya Malahovskiy, 2017-09-25 13:20

redmine_after.png - After fix (44.7 KB) Ilya Malahovskiy, 2017-09-25 13:21


Related issues

Related to Redmine - Feature #26494: Add ability to enable\disable multiple columns on project... Closed
Related to Redmine - Defect #28708: Project display should have text belonging to project in ... Closed
Related to Redmine - Feature #29482: Query system for Projects page Closed
Related to Redmine - Patch #29951: Quick design fix/proposals for projects index page Closed
Duplicated by Redmine - Defect #27174: Projects page show incorrect format when I use firefox an... Closed
Duplicated by Redmine - Defect #27399: Issue in project list Closed
Duplicated by Redmine - Defect #27556: Changes in the project view, the information is displayed... Closed
Duplicated by Redmine - Defect #27558: Project view looks like is a bug in v3.4.3 Closed
Duplicated by Redmine - Defect #28005: Broken Project page Closed
Duplicated by Redmine - Feature #28473: Using the classical 'list' view on projects Closed
Duplicated by Redmine - Defect #28122: Organization of Projects Closed

History

#1 Updated by Toshi MARUYAMA about 4 years ago

Please explain why you need your change.
And your change breaks project list on multiple columns introduced by r15910.

before

after

#2 Updated by Ilya Malahovskiy about 4 years ago

Please add descriptions to projects and check this page on hight resolution(1080p for example), and you will see the problem.

#3 Updated by Ilya Malahovskiy about 4 years ago

Before

After

#4 Updated by Toshi MARUYAMA about 4 years ago

Why do you keep "column-width: 400px;"?

#5 Updated by Ilya Malahovskiy about 4 years ago

Please view diff file. In source code "400px", I changed it to auto.
What are you do not understand?

#6 Updated by Toshi MARUYAMA about 4 years ago

You changed "-webkit-column-width:" and "-moz-column-width:" but not "column-width:".

#7 Updated by Ilya Malahovskiy about 4 years ago

I tried to change "column-width:", but it is not affected on this issue. May be it affect on old browsers, I do not know for what it. Or may be it affect on mobile view.

#8 Updated by Ilya Malahovskiy about 4 years ago

What information do you need?

#9 Updated by Toshi MARUYAMA about 4 years ago

  • Duplicated by Defect #27174: Projects page show incorrect format when I use firefox and use bitnami Version 3.4.2-4 redmine setup. added

#10 Updated by Toshi MARUYAMA almost 4 years ago

Ilya Malahovskiy wrote:

What information do you need?

Did you try Windows IE and Edge?

#11 Updated by Toshi MARUYAMA almost 4 years ago

#12 Updated by Marius BALTEANU almost 4 years ago

  • Duplicated by Defect #27556: Changes in the project view, the information is displayed in the form of columns. added

#13 Updated by Marius BALTEANU almost 4 years ago

  • Duplicated by Defect #27558: Project view looks like is a bug in v3.4.3 added

#14 Updated by Toshi MARUYAMA almost 4 years ago

#15 Updated by Isaiah Lim almost 4 years ago

Got the same issue on a fresh install of v3.4.4-stable on Raspbian.

Anyway, here is my $0.02, after analyzing and playing with it.
This feature works as intended when the 'Projects' page is heavily populated with content. An example would be: https://www.r-labs.org/projects
But for a page that has a few projects/sub-projects, when the descriptions are split into multiple columns, it looks really ugly.
Is there a way to only split the content into columns if the browser height is exceeded?

Another alternative is to add an option to enable/disable columns?

#16 Updated by Mischa The Evil over 3 years ago

  • Related to Feature #26494: Add ability to enable\disable multiple columns on project list page added

#17 Updated by Go MAEDA over 3 years ago

  • Duplicated by Feature #28473: Using the classical 'list' view on projects added

#18 Updated by Go MAEDA over 3 years ago

  • Related to Defect #28708: Project display should have text belonging to project in same column added

#19 Updated by Marius BALTEANU about 3 years ago

#20 Updated by Marius BALTEANU almost 3 years ago

  • Related to Patch #29951: Quick design fix/proposals for projects index page added

#21 Updated by Marius BALTEANU almost 3 years ago

I've added some design proposals for the projects page in #29951.

#22 Updated by Marius BALTEANU almost 3 years ago

#23 Updated by Marius BALTEANU almost 3 years ago

  • Tracker changed from Patch to Defect
  • Status changed from Needs feedback to Closed
  • Resolution set to Fixed

This problem was fixed in latest Redmine versions (3.4.8 and 4.0.1), please see #29951 for more details. Now root projects with their subprojects are shown in their own box without breaking on multiple columns. Any feedback is welcome regarding the new projects page design.

In #29482 we discuss the possibility to let users to chose the view (between the current projects page with multi columns and classical table list), please watch that ticket for updates.

I'll close this issue because I think the root problem was fixed, please reopen if I'm wrong.

Also available in: Atom PDF