Project

General

Profile

Actions

Feature #883

closed

Add suport for mobile devices (CSS)

Added by Maxim Krušina about 16 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
UI
Target version:
-
Start date:
2008-03-17
Due date:
% Done:

0%

Estimated time:
Resolution:
Duplicate

Description

Add basic support for mobile devices. This can be done easily by creating special version of CSS dedicated for mobile devices like phones, PDAs, etc.

When on-the-go (stucked in the tram in traffic jam :), I'm using my PDA phone to solve some business, especially creating new tickets from client's emails. Redmine works in Pocket IE or Opera (preferred), but special light-weight CSS optimized for mobiles would be very appreciated.

Anyone else interested? I'm total lamer in Ruby, but I can try to modify CSS.


Files


Related issues

Has duplicate Redmine - Feature #1277: Add iPhone specific viewClosed2008-05-21

Actions
Is duplicate of Redmine - Feature #19097: Responsive layout for mobile devicesClosedJean-Philippe Lang

Actions
Actions #1

Updated by Mathias S about 16 years ago

I like the idea a lot as well. I'm no Ruby-Coder either but would be glad to support the CSS-Tasks as soon as I have time.

Actions #2

Updated by Maxim Krušina about 16 years ago

I can't assign ticket to me, here, but we're starting to create Mobile CSS, hurrah!

Actions #3

Updated by Maxim Krušina about 16 years ago

  • Status changed from New to 7
  • Assignee set to Maxim Krušina
Actions #4

Updated by Tobias Sturesson almost 15 years ago

Are there any news on this?
Would be a really exciting feature!!!

Actions #5

Updated by Oleg Lozinskij almost 14 years ago

+1

Actions #6

Updated by Fernando Hartmann about 13 years ago

+1

Actions #7

Updated by John Bigler about 13 years ago

Any news ? I'm longing for this ;-)

Actions #8

Updated by Aleksey Dubov over 12 years ago

+1

Actions #9

Updated by Terence Mill over 12 years ago

here some plugins:

Actions #10

Updated by Simen Endsjø over 12 years ago

Any updates here?

Actions #11

Updated by Predrag Radovic about 12 years ago

Very basic (font-size) patches for handheld CSS (like Kindle Touch) are attached.

Actions #12

Updated by Fabio Vasco about 12 years ago

+1

Any update?

Actions #13

Updated by Raphael Kallensee over 11 years ago

I think the best option would be to make the default theme more responsive (in sense of Responsive Webdesign). This shouldn't be too much work, but require some template/CSS/JS changes.

A great first step is the "Redmine Responsive Design Theme" from Xander Dumaine. He described it in a blog post and he has a Redmine project where the sources can be found (his Redmine installation also uses his theme, so you can try it out over there).

Actions #14

Updated by Jean-Philippe Lang about 11 years ago

  • Status changed from 7 to New
  • Assignee deleted (Maxim Krušina)
Actions #15

Updated by Daniel Felix about 11 years ago

A newer approach to solve this, would be the usage of media queries.
With this technology, there's a good way to customize the display of Redmine depending on the window width.

This implementation won't be easy, as there are many rules which needs to be tweaked.

Actions #16

Updated by Maxime Vez over 10 years ago

+1 for a native responsive design theme in Redmine, so we can access it from all form factor devices.

Actions #17

Updated by Robert Barnebeck over 10 years ago

+1 Would be great!

Actions #18

Updated by Toshiya TSURU over 10 years ago

+1

Actions #19

Updated by Jonas Halbe over 10 years ago

+1 !

Actions #20

Updated by Anonymous over 10 years ago

+2

Actions #21

Updated by Huang Ruhua about 10 years ago

+1

Actions #23

Updated by Andriy Lesyuk almost 10 years ago

Hi! I added support for the responsive layout to my Red-Andy theme. Please check.

Actions #24

Updated by Toshi MARUYAMA almost 10 years ago

Actions #25

Updated by Jan from Planio www.plan.io about 9 years ago

  • Related to Feature #19097: Responsive layout for mobile devices added
Actions #26

Updated by Toshi MARUYAMA over 8 years ago

  • Status changed from New to Closed
  • Resolution set to Duplicate

Try #19097.

Actions #27

Updated by Toshi MARUYAMA over 8 years ago

  • Related to deleted (Feature #19097: Responsive layout for mobile devices)
Actions #28

Updated by Toshi MARUYAMA over 8 years ago

  • Related to deleted (Feature #13842: Support mobile phone users better)
Actions #29

Updated by Toshi MARUYAMA over 8 years ago

  • Is duplicate of Feature #19097: Responsive layout for mobile devices added
Actions

Also available in: Atom PDF